aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 19:43:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 19:43:45 +0000
commitf7f106c4bee1ba2650fd9d939c53437052fc9f66 (patch)
treed62eea78dfcbbc445cc72237554a751bd7e12803
parentee161386d4cacfa5a6c03f35e393db16494e167c (diff)
downloadports-f7f106c4bee1ba2650fd9d939c53437052fc9f66.tar.gz
ports-f7f106c4bee1ba2650fd9d939c53437052fc9f66.zip
Notes
-rw-r--r--MOVED5
-rw-r--r--net-p2p/transmission-qt/Makefile26
-rw-r--r--net-p2p/transmission/Makefile11
3 files changed, 9 insertions, 33 deletions
diff --git a/MOVED b/MOVED
index 427825a5a76f..842331d52786 100644
--- a/MOVED
+++ b/MOVED
@@ -4079,7 +4079,6 @@ net-p2p/transmission25|net-p2p/transmission|2013-03-09|gtk version is now fine
net-p2p/transmission25-cli|net-p2p/transmission-cli|2013-03-09|gtk version is now fine
net-p2p/transmission25-daemon|net-p2p/transmission-daemon|2013-03-09|gtk version is now fine
net-p2p/transmission25-gtk2|net-p2p/transmission-gtk2|2013-03-09|gtk version is now fine
-net-p2p/transmission25-qt4|net-p2p/transmission-qt4|2013-03-09|gtk version is now fine
www/transmission25-web|www/transmission-web|2013-03-09|gtk version is now fine
net-p2p/transmission-gtk2|net-p2p/transmission-gtk|2013-03-09|Now uses GTK 3
ftp/proma||2013-03-09|Has expired: Broken for more than 6 months
@@ -10279,8 +10278,6 @@ textproc/kibana46|textproc/kibana5|2018-07-10|Has expired: End of Life was 2018-
print/cups-connector|print/cloud-print-connector|2018-07-11|Project renamed upstream
net/wpa_gui|net/wpa_supplicant_gui|2018-07-12|Rename to wpa_supplicant_gui for ease of search
lang/gcc47|lang/gcc6|2018-07-15|Has expired: Unsupported by upstream. Use GCC 6 or newer instead
-net-p2p/transmission-qt4|net-p2p/transmission-qt@qt4|2018-07-15|Moved into flavored version
-net-p2p/transmission-qt5|net-p2p/transmission-qt@qt5|2018-07-15|Moved into flavored version
java/jaf||2018-07-16|Included in JRE since 1.6 version
net/p5-ZConf-Bookmarks||2018-07-16|Has expired: Unmaintained
net/p5-ZConf||2018-07-16|Has expired: Unmaintained
@@ -11679,3 +11676,5 @@ graphics/photivo@qt4||2019-03-16|Qt4 deprecation
graphics/photivo@qt5|graphics/photivo|2019-03-16|Flavor has been removed
archivers/quazip@qt4||2019-03-16|Qt4 deprecation
archivers/quazip@qt5|archivers/quazip|2019-03-16|Flavor has been removed
+net-p2p/transmission@qt4||2019-03-16|Qt4 deprecation
+net-p2p/transmission@qt5|net-p2p/transmission-qt|2019-03-16|Flavor has been removed
diff --git a/net-p2p/transmission-qt/Makefile b/net-p2p/transmission-qt/Makefile
index 6fb8eb8f1eab..4556201fd252 100644
--- a/net-p2p/transmission-qt/Makefile
+++ b/net-p2p/transmission-qt/Makefile
@@ -1,36 +1,18 @@
# $FreeBSD$
-PORTREVISION= 7
-PKGNAMESUFFIX= -${FLAVOR}
+PORTREVISION= 8
+PKGNAMESUFFIX= -qt5
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-FLAVORS= qt5 qt4
-FLAVOR?= ${FLAVORS:[1]}
+CONFLICTS_INSTALL= transmission-qt4
-qt4_CONFLICTS_INSTALL= transmission-qt5
-qt5_CONFLICTS_INSTALL= transmission-qt4
-
-.if ${FLAVOR} == qt4
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE=2019-03-15
-USES= qt:4
-NLS_USES= gettext-runtime:run qt:4
-USE_QT= moc_build linguisttools_build qmake_build rcc_build \
- uic_build corelib dbus gui network xml
-CMAKE_OFF+= USE_QT5
-.endif
-
-.if ${FLAVOR} == qt5
-USES= qt:5
+USES= compiler:c++11-lang qt:5
NLS_USES= gettext-runtime:run qt:5
USE_QT= buildtools_build linguisttools_build qmake_build \
core dbus gui network widgets
CMAKE_ON= USE_QT5
-.endif
-
-USES+= compiler:c++11-lang
MASTERDIR= ${.CURDIR}/../transmission-cli
DESCR= ${.CURDIR}/pkg-descr
diff --git a/net-p2p/transmission/Makefile b/net-p2p/transmission/Makefile
index 5b8a668ad771..30c48a140b8f 100644
--- a/net-p2p/transmission/Makefile
+++ b/net-p2p/transmission/Makefile
@@ -2,7 +2,7 @@
PORTNAME= transmission
DISTVERSION= 2.94
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
MAINTAINER= rigoletto@FreeBSD.org
@@ -13,15 +13,11 @@ LICENSE_COMB= multi
USES= metaport
-OPTIONS_DEFINE= CLI DAEMON GTK WEB
-
-OPTIONS_RADIO= QT
-OPTIONS_RADIO_QT= QT4 QT5
+OPTIONS_DEFINE= CLI DAEMON GTK WEB QT5
CLI_DESC= Command line version
DAEMON_DESC= Daemon version
GTK_DESC= GTK version
-QT4_DESC= Qt4 version
QT5_DESC= Qt5 version
WEB_DESC= Web client
@@ -30,8 +26,7 @@ OPTIONS_DEFAULT= CLI DAEMON GTK QT4 WEB
CLI_RUN_DEPENDS= transmission-cli:net-p2p/transmission-cli
DAEMON_RUN_DEPENDS= transmission-daemon:net-p2p/transmission-daemon
GTK_RUN_DEPENDS= transmission-gtk:net-p2p/transmission-gtk
-QT4_RUN_DEPENDS= transmission-qt:net-p2p/transmission-qt@qt4
-QT5_RUN_DEPENDS= transmission-qt:net-p2p/transmission-qt@qt5
+QT5_RUN_DEPENDS= transmission-qt:net-p2p/transmission-qt
WEB_RUN_DEPENDS= ${DATADIR}/web/index.html:www/transmission-web
.include <bsd.port.mk>