aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-11-28 18:01:19 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-11-28 18:01:19 +0000
commit08f521843d90a19e726862a15ca21b906883ea59 (patch)
treea11f631a69f234abd253dffce464de2f5af7dd74
parent8ec1201f7beea9edae268f7fd4ba116283332659 (diff)
downloadports-08f521843d90a19e726862a15ca21b906883ea59.tar.gz
ports-08f521843d90a19e726862a15ca21b906883ea59.zip
MFH: r518596
net/py-wsproto: Fix runtime dependencies and Python version restriction * Update the RUN_DEPENDS and limit the port to Python 3.6 or newer as the support for Python 2.7 and 3.5 was dropped with the 0.15.0 release. Python 3.6 needs also the devel/py-dataclasses package as an additional dependency to work properly. * Add a "do-test" target while I'm here to make future QA easier. * Bump PORTREVISION for package change. PR: 242025 (related) Approved by: portmgr blanket (runtime fix) Approved by: ports-secteam bugfix blanket
Notes
Notes: svn path=/branches/2019Q4/; revision=518597
-rw-r--r--net/py-wsproto/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/net/py-wsproto/Makefile b/net/py-wsproto/Makefile
index dec4a38d3ac0..1f37fbf28d9c 100644
--- a/net/py-wsproto/Makefile
+++ b/net/py-wsproto/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wsproto
PORTVERSION= 0.15.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,12 +13,21 @@ COMMENT= Sans-IO WebSocket protocol implementation
LICENSE= MIT
-RUN_DEPENDS= ${PY_ENUM34} \
- ${PYTHON_PKGNAMEPREFIX}h11>=0.8.1:net/py-h11@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}h11>=0.8.1:net/py-h11@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3700
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dataclasses>0:devel/py-dataclasses@${PY_FLAVOR}
+.endif
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.post.mk>