aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-04-16 14:50:46 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2018-04-16 14:50:46 +0000
commit1cef8da47043faaf7f7fb7965138e1b35b948eec (patch)
tree6579eb951d28a05550235101c4e42f27ebfa0014
parent625428c73ab7a6de24115b9efed1ff2b2d155176 (diff)
downloadports-1cef8da47043faaf7f7fb7965138e1b35b948eec.tar.gz
ports-1cef8da47043faaf7f7fb7965138e1b35b948eec.zip
Notes
-rw-r--r--biology/Makefile1
-rw-r--r--biology/fastahack/Makefile19
-rw-r--r--biology/fastahack/distinfo3
-rw-r--r--biology/fastahack/files/Makefile62
-rw-r--r--biology/fastahack/pkg-descr7
-rw-r--r--biology/fastahack/pkg-plist7
6 files changed, 99 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 7508cc78b981..88e9aa1a1e54 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -26,6 +26,7 @@
SUBDIR += emboss
SUBDIR += fasta
SUBDIR += fasta3
+ SUBDIR += fastahack
SUBDIR += fastdnaml
SUBDIR += fastool
SUBDIR += fastqc
diff --git a/biology/fastahack/Makefile b/biology/fastahack/Makefile
new file mode 100644
index 000000000000..1fe12a33dabb
--- /dev/null
+++ b/biology/fastahack/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= fastahack
+DISTVERSION= g20160702
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Utility for indexing and sequence extraction from FASTA files
+
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= ekg
+GH_TAGNAME= bbc645f2f7966cb7b44446200c02627c3168b399
+
+MAKEFILE= ${FILESDIR}/Makefile
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/biology/fastahack/distinfo b/biology/fastahack/distinfo
new file mode 100644
index 000000000000..0de12c1b521a
--- /dev/null
+++ b/biology/fastahack/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523600462
+SHA256 (ekg-fastahack-g20160702-bbc645f2f7966cb7b44446200c02627c3168b399_GH0.tar.gz) = dc8ef61765b7720fd2d163143696f1c82251bfd906ac5261642e7230d81d5da6
+SIZE (ekg-fastahack-g20160702-bbc645f2f7966cb7b44446200c02627c3168b399_GH0.tar.gz) = 18200
diff --git a/biology/fastahack/files/Makefile b/biology/fastahack/files/Makefile
new file mode 100644
index 000000000000..3d878de6e14c
--- /dev/null
+++ b/biology/fastahack/files/Makefile
@@ -0,0 +1,62 @@
+
+# Use ?= to allow overriding from the env or command-line, e.g.
+#
+# make CXXFLAGS="-O3 -fPIC" install
+#
+# Package managers will override many of these variables automatically, so
+# this is aimed at making it easy to create packages (Debian packages,
+# FreeBSD ports, MacPorts, pkgsrc, etc.)
+
+CXX ?= c++
+CXXFLAGS ?= -O3
+DESTDIR ?= stage
+PREFIX ?= /usr/local
+STRIP ?= strip
+INSTALL ?= install -c
+MKDIR ?= mkdir -p
+AR ?= ar
+
+# Required flags that we shouldn't override
+# Must be compiler-independent
+CXXFLAGS += -D_FILE_OFFSET_BITS=64
+
+BIN = fastahack
+LIB = libfastahack.a
+OBJS = Fasta.o split.o disorder.o
+MAIN = FastaHack.o
+
+all: $(BIN) $(LIB)
+
+$(BIN): $(OBJS) $(MAIN)
+ $(CXX) $(CXXFLAGS) $(OBJS) $(MAIN) -o $(BIN)
+
+$(LIB): $(OBJS)
+ ${AR} -rs $(LIB) $(OBJS)
+
+FastaHack.o: Fasta.h FastaHack.cpp
+ $(CXX) $(CXXFLAGS) -c FastaHack.cpp
+
+Fasta.o: Fasta.h Fasta.cpp
+ $(CXX) $(CXXFLAGS) -c Fasta.cpp
+
+split.o: split.h split.cpp
+ $(CXX) $(CXXFLAGS) -c split.cpp
+
+disorder.o: disorder.c disorder.h
+ $(CXX) $(CXXFLAGS) -c disorder.c
+
+install: all
+ $(MKDIR) $(DESTDIR)$(PREFIX)/bin
+ $(MKDIR) $(DESTDIR)$(PREFIX)/include/fastahack
+ $(MKDIR) $(DESTDIR)$(PREFIX)/lib
+ $(INSTALL) $(BIN) $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL) *.h $(DESTDIR)$(PREFIX)/include/fastahack
+ $(INSTALL) $(LIB) $(DESTDIR)$(PREFIX)/lib
+
+install-strip: install
+ $(STRIP) $(DESTDIR)$(PREFIX)/bin/$(BIN)
+
+clean:
+ rm -rf $(BIN) $(LIB) $(OBJS) $(DESTDIR)
+
+.PHONY: clean
diff --git a/biology/fastahack/pkg-descr b/biology/fastahack/pkg-descr
new file mode 100644
index 000000000000..c1ca6d3c68cf
--- /dev/null
+++ b/biology/fastahack/pkg-descr
@@ -0,0 +1,7 @@
+Fastahack is a small application for indexing and extracting sequences and
+subsequences from FASTA files. The included Fasta.cpp library provides a FASTA
+reader and indexer that can be embedded into applications which would benefit
+from directly reading subsequences from FASTA files. The library automatically
+handles index file generation and use.
+
+WWW: https://github.com/ekg/fastahack
diff --git a/biology/fastahack/pkg-plist b/biology/fastahack/pkg-plist
new file mode 100644
index 000000000000..99f591c84b84
--- /dev/null
+++ b/biology/fastahack/pkg-plist
@@ -0,0 +1,7 @@
+bin/fastahack
+include/fastahack/Fasta.h
+include/fastahack/LargeFileSupport.h
+include/fastahack/Region.h
+include/fastahack/disorder.h
+include/fastahack/split.h
+lib/libfastahack.a