aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2019-12-09 09:24:14 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2019-12-09 09:24:14 +0000
commit2129081c7e704786e8c017cee8b349a22698395a (patch)
treeeb623d400a63998b934ede7ddc1a6278b53fb602
parent051db9d9bb7e552618c93971e25c96989417b57d (diff)
downloadports-2129081c7e704786e8c017cee8b349a22698395a.tar.gz
ports-2129081c7e704786e8c017cee8b349a22698395a.zip
MFH: r519233 r519241 r519244
Fix namespace pollution in python3.5 and python3.6 (upstreamed fix) The standard math library (libm) may follow IEEE-754 recommendation to include an implementation of sinPi(), i.e. sinPi(x):=sin(pi*x). And this triggers a name clash, found by FreeBSD developer Steve Kargl, who worked on putting sinpi into libm used on FreeBSD (it has to be named "sinpi", not "sinPi", cf. e.g. https://en.cppreference.com/w/c/experimental/fpext4). - python2.7 and > 3.6 are already fixed PR: 232792 Submitted by: Steve Kargl <sgk@troutmask.apl.washington.edu>, Dima Pasechnik <dimpase+freebsd@gmail.com> Approved by: python (maintainer timeout) Obtained from: https://github.com/python/cpython/commit/b545ba0a508a5980ab147ed2641a42be3b31a2db Backport fix of https://bugs.python.org/issue32849 This is needed for starting sysutils/azure-agent at boot: https://github.com/Azure/WALinuxAgent/issues/1687 Obtained from: https://github.com/python/cpython/pull/12852/commits/f9c01a16dae8aa15d264a1937fb589e8598d1c88 Sponsored by: The FreeBSD Foundation Fix makefile ordering. Reported by: mat Approved by: ports-secteam (miwi) Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/branches/2019Q4/; revision=519597
-rw-r--r--lang/python35/Makefile6
-rw-r--r--lang/python35/distinfo4
-rw-r--r--lang/python36/Makefile6
-rw-r--r--lang/python36/distinfo6
4 files changed, 19 insertions, 3 deletions
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index 219ffc27b761..7e793c139642 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -3,13 +3,17 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
DISTNAME= Python-${PORTVERSION}
DIST_SUBDIR= python
+# Resolve sinpi name clash with libm (IEEE-754 violation)
+PATCH_SITES= https://github.com/python/cpython/commit/
+PATCHFILES= f57cd8288dbe6aba99c057f37ad6d58f8db75350.patch:-p1
+
MAINTAINER= python@FreeBSD.org
COMMENT= Interpreted object-oriented programming language
diff --git a/lang/python35/distinfo b/lang/python35/distinfo
index f7713fff2871..c12d9d86b511 100644
--- a/lang/python35/distinfo
+++ b/lang/python35/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1552961810
+TIMESTAMP = 1575745214
SHA256 (python/Python-3.5.7.tar.xz) = 285892899bf4d5737fd08482aa6171c6b2564a45b9102dfacfb72826aebdc7dc
SIZE (python/Python-3.5.7.tar.xz) = 15324736
+SHA256 (python/f57cd8288dbe6aba99c057f37ad6d58f8db75350.patch) = 44340896504b297bbab06db0bb0a71ddf9f25bbe02ab3dcdfeec2772c957b69f
+SIZE (python/f57cd8288dbe6aba99c057f37ad6d58f8db75350.patch) = 2542
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 85aaa4dd1288..2e3eb955e19f 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -3,12 +3,18 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
DISTNAME= Python-${PORTVERSION}
DIST_SUBDIR= python
+# Resolve sinpi name clash with libm (IEEE-754 violation)
+PATCH_SITES= https://github.com/python/cpython/commit/
+PATCHFILES= f57cd8288dbe6aba99c057f37ad6d58f8db75350.patch:-p1 \
+ f9c01a16dae8aa15d264a1937fb589e8598d1c88.patch:-p1
+
MAINTAINER= python@FreeBSD.org
COMMENT= Interpreted object-oriented programming language
diff --git a/lang/python36/distinfo b/lang/python36/distinfo
index 34f0dbffecfa..1cc84ef9ad84 100644
--- a/lang/python36/distinfo
+++ b/lang/python36/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1562110897
+TIMESTAMP = 1575752359
SHA256 (python/Python-3.6.9.tar.xz) = 5e2f5f554e3f8f7f0296f7e73d8600c4e9acbaee6b2555b83206edf5153870da
SIZE (python/Python-3.6.9.tar.xz) = 17212164
+SHA256 (python/f57cd8288dbe6aba99c057f37ad6d58f8db75350.patch) = 44340896504b297bbab06db0bb0a71ddf9f25bbe02ab3dcdfeec2772c957b69f
+SIZE (python/f57cd8288dbe6aba99c057f37ad6d58f8db75350.patch) = 2542
+SHA256 (python/f9c01a16dae8aa15d264a1937fb589e8598d1c88.patch) = a5cf6ef701d6afb14417232c6723fe2c50d7bf35d87bf6b3e3bcbfa1000a38f9
+SIZE (python/f9c01a16dae8aa15d264a1937fb589e8598d1c88.patch) = 2888