aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-03 19:58:37 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-03 19:58:37 +0000
commit28e7e01df0bd11e6445803ff4a8ebd8e3ca712ec (patch)
treee04a4a95d5849381e2b282b3e90796f6b4ae0139
parent931c22e7cb046db5b0a7ecf4c617acac21b1c1d7 (diff)
downloadports-28e7e01df0bd11e6445803ff4a8ebd8e3ca712ec.tar.gz
ports-28e7e01df0bd11e6445803ff4a8ebd8e3ca712ec.zip
Notes
-rw-r--r--editors/focuswriter/Makefile5
-rw-r--r--editors/texworks/files/patch-TeXworks.pro5
-rw-r--r--games/frogatto/files/patch-Makefile13
-rw-r--r--games/tanglet/Makefile9
-rw-r--r--graphics/atril/files/configure.ac22
-rw-r--r--graphics/atril/files/patch-configure149
-rw-r--r--graphics/gthumb/Makefile4
-rw-r--r--multimedia/ogmrip/Makefile3
-rw-r--r--polish/kadu/Makefile2
-rw-r--r--textproc/stardict3/Makefile3
10 files changed, 10 insertions, 205 deletions
diff --git a/editors/focuswriter/Makefile b/editors/focuswriter/Makefile
index ebacf36679c3..11f7a7748799 100644
--- a/editors/focuswriter/Makefile
+++ b/editors/focuswriter/Makefile
@@ -25,8 +25,6 @@ USE_QT5= concurrent core gui multimedia network printsupport widgets \
buildtools_build linguisttools_build
INSTALLS_ICONS= yes
-LIBS+= -lz
-
PORTDATA= *
PORTDOCS= CREDITS NEWS README
@@ -35,8 +33,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e '/PKGCONFIG/s/ zlib// ; \
- /INSTALLS/s/man //' \
+ @${REINPLACE_CMD} -e '/INSTALLS/s/man //' \
${WRKSRC}/focuswriter.pro
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000054
@${REINPLACE_CMD} -e 's/std::lround/lround/g' \
diff --git a/editors/texworks/files/patch-TeXworks.pro b/editors/texworks/files/patch-TeXworks.pro
index a2b6ac58f1b8..b1adfbbfae7a 100644
--- a/editors/texworks/files/patch-TeXworks.pro
+++ b/editors/texworks/files/patch-TeXworks.pro
@@ -1,12 +1,11 @@
--- TeXworks.pro.orig 2015-04-03 18:05:39 UTC
+++ TeXworks.pro
-@@ -108,7 +108,8 @@ unix:!macx { # on Unix-ish platforms we
+@@ -108,7 +108,7 @@ unix:!macx { # on Unix-ish platforms we
CONFIG += link_pkgconfig
PKGCONFIG += hunspell
PKGCONFIG += poppler-qt4
- PKGCONFIG += zlib
-+ PKGCONFIG += synctex
-+ LIBS += -lz
++ PKGCONFIG += synctex zlib
# Enclose the path in \\\" (which later gets expanded to \", which in turn
# gets expanded to " in the c++ code)
diff --git a/games/frogatto/files/patch-Makefile b/games/frogatto/files/patch-Makefile
index 1d6d82bb7289..50294eedbd5d 100644
--- a/games/frogatto/files/patch-Makefile
+++ b/games/frogatto/files/patch-Makefile
@@ -9,7 +9,7 @@
CCACHE?=ccache
USE_CCACHE?=$(shell which $(CCACHE) 2>&1 > /dev/null && echo yes)
ifneq ($(USE_CCACHE),yes)
-@@ -34,14 +34,14 @@ BASE_CXXFLAGS += -O2
+@@ -34,7 +34,7 @@ BASE_CXXFLAGS += -O2
endif
# Initial compiler options, used before CXXFLAGS and CPPFLAGS.
@@ -17,16 +17,7 @@
+BASE_CXXFLAGS += -fno-inline-functions -fthreadsafe-statics -Wnon-virtual-dtor -Werror -Wformat -Wswitch
# Compiler include options, used after CXXFLAGS and CPPFLAGS.
--INC := $(shell pkg-config --cflags x11 sdl glu glew SDL_image libpng zlib)
-+INC := $(shell pkg-config --cflags x11 sdl glu glew SDL_image libpng)
-
- # Linker library options.
- LIBS := $(shell pkg-config --libs x11 ) -lSDLmain \
-- $(shell pkg-config --libs sdl glu glew SDL_image libpng zlib) -lSDL_ttf -lSDL_mixer
-+ $(shell pkg-config --libs sdl glu glew SDL_image libpng) -lz -lSDL_ttf -lSDL_mixer
-
- include Makefile.common
-
+ INC := $(shell pkg-config --cflags x11 sdl glu glew SDL_image libpng zlib)
@@ -60,7 +60,7 @@ game: $(objects)
$(CCACHE) $(CXX) \
$(BASE_CXXFLAGS) $(LDFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(INC) \
diff --git a/games/tanglet/Makefile b/games/tanglet/Makefile
index d0676189df8d..0f333e609de3 100644
--- a/games/tanglet/Makefile
+++ b/games/tanglet/Makefile
@@ -14,17 +14,14 @@ LICENSE= GPLv3+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= compiler:c++11-lib desktop-file-utils qmake shared-mime-info tar:bzip2
+USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake \
+ shared-mime-info tar:bzip2
USE_QT5= buildtools_build linguisttools_build core gui widgets
CXXFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
-D_DECLARE_C99_LDBL_MATH # XXX ports/193528
post-patch:
- @${REINPLACE_CMD} -e \
- '/link_pkgconfig/d ; \
- s|PKGCONFIG|LIBS| ; \
- s|zlib|-lz| ; \
- s|share/man|man|' ${WRKSRC}/tanglet.pro
+ @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/tanglet.pro
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/atril/files/configure.ac b/graphics/atril/files/configure.ac
deleted file mode 100644
index 40de5b0b4b48..000000000000
--- a/graphics/atril/files/configure.ac
+++ /dev/null
@@ -1,22 +0,0 @@
---- configure.ac.orig 2015-09-04 11:33:09.197403000 +0200
-+++ configure.ac 2015-09-04 11:33:38.935108000 +0200
-@@ -697,16 +697,16 @@
- case "$with_gtk" in
- 2.0)
- PKG_CHECK_MODULES(EPUB, webkit-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib,have_webkit=yes,have_webkit=no)
-+ libxml-2.0 >= $LIBXML_REQUIRED ,have_webkit=yes,have_webkit=no)
- ;;
- 3.0)
- PKG_CHECK_MODULES(EPUB, webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib,have_webkit=yes,have_webkit=no)
-+ libxml-2.0 >= $LIBXML_REQUIRED ,have_webkit=yes,have_webkit=no)
- if test "x$have_webkit" = "xno"; then
- AC_MSG_NOTICE([Webkit2 4.0 not found, trying 3.0])
- WEBKIT_API_VERSION=3.0
- PKG_CHECK_MODULES(EPUB, webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib,have_webkit=yes,have_webkit=no)
-+ libxml-2.0 >= $LIBXML_REQUIRED ,have_webkit=yes,have_webkit=no)
- fi
- ;;
- esac
diff --git a/graphics/atril/files/patch-configure b/graphics/atril/files/patch-configure
deleted file mode 100644
index 9dbd4a65fceb..000000000000
--- a/graphics/atril/files/patch-configure
+++ /dev/null
@@ -1,149 +0,0 @@
---- configure.orig 2015-09-04 11:35:11.223593000 +0200
-+++ configure 2015-09-04 11:35:40.650664000 +0200
-@@ -21453,14 +21453,14 @@
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
-- libxml-2.0 >= \$LIBXML_REQUIRED zlib\""; } >&5
-+ libxml-2.0 >= \$LIBXML_REQUIRED \""; } >&5
- ($PKG_CONFIG --exists --print-errors "webkit-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib") 2>&5
-+ libxml-2.0 >= $LIBXML_REQUIRED ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_EPUB_CFLAGS=`$PKG_CONFIG --cflags "webkit-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>/dev/null`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
- pkg_failed=yes
-@@ -21473,14 +21473,14 @@
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
-- libxml-2.0 >= \$LIBXML_REQUIRED zlib\""; } >&5
-+ libxml-2.0 >= \$LIBXML_REQUIRED \""; } >&5
- ($PKG_CONFIG --exists --print-errors "webkit-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib") 2>&5
-+ libxml-2.0 >= $LIBXML_REQUIRED ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_EPUB_LIBS=`$PKG_CONFIG --libs "webkit-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>/dev/null`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
- pkg_failed=yes
-@@ -21502,10 +21502,10 @@
- fi
- if test $_pkg_short_errors_supported = yes; then
- EPUB_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "webkit-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>&1`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>&1`
- else
- EPUB_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "webkit-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>&1`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>&1`
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$EPUB_PKG_ERRORS" >&5
-@@ -21534,14 +21534,14 @@
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit2gtk-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
-- libxml-2.0 >= \$LIBXML_REQUIRED zlib\""; } >&5
-+ libxml-2.0 >= \$LIBXML_REQUIRED \""; } >&5
- ($PKG_CONFIG --exists --print-errors "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib") 2>&5
-+ libxml-2.0 >= $LIBXML_REQUIRED ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_EPUB_CFLAGS=`$PKG_CONFIG --cflags "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>/dev/null`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
- pkg_failed=yes
-@@ -21554,14 +21554,14 @@
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit2gtk-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
-- libxml-2.0 >= \$LIBXML_REQUIRED zlib\""; } >&5
-+ libxml-2.0 >= \$LIBXML_REQUIRED \""; } >&5
- ($PKG_CONFIG --exists --print-errors "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib") 2>&5
-+ libxml-2.0 >= $LIBXML_REQUIRED ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_EPUB_LIBS=`$PKG_CONFIG --libs "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>/dev/null`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
- pkg_failed=yes
-@@ -21583,10 +21583,10 @@
- fi
- if test $_pkg_short_errors_supported = yes; then
- EPUB_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>&1`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>&1`
- else
- EPUB_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>&1`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>&1`
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$EPUB_PKG_ERRORS" >&5
-@@ -21617,14 +21617,14 @@
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit2gtk-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
-- libxml-2.0 >= \$LIBXML_REQUIRED zlib\""; } >&5
-+ libxml-2.0 >= \$LIBXML_REQUIRED \""; } >&5
- ($PKG_CONFIG --exists --print-errors "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib") 2>&5
-+ libxml-2.0 >= $LIBXML_REQUIRED ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_EPUB_CFLAGS=`$PKG_CONFIG --cflags "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>/dev/null`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
- pkg_failed=yes
-@@ -21637,14 +21637,14 @@
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit2gtk-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
-- libxml-2.0 >= \$LIBXML_REQUIRED zlib\""; } >&5
-+ libxml-2.0 >= \$LIBXML_REQUIRED \""; } >&5
- ($PKG_CONFIG --exists --print-errors "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib") 2>&5
-+ libxml-2.0 >= $LIBXML_REQUIRED ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_EPUB_LIBS=`$PKG_CONFIG --libs "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>/dev/null`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
- pkg_failed=yes
-@@ -21666,10 +21666,10 @@
- fi
- if test $_pkg_short_errors_supported = yes; then
- EPUB_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>&1`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>&1`
- else
- EPUB_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
-- libxml-2.0 >= $LIBXML_REQUIRED zlib" 2>&1`
-+ libxml-2.0 >= $LIBXML_REQUIRED " 2>&1`
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$EPUB_PKG_ERRORS" >&5
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index 9daed793d800..cf44c9bbde09 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -94,8 +94,6 @@ YELP_DESC= Viewer for built-in help system
YELP_RUN_DEPENDS= yelp:x11/yelp
post-patch:
- @${REINPLACE_CMD} -e \
- 's|-Wl,--as-needed|| ; \
- /^[[:blank:]]zlib/d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-Wl,--as-needed||' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index ea1757b42721..b3f06bebd427 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -136,8 +136,7 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e '/local/s|^CFLAGS=|#CFLAGS=|g ; \
/local/s|^CPPFLAGS=|#CPPFLAGS=|g ; \
- /local/s|^LDFLAGS=|#LDFLAGS=|g ; \
- s|libpng zlib|libpng|g' ${WRKSRC}/configure
+ /local/s|^LDFLAGS=|#LDFLAGS=|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|^SUBDIRS|#SUBDIRS|g' ${WRKSRC}/docs/Makefile.in
@${REINPLACE_CMD} -e \
'/PROGRAM/s|MP4Box|mp4box|g' ${WRKSRC}/libogmrip/ogmrip-mp4.c
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index b77386a9ddeb..d59c397ca7cb 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -56,8 +56,6 @@ GG_EMOTS_DISTFILES= ${GG6_EMOTS_DISTFILE}:additions \
${GG7_EMOTS_DISTFILE}:additions
post-patch:
- @${REINPLACE_CMD} '/zlib/ s|^|#|' \
- ${WRKSRC}/plugins/jabber_protocol/CMakeLists.txt
@${REINPLACE_CMD} '/kadu_add_test/ s|^|#|' \
${WRKSRC}/kadu-core/plugin/CMakeLists.txt
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index b35a158a2a28..77ec09e7626e 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -43,9 +43,6 @@ post-patch:
-e '/as_fn_error.*gnome-doc-utils/d' \
-e '/DEP_MODULES=/s/"$$/ gmodule-2.0"/' \
${WRKSRC}/dict/configure
- @${REINPLACE_CMD} \
- -e '/^DEP_MODULES=/s/zlib//' \
- ${WRKSRC}/lib/configure
post-patch-GNOME-off:
${REINPLACE_CMD} -e '/^SUBDIRS/s,help,,' ${WRKSRC}/dict/Makefile.in