aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2019-12-18 22:22:03 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2019-12-18 22:22:03 +0000
commit2a8b525b7c493060b73f68f1a12b4c68d37f9c46 (patch)
tree828b46ffb3bb8bdb58e0ed7e10705fee6221267d
parenta95c46a48e9a551afbfaa3cc8bd99b1eb29d32d5 (diff)
downloadports-2a8b525b7c493060b73f68f1a12b4c68d37f9c46.tar.gz
ports-2a8b525b7c493060b73f68f1a12b4c68d37f9c46.zip
Add missing updates to catch up net/samba410 4.10.8 -> 4.10.11 changes.
PR: 242681 Approved by: portmgr (implicit, packaging fix) MFH: 2019Q4 (packaging fix)
Notes
Notes: svn path=/branches/2019Q4/; revision=520405
-rw-r--r--net/samba410/Makefile100
-rw-r--r--net/samba410/files/0001-Zfs-provision-1.patch14
-rw-r--r--net/samba410/files/0001-provision-use-ASCII-quotes.patch30
-rw-r--r--net/samba410/pkg-plist6
4 files changed, 98 insertions, 52 deletions
diff --git a/net/samba410/Makefile b/net/samba410/Makefile
index 8fd39d82fecc..83ad9d7f3bc1 100644
--- a/net/samba410/Makefile
+++ b/net/samba410/Makefile
@@ -15,10 +15,12 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
IGNORE_NONTHREAD_PYTHON= needs port lang/python${PYTHON_SUFFIX} to be build with THREADS support
-
CONFLICTS_INSTALL?= samba4-4.0.* samba4[1-9]-4.* p5-Parse-Pidl-4.*
+USES= cpe
+
EXTRA_PATCHES+= ${PATCHDIR}/0001-Zfs-provision-1.patch:-p1
+EXTRA_PATCHES+= ${PATCHDIR}/0001-provision-use-ASCII-quotes.patch:-p1
SAMBA4_BASENAME= samba
SAMBA4_PORTNAME= ${SAMBA4_BASENAME}4
@@ -65,12 +67,10 @@ CONFIGURE_ARGS+= --mandir="${MANPREFIX}/man" \
# XXX: Flags
CONFIGURE_ENV+= PTHREAD_LDFLAGS="-lpthread"
-USES= compiler:c++11-lang cpe iconv gettext-runtime \
- localbase:ldflags perl5 pkgconfig shebangfix \
- ssl waf
+USES+= compiler:c++11-lang iconv localbase:ldflags \
+ perl5 pkgconfig shebangfix ssl waf gettext-runtime
USE_PERL5= build
USE_LDCONFIG= ${SAMBA4_LIBDIR}
-LLD_UNSAFE= yes
WAF_CMD= buildtools/bin/waf
CONFIGURE_LOG= bin/config.log
@@ -79,57 +79,67 @@ PKGCONFIGDIR_REL?= ${PKGCONFIGDIR:S,^${PREFIX}/,,}
PLIST_SUB+= PKGCONFIGDIR=${PKGCONFIGDIR_REL}
SUB_LIST+= PKGCONFIGDIR=${PKGCONFIGDIR_REL}
##############################################################################
-# Options
OPTIONS_SUB= yes
-OPTIONS_DEFINE= AD_DC ADS DEBUG DOCS FAM LDAP \
- QUOTAS SYSLOG UTMP PROFILE
-# Make those default options
-OPTIONS_DEFAULT:= ${OPTIONS_DEFINE} GSSAPI_BUILTIN AVAHI
+OPTIONS_DEFINE= AD_DC ADS CLUSTER CUPS DEBUG DOCS FAM GPGME \
+ LDAP NTVFS PROFILE QUOTAS SPOTLIGHT SYSLOG UTMP
# This shouldn't be default in the release
OPTIONS_DEFINE+= DEVELOPER MANDOC
+#OPTIONS_DEFINE+= MEMORY_DEBUG
OPTIONS_DEFINE_amd64= AESNI
OPTIONS_DEFAULT_amd64= AESNI
-OPTIONS_DEFINE+= CLUSTER CUPS GLUSTERFS GPGME NTVFS SPOTLIGHT
-#OPTIONS_DEFINE+= MEMORY_DEBUG
+OPTIONS_GROUP= VFS
+OPTIONS_GROUP_VFS= FRUIT GLUSTERFS
OPTIONS_SINGLE= GSSAPI ZEROCONF
# GSSAPI_HEIMDAL
OPTIONS_SINGLE_GSSAPI= GSSAPI_BUILTIN GSSAPI_MIT
-OPTIONS_SINGLE_ZEROCONF= AVAHI MDNSRESPONDER
+OPTIONS_SINGLE_ZEROCONF= ZEROCONF_NONE AVAHI MDNSRESPONDER
OPTIONS_RADIO= DNS
OPTIONS_RADIO_DNS= NSUPDATE BIND911 BIND914
+# Make those default options
+OPTIONS_DEFAULT= AD_DC ADS DEBUG DOCS FAM LDAP \
+ QUOTAS SYSLOG UTMP PROFILE \
+ FRUIT GSSAPI_BUILTIN AVAHI
##############################################################################
AD_DC_DESC= Active Directory Domain Controller
ADS_DESC= Active Directory client(implies LDAP)
AESNI_DESC= Accelerated AES crypto functions(amd64 only)
-CLUSTER_DESC= Clustering
+CLUSTER_DESC= Clustering support
DEVELOPER_DESC= With developer framework(implies NTVFS)
FAM_DESC= File Alteration Monitor
-GPGME_DESC= GpgME
-GLUSTERFS_DESC= GlusterFS
+GPGME_DESC= GpgME support
LDAP_DESC= LDAP client
LIBZFS_DESC= LibZFS
-SPOTLIGHT_DESC= Spotlight
+SPOTLIGHT_DESC= Spotlight server-side search support
MANDOC_DESC= Build manpages from DOCBOOK templates
-MEMORY_DEBUG_DESC= Debug memory allocation
+MEMORY_DEBUG_DESC= Debug memory allocator
NTVFS_DESC= Build *DEPRECATED* NTVFS file server
PICKY_DEVELOPER_DESC= Treat compiler warnings as errors(implies DEVELOPER)
PROFILE_DESC= Profiling data
-QUOTAS_DESC= Disk quota
+QUOTAS_DESC= Disk quota support
UTMP_DESC= UTMP accounting
+VFS_DESC= VFS modules
+GLUSTERFS_DESC= GlusterFS support
+FRUIT_DESC= MacOSX and TimeMachine support
+
GSSAPI_BUILTIN_DESC= GSSAPI support via bundled Heimdal
+ZEROCONF_DESC= Zero configuration networking
+ZEROCONF_NONE_DESC= Zeroconf support is absent
+
+DNS_DESC= DNS frontend
BIND911_DESC= Use Bind 9.11 as AD DC DNS server frontend
BIND914_DESC= Use Bind 9.14 as AD DC DNS server frontend
NSUPDATE_DESC= Use samba NSUPDATE utility for AD DC
##############################################################################
# XXX: Unconditional dependencies which can't be switched off(if present in
# the system)
+
# Readline(sponsored by Python)
# XXX: USES=readline pollutes CPPFLAGS, so we explicitly put dependency
LIB_DEPENDS+= libreadline.so:devel/readline
@@ -139,7 +149,8 @@ LIB_DEPENDS+= libpopt.so:devel/popt
LIB_DEPENDS+= libinotify.so:devel/libinotify
# GNUTLS
LIB_DEPENDS+= libgnutls.so:security/gnutls
-# NFS4 ACL glue
+LIB_DEPENDS+= libgcrypt.so:security/libgcrypt
+# NFSv4 ACL glue
LIB_DEPENDS+= libsunacl.so:sysutils/libsunacl
# Jansson
BUILD_DEPENDS+= jansson>=2.10:devel/jansson
@@ -153,6 +164,7 @@ BUILD_DEPENDS+= p5-Parse-Yapp>=0:devel/p5-Parse-Yapp
SAMBA4_BUNDLED_LIBS+= !libarchive
BUILD_DEPENDS+= libarchive>=3.1.2:archivers/libarchive
RUN_DEPENDS+= libarchive>=3.1.2:archivers/libarchive
+
### Bundled libraries
SAMBA4_BUNDLED_CMOCKA?= no
SAMBA4_BUNDLED_TALLOC?= no
@@ -162,7 +174,6 @@ SAMBA4_BUNDLED_LDB?= yes
# cmocka
.if defined(SAMBA4_BUNDLED_CMOCKA) && ${SAMBA4_BUNDLED_CMOCKA} == yes
SAMBA4_BUNDLED_LIBS+= cmocka
-SAMBA4_BUILTIN_LIBS+= cmocka
CONFLICTS+= cmocka-1.*
PLIST_SUB+= SAMBA4_BUNDLED_CMOCKA=""
SUB_LIST+= SAMBA4_BUNDLED_CMOCKA=""
@@ -176,7 +187,6 @@ SUB_LIST+= SAMBA4_BUNDLED_CMOCKA="@comment "
# talloc
.if defined(SAMBA4_BUNDLED_TALLOC) && ${SAMBA4_BUNDLED_TALLOC} == yes
SAMBA4_BUNDLED_LIBS+= talloc
-SAMBA4_BUILTIN_LIBS+= talloc
CONFLICTS+= talloc-* talloc1-*
PLIST_SUB+= SAMBA4_BUNDLED_TALLOC=""
SUB_LIST+= SAMBA4_BUNDLED_TALLOC=""
@@ -190,7 +200,6 @@ SUB_LIST+= SAMBA4_BUNDLED_TALLOC="@comment "
# tevent
.if defined(SAMBA4_BUNDLED_TEVENT) && ${SAMBA4_BUNDLED_TEVENT} == yes
SAMBA4_BUNDLED_LIBS+= tevent
-SAMBA4_BUILTIN_LIBS+= tevent
CONFLICTS+= tevent-* tevent1-*
PLIST_SUB+= SAMBA4_BUNDLED_TEVENT=""
SUB_LIST+= SAMBA4_BUNDLED_TEVENT=""
@@ -204,7 +213,6 @@ SUB_LIST+= SAMBA4_BUNDLED_TEVENT="@comment "
# tdb
.if defined(SAMBA4_BUNDLED_TDB) && ${SAMBA4_BUNDLED_TDB} == yes
SAMBA4_BUNDLED_LIBS+= tdb
-SAMBA4_BUILTIN_LIBS+= tdb
CONFLICTS+= tdb-* tdb1-*
PLIST_SUB+= SAMBA4_BUNDLED_TDB=""
SUB_LIST+= SAMBA4_BUNDLED_TDB=""
@@ -219,7 +227,6 @@ SUB_LIST+= SAMBA4_BUNDLED_TDB="@comment "
.if defined(SAMBA4_BUNDLED_LDB) && ${SAMBA4_BUNDLED_LDB} == yes
SAMBA4_BUNDLED_LDB= yes
SAMBA4_BUNDLED_LIBS+= ldb
-SAMBA4_BUILTIN_LIBS+= ldb
PLIST_SUB+= SAMBA4_BUNDLED_LDB=""
SUB_LIST+= SAMBA4_BUNDLED_LDB=""
SAMBA4_MODULEDIR= ${SAMBA4_LIBDIR}/modules
@@ -237,7 +244,6 @@ SAMBA4_MODULEDIR= ${PREFIX}/lib/shared-modules
|| (defined(SAMBA4_BUNDLED_LDB) && ${SAMBA4_BUNDLED_LDB} == yes) \
|| (defined(SAMBA4_BUNDLED_TEVENT) && ${SAMBA4_BUNDLED_TEVENT} == yes)
SAMBA4_BUNDLED_LIBS+= replace
-#SAMBA4_BUILTIN_LIBS+= replace
.endif
# Don't use external libcom_err
SAMBA4_BUNDLED_LIBS+= com_err
@@ -266,11 +272,20 @@ CONFIGURE_ARGS+= \
--with-acl-support \
--with-sendfile-support \
--disable-ctdb-tests \
- ${ICONV_CONFIGURE_BASE}
+
+# ${ICONV_CONFIGURE_BASE}
##############################################################################
-BIND911_RUN_DEPENDS= bind911>=9.11.0.0:dns/bind911
-BIND914_RUN_DEPENDS= bind914>=9.14.0.0:dns/bind914
-NSUPDATE_RUN_DEPENDS= samba-nsupdate:dns/samba-nsupdate
+FRUIT_PREVENTS= ZEROCONF_NONE
+FRUIT_PREVENTS_MSG= MacOSX support requires Zeroconf(AVAHI or MDNSRESPONDER)
+FRUIT_VARS= SAMBA4_MODULES+=vfs_fruit
+FRUIT_PLIST_FILES+= man/man8/vfs_fruit.8.gz
+
+GLUSTERFS_CONFIGURE_ENABLE= glusterfs
+GLUSTERFS_LIB_DEPENDS= libglusterfs.so:net/glusterfs
+GLUSTERFS_VARS= SAMBA4_MODULES+=vfs_glusterfs
+GLUSTERFS_PLIST_FILES+= man/man8/vfs_glusterfs.8.gz
+##############################################################################
+ZEROCONF_NONE_VARS= MAKE_ENV+=ZEROCONF=none
AVAHI_CONFIGURE_ENABLE= avahi
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
@@ -280,6 +295,10 @@ MDNSRESPONDER_CONFIGURE_ENABLE= dnssd
MDNSRESPONDER_LIB_DEPENDS= libdns_sd.so:net/mDNSResponder
MDNSRESPONDER_VARS= SAMBA4_SERVICES+=mdnsd
##############################################################################
+BIND911_RUN_DEPENDS= bind911>=9.11.0.0:dns/bind911
+BIND914_RUN_DEPENDS= bind914>=9.14.0.0:dns/bind914
+NSUPDATE_RUN_DEPENDS= samba-nsupdate:dns/samba-nsupdate
+##############################################################################
DEBUG_CONFIGURE_ON= --verbose --enable-debug
DEBUG_MAKE_ARGS= --verbose
DEBUG_FLAGS= -g -ggdb3 -O0
@@ -315,11 +334,6 @@ CUPS_LIB_DEPENDS= libcups.so:print/cups
FAM_USES= fam
FAM_CONFIGURE_WITH= fam
-GLUSTERFS_CONFIGURE_ENABLE= glusterfs
-GLUSTERFS_LIB_DEPENDS= libglusterfs.so:net/glusterfs
-GLUSTERFS_VARS= SAMBA4_MODULES+=vfs_glusterfs
-GLUSTERFS_PLIST_FILES+= man/man8/vfs_glusterfs.8.gz
-
GPGME_CONFIGURE_WITH= gpgme
GPGME_LIB_DEPENDS= libgpgme.so:security/gpgme
@@ -330,7 +344,7 @@ QUOTAS_CONFIGURE_WITH= quotas
SPOTLIGHT_CONFIGURE_ENABLE= spotlight
SPOTLIGHT_BUILD_DEPENDS= tracker>=1.4.1:sysutils/tracker
SPOTLIGHT_RUN_DEPENDS= tracker>=1.4.1:sysutils/tracker
-SPOTLIGHT_USES= bison
+SPOTLIGHT_USES= bison gnome
SPOTLIGHT_USE= gnome=glib20
SYSLOG_CONFIGURE_WITH= syslog
@@ -403,6 +417,7 @@ SUB_LIST+= SAMBA4_PYTHON="@comment "
USES+= python:3.4+
PLIST_SUB+= SAMBA4_PYTHON=""
SUB_LIST+= SAMBA4_PYTHON=""
+CONFIGURE_ARGS+= --nopycache
.if defined(SAMBA4_BUNDLED_TALLOC) && ${SAMBA4_BUNDLED_TALLOC} == yes
SAMBA4_BUNDLED_LIBS+= pytalloc-util
@@ -441,7 +456,6 @@ SAMBA4_MODULES+= ${WANT_EXP_MODULES}
.if defined(SAMBA4_BUNDLED_LIBS) && !empty(SAMBA4_BUNDLED_LIBS)
CONFIGURE_ARGS+= --bundled-libraries="${SAMBA4_BUNDLED_LIBS:Q:C|(\\\\ )+|,|g:S|\\||g}"
-CONFIGURE_ARGS+= --builtin-libraries="${SAMBA4_BUILTIN_LIBS:Q:C|(\\\\ )+|,|g:S|\\||g}"
.endif
.if defined(SAMBA4_MODULES) && !empty(SAMBA4_MODULES)
@@ -623,6 +637,10 @@ post-install: post-install-rm-junk post-install-fix-manpages
${INSTALL} -d -m 0755 "${STAGEDIR}${SAMBA4_MODULEDIR}/${dir}"
.endfor
+post-install-FRUIT-off:
+ ${RM} ${STAGEDIR}${SAMBA4_MODULEDIR}/vfs/fruit.so
+ ${RM} ${STAGEDIR}${PREFIX}/man/man8/vfs_fruit.8
+
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
@@ -630,10 +648,10 @@ post-install-DOCS-on:
.endfor
post-install-CLUSTER-on:
- ${LN} -nfs ../../../../share/ctdb/events/legacy/00.ctdb.script ${STAGEDIR}${PREFIX}/etc/ctdb/events/legacy/00.ctdb.script
- ${LN} -nfs ../../../../share/ctdb/events/legacy/10.interface.script ${STAGEDIR}${PREFIX}/etc/ctdb/events/legacy/10.interface.script
- ${LN} -nfs ../../../../share/ctdb/events/legacy/05.system.script ${STAGEDIR}${PREFIX}/etc/ctdb/events/legacy/05.system.script
- ${LN} -nfs ../../../../share/ctdb/events/legacy/01.reclock.script ${STAGEDIR}${PREFIX}/etc/ctdb/events/legacy/01.reclock.script
+ ${LN} -nfs ../../../../share/ctdb/events/legacy/00.ctdb.script ${STAGEDIR}${PREFIX}/etc/ctdb/events/legacy/00.ctdb.script
+ ${LN} -nfs ../../../../share/ctdb/events/legacy/10.interface.script ${STAGEDIR}${PREFIX}/etc/ctdb/events/legacy/10.interface.script
+ ${LN} -nfs ../../../../share/ctdb/events/legacy/05.system.script ${STAGEDIR}${PREFIX}/etc/ctdb/events/legacy/05.system.script
+ ${LN} -nfs ../../../../share/ctdb/events/legacy/01.reclock.script ${STAGEDIR}${PREFIX}/etc/ctdb/events/legacy/01.reclock.script
# !SAMBA4_SUBPORT
.endif
diff --git a/net/samba410/files/0001-Zfs-provision-1.patch b/net/samba410/files/0001-Zfs-provision-1.patch
index df5a6ad3b6fa..bfa5b4d07135 100644
--- a/net/samba410/files/0001-Zfs-provision-1.patch
+++ b/net/samba410/files/0001-Zfs-provision-1.patch
@@ -120,7 +120,7 @@ diff --git a/source3/smbd/pysmbd.c b/source3/smbd/pysmbd.c
index 63fc5d68c33..f5a536ee186 100644
--- a/source3/smbd/pysmbd.c
+++ b/source3/smbd/pysmbd.c
-@@ -387,6 +387,20 @@ static SMB_ACL_T make_simple_acl(TALLOC_
+@@ -392,6 +392,20 @@ static SMB_ACL_T make_simple_acl(TALLOC_
return acl;
}
@@ -141,7 +141,7 @@ index 63fc5d68c33..f5a536ee186 100644
/*
set a simple ACL on a file, as a test
*/
-@@ -432,6 +446,57 @@ static PyObject *py_smbd_set_simple_acl(
+@@ -437,6 +451,57 @@ static PyObject *py_smbd_set_simple_acl(
Py_RETURN_NONE;
}
@@ -169,13 +169,13 @@ index 63fc5d68c33..f5a536ee186 100644
+ acl = make_simple_nfsv4_acl(frame, gid, mode);
+ if (acl == NULL) {
+ TALLOC_FREE(frame);
-+ return NULL;
++ Py_RETURN_NONE;
+ }
+
+ conn = get_conn_tos(service, NULL);
+ if (!conn) {
+ TALLOC_FREE(frame);
-+ return NULL;
++ Py_RETURN_NONE;
+ }
+
+ /*
@@ -199,7 +199,7 @@ index 63fc5d68c33..f5a536ee186 100644
/*
chown a file
*/
-@@ -540,7 +605,7 @@ static PyObject *py_smbd_unlink(PyObject
+@@ -536,7 +601,7 @@ static PyObject *py_smbd_unlink(PyObject
}
/*
@@ -208,7 +208,7 @@ index 63fc5d68c33..f5a536ee186 100644
*/
static PyObject *py_smbd_have_posix_acls(PyObject *self)
{
-@@ -551,6 +616,86 @@ static PyObject *py_smbd_have_posix_acls
+@@ -547,6 +612,86 @@ static PyObject *py_smbd_have_posix_acls
#endif
}
@@ -295,7 +295,7 @@ index 63fc5d68c33..f5a536ee186 100644
/*
set the NT ACL on a file
*/
-@@ -843,9 +988,24 @@ static PyMethodDef py_smbd_methods[] = {
+@@ -881,9 +1026,24 @@ static PyMethodDef py_smbd_methods[] = {
{ "have_posix_acls",
(PyCFunction)py_smbd_have_posix_acls, METH_NOARGS,
NULL },
diff --git a/net/samba410/files/0001-provision-use-ASCII-quotes.patch b/net/samba410/files/0001-provision-use-ASCII-quotes.patch
new file mode 100644
index 000000000000..1c63cd334b06
--- /dev/null
+++ b/net/samba410/files/0001-provision-use-ASCII-quotes.patch
@@ -0,0 +1,30 @@
+From d01c5bc9fbe316d2358ead6382f4e7e3bf5fc000 Mon Sep 17 00:00:00 2001
+From: Philipp Gesang <philipp.gesang@intra2net.com>
+Date: Tue, 12 Mar 2019 15:51:16 +0100
+Subject: [PATCH] provision: use ASCII quotes
+
+Remove some Unicode quotes that cause problems under the C
+locale.
+
+Signed-off-by: Philipp Gesang <philipp.gesang@intra2net.com>
+Reviewed-by: Douglas Bagnall <douglas.bagnall@catalyst.net.nz>
+---
+ source4/setup/extended-rights.ldif | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/source4/setup/extended-rights.ldif b/source4/setup/extended-rights.ldif
+index ef4c3049601..67417b7d020 100644
+--- a/source4/setup/extended-rights.ldif
++++ b/source4/setup/extended-rights.ldif
+@@ -11,7 +11,7 @@
+ #
+
+ # Technical Documentation. Microsoft publishes Open Specifications
+-# documentation (“this documentation”) for protocols, file formats,
++# documentation ("this documentation") for protocols, file formats,
+ # data portability, computer languages, and standards
+ # support. Additionally, overview documents cover inter-protocol
+ # relationships and interactions.
+--
+2.18.0
+
diff --git a/net/samba410/pkg-plist b/net/samba410/pkg-plist
index 441f6408b4d4..52b4f3091d50 100644
--- a/net/samba410/pkg-plist
+++ b/net/samba410/pkg-plist
@@ -386,9 +386,7 @@ lib/samba4/private/libxattr-tdb-samba4.so
%%SAMBA4_MODULEDIR%%/vfs/expand_msdfs.so
%%SAMBA4_MODULEDIR%%/vfs/extd_audit.so
%%SAMBA4_MODULEDIR%%/vfs/fake_perms.so
-%%SAMBA4_MODULEDIR%%/vfs/fruit.so
%%SAMBA4_MODULEDIR%%/vfs/full_audit.so
-%%SAMBA4_MODULEDIR%%/vfs/glusterfs_fuse.so
%%SAMBA4_MODULEDIR%%/vfs/linux_xfs_sgid.so
%%SAMBA4_MODULEDIR%%/vfs/media_harmony.so
%%SAMBA4_MODULEDIR%%/vfs/netatalk.so
@@ -669,9 +667,7 @@ man/man8/vfs_dirsort.8.gz
man/man8/vfs_extd_audit.8.gz
man/man8/vfs_fake_perms.8.gz
man/man8/vfs_freebsd.8.gz
-man/man8/vfs_fruit.8.gz
man/man8/vfs_full_audit.8.gz
-man/man8/vfs_glusterfs_fuse.8.gz
man/man8/vfs_linux_xfs_sgid.8.gz
man/man8/vfs_media_harmony.8.gz
man/man8/vfs_netatalk.8.gz
@@ -951,6 +947,7 @@ man/man8/winbindd.8.gz
%%PYTHON_SITELIBDIR%%/samba/tests/blackbox/traffic_learner.py
%%PYTHON_SITELIBDIR%%/samba/tests/blackbox/traffic_replay.py
%%PYTHON_SITELIBDIR%%/samba/tests/blackbox/traffic_summary.py
+%%PYTHON_SITELIBDIR%%/samba/tests/blackbox/undoguididx.py
%%PYTHON_SITELIBDIR%%/samba/tests/common.py
%%PYTHON_SITELIBDIR%%/samba/tests/complex_expressions.py
%%PYTHON_SITELIBDIR%%/samba/tests/core.py
@@ -1118,6 +1115,7 @@ man/man8/winbindd.8.gz
%%SAMBA4_BUNDLED_LDB%%lib/samba4/private/libldb-key-value-samba4.so
%%SAMBA4_BUNDLED_LDB%%lib/samba4/private/libldb-tdb-err-map-samba4.so
%%SAMBA4_BUNDLED_LDB%%lib/samba4/private/libldb-tdb-int-samba4.so
+%%SAMBA4_BUNDLED_LDB%%lib/samba4/private/libldb.so.1
%%SAMBA4_BUNDLED_LDB%%%%SAMBA4_MODULEDIR%%/ldb/asq.so
%%SAMBA4_BUNDLED_LDB%%%%SAMBA4_MODULEDIR%%/ldb/ldb.so
%%SAMBA4_BUNDLED_LDB%%%%SAMBA4_MODULEDIR%%/ldb/paged_searches.so