aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-12-07 10:46:32 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-12-07 10:46:32 +0000
commit330fcd965139b75be45ea78c57bd837314e65633 (patch)
tree7abe6e3b946c4a7cecb0c2f6c0ceea18f32e2334
parent6da20222530aa74a2e5e66ab54664db0884ba923 (diff)
downloadports-330fcd965139b75be45ea78c57bd837314e65633.tar.gz
ports-330fcd965139b75be45ea78c57bd837314e65633.zip
MFH: r514253
www/wpebackend-fdo needs C++11 compiler: /wrkdirs/usr/ports/www/wpebackend-fdo/work/wpebackend-fdo-1.4.0/src/ipc.h:40: error: ISO C++ forbids declaration of 'unique_ptr' with no type sysutils/xfce4-kbdleds-plugin needs C11 compiler similarly to other xfce ports. This MFH should unblock 265 ports. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/branches/2019Q4/; revision=519196
-rw-r--r--sysutils/xfce4-kbdleds-plugin/Makefile3
-rw-r--r--www/wpebackend-fdo/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/sysutils/xfce4-kbdleds-plugin/Makefile b/sysutils/xfce4-kbdleds-plugin/Makefile
index ade1e3a8a636..16da7aa2d4d3 100644
--- a/sysutils/xfce4-kbdleds-plugin/Makefile
+++ b/sysutils/xfce4-kbdleds-plugin/Makefile
@@ -17,7 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gettext-tools gmake gnome libtool pkgconfig tar:bzip2 xfce
+USES= compiler:c11 gettext-tools gmake gnome libtool pkgconfig \
+ tar:bzip2 xfce
GNU_CONFIGURE= yes
USE_GNOME= cairo gdkpixbuf2 glib20 gtk20 intltool pango
USE_XORG= ice sm x11
diff --git a/www/wpebackend-fdo/Makefile b/www/wpebackend-fdo/Makefile
index 329386881722..7f878b9c2213 100644
--- a/www/wpebackend-fdo/Makefile
+++ b/www/wpebackend-fdo/Makefile
@@ -14,7 +14,8 @@ LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon \
libwpe-1.0.so:www/libwpe \
libwayland-client.so:graphics/wayland
-USES= cmake pkgconfig localbase:ldflags gl gnome tar:xz
+USES= cmake compiler:c++11-lang pkgconfig localbase:ldflags gl gnome \
+ tar:xz
USE_GL= egl
USE_GNOME= glib20