aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2006-12-12 13:49:02 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2006-12-12 13:49:02 +0000
commit34b6cd81a7968f774a4ee76277297eed2320fa9c (patch)
tree9e2f00e810a6686268d425ae85e0eb44e291f069
parentddcab5353dbf7fd42751a22ff832f67baceaa5e7 (diff)
Notes
-rw-r--r--lang/erlang/Makefile4
-rw-r--r--lang/erlang/Makefile.lib1
-rw-r--r--lang/erlang/files/pkg-message.in (renamed from lang/erlang/pkg-message)4
-rw-r--r--lang/erlang14/Makefile4
-rw-r--r--lang/erlang14/Makefile.lib1
-rw-r--r--lang/erlang14/files/pkg-message.in (renamed from lang/erlang14/pkg-message)4
6 files changed, 12 insertions, 6 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 4429db017734..785021b672aa 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -25,6 +25,8 @@ COMMENT= A functional programming language from Ericsson
CONFLICTS?= erlang-lite-r[0-9]*
+SUB_FILES= pkg-message
+
# The Java applications that are part of the Erlang distribution are
# not strictly necessary - it is included for completeness sake. A
# problem with the Erlang build procedure is that it only checks if
@@ -87,7 +89,7 @@ NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-PLIST_SUB+= ERTS_VSN=${ERTS_VSN}
+PLIST_SUB+= ERTS_VSN=${ERTS_VSN} TOOLS_VSN=${TOOLS_VSN}
# The man-pages are put (in spite of FreeBSD's port convention) in a private
# subdir. This is to avoid cluttering up the man page name space. Also the
diff --git a/lang/erlang/Makefile.lib b/lang/erlang/Makefile.lib
index 4e31eb5ea67a..3f8751174ac0 100644
--- a/lang/erlang/Makefile.lib
+++ b/lang/erlang/Makefile.lib
@@ -1,6 +1,7 @@
# $FreeBSD$
ERTS_VSN= 5.5.2
+TOOLS_VSN= 2.5.2
OTP_LIBS= appmon-2.1.6 \
asn1-1.4.4.11 \
compiler-4.4.2 \
diff --git a/lang/erlang/pkg-message b/lang/erlang/files/pkg-message.in
index a9628d938b35..6abe1f5611f3 100644
--- a/lang/erlang/pkg-message
+++ b/lang/erlang/files/pkg-message.in
@@ -7,9 +7,9 @@ Installation tips:
You can find an emacs mode for Erlang here:
- ${LOCALBASE}/lib/erlang/lib/tools-2.5.2/emacs
+ %%LOCALBASE%%/lib/erlang/lib/tools-2.5.2/emacs
You may wish to add the following line to /etc/manpath.config:
-OPTIONAL_MANPATH /usr/local/lib/erlang/man
+OPTIONAL_MANPATH %%LOCALBASE%%/lib/erlang/man
===========================================================================
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 4429db017734..785021b672aa 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -25,6 +25,8 @@ COMMENT= A functional programming language from Ericsson
CONFLICTS?= erlang-lite-r[0-9]*
+SUB_FILES= pkg-message
+
# The Java applications that are part of the Erlang distribution are
# not strictly necessary - it is included for completeness sake. A
# problem with the Erlang build procedure is that it only checks if
@@ -87,7 +89,7 @@ NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-PLIST_SUB+= ERTS_VSN=${ERTS_VSN}
+PLIST_SUB+= ERTS_VSN=${ERTS_VSN} TOOLS_VSN=${TOOLS_VSN}
# The man-pages are put (in spite of FreeBSD's port convention) in a private
# subdir. This is to avoid cluttering up the man page name space. Also the
diff --git a/lang/erlang14/Makefile.lib b/lang/erlang14/Makefile.lib
index 4e31eb5ea67a..3f8751174ac0 100644
--- a/lang/erlang14/Makefile.lib
+++ b/lang/erlang14/Makefile.lib
@@ -1,6 +1,7 @@
# $FreeBSD$
ERTS_VSN= 5.5.2
+TOOLS_VSN= 2.5.2
OTP_LIBS= appmon-2.1.6 \
asn1-1.4.4.11 \
compiler-4.4.2 \
diff --git a/lang/erlang14/pkg-message b/lang/erlang14/files/pkg-message.in
index a9628d938b35..6abe1f5611f3 100644
--- a/lang/erlang14/pkg-message
+++ b/lang/erlang14/files/pkg-message.in
@@ -7,9 +7,9 @@ Installation tips:
You can find an emacs mode for Erlang here:
- ${LOCALBASE}/lib/erlang/lib/tools-2.5.2/emacs
+ %%LOCALBASE%%/lib/erlang/lib/tools-2.5.2/emacs
You may wish to add the following line to /etc/manpath.config:
-OPTIONAL_MANPATH /usr/local/lib/erlang/man
+OPTIONAL_MANPATH %%LOCALBASE%%/lib/erlang/man
===========================================================================