aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-12-20 09:53:57 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-12-20 09:53:57 +0000
commit427ad41a67163ccae8930c6db8cdb59348f3797d (patch)
tree45176b660ded13e70d105c1402d095244fee4671
parent2a8b525b7c493060b73f68f1a12b4c68d37f9c46 (diff)
downloadports-427ad41a67163ccae8930c6db8cdb59348f3797d.tar.gz
ports-427ad41a67163ccae8930c6db8cdb59348f3797d.zip
MFH: r520157 [NEW] astro/py-pymeeus: Python implementation of Jean Meeus astronomical routines
PyMeeus is a Python implementation of the astronomical algorithms described in the classical book "Astronomical Algorithms, 2nd Edition, Willmann-Bell Inc. (1998)" by Jean Meeus. WWW: https://github.com/architest/pymeeus PR: 240735 Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2019Q4/; revision=520489
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-pymeeus/Makefile26
-rw-r--r--astro/py-pymeeus/distinfo3
-rw-r--r--astro/py-pymeeus/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 3cf1f1233003..b3a927e49a10 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -88,6 +88,7 @@
SUBDIR += py-horoscopegenerator
SUBDIR += py-metar
SUBDIR += py-metpy
+ SUBDIR += py-pymeeus
SUBDIR += py-pymetar
SUBDIR += py-pysofa
SUBDIR += py-pywapi
diff --git a/astro/py-pymeeus/Makefile b/astro/py-pymeeus/Makefile
new file mode 100644
index 000000000000..0001e0177e86
--- /dev/null
+++ b/astro/py-pymeeus/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= pymeeus
+PORTVERSION= 0.3.6
+CATEGORIES= astro science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyMeeus-${DISTVERSION}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Python implementation of Jean Meeus astronomical routines
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+
+.include <bsd.port.mk>
diff --git a/astro/py-pymeeus/distinfo b/astro/py-pymeeus/distinfo
new file mode 100644
index 000000000000..cf6a6ca130a6
--- /dev/null
+++ b/astro/py-pymeeus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1576391625
+SHA256 (PyMeeus-0.3.6.tar.gz) = 1f1ba0682e1b5c6b0cd6432c966e8bc8acc31737ea6f0ae79917a2189a98bb87
+SIZE (PyMeeus-0.3.6.tar.gz) = 736212
diff --git a/astro/py-pymeeus/pkg-descr b/astro/py-pymeeus/pkg-descr
new file mode 100644
index 000000000000..0d113e32da66
--- /dev/null
+++ b/astro/py-pymeeus/pkg-descr
@@ -0,0 +1,5 @@
+PyMeeus is a Python implementation of the astronomical algorithms
+described in the classical book "Astronomical Algorithms, 2nd Edition,
+Willmann-Bell Inc. (1998)" by Jean Meeus.
+
+WWW: https://github.com/architest/pymeeus