aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-02-20 18:10:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-02-20 18:10:56 +0000
commit4965ee61fdd48d7a1a941689b7323a10bbfab2d5 (patch)
treece5a03161f51d42681401ff79bf618155ebc8609
parent1f7eec31015fb55ef7b15f1be8866e49cb3dd4a1 (diff)
Notes
-rw-r--r--www/gecko-mediaplayer/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/www/gecko-mediaplayer/Makefile b/www/gecko-mediaplayer/Makefile
index f32326624ea4..009550714de3 100644
--- a/www/gecko-mediaplayer/Makefile
+++ b/www/gecko-mediaplayer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gecko-mediaplayer
-# Date created: 14 March 2009
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
+# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-#
PORTNAME= gecko-mediaplayer
PORTVERSION= 1.0.0
@@ -17,12 +13,13 @@ COMMENT= Multimedia browser plugin for Gecko based browsers
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= gnome-mplayer:${PORTSDIR}/multimedia/gnome-mplayer
-OPTIONS= GCONF "Use Gconf to store preferences" off \
- NOCACHE "Disable caching of remote media to local storage" off
+OPTIONS_DEFINE= GCONF NOCACHE
+NOCACHE_DESC= Disable caching of remote media to local storage
GNU_CONFIGURE= yes
USE_GETTEXT= yes
-USE_GNOME= glib20 pkgconfig
+USE_PKGCONFIG= build
+USE_GNOME= glib20
USE_GECKO= libxul19
USE_WEBPLUGINS= native
WEBPLUGINS_FILES= ${PORTNAME}-dvx.so ${PORTNAME}-qt.so ${PORTNAME}-rm.so \
@@ -33,9 +30,9 @@ CONFIGURE_ARGS+=--with-plugin_dir="${WEBPLUGINS_DIR}"
PORTDOCS= README COPYING AUTHORS ChangeLog INSTALL NEWS javascript.txt
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GCONF)
+.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= gconf2
CONFIGURE_ARGS+= --with-gconf
GCONF_SCHEMAS= ${PORTNAME}.schemas
@@ -43,7 +40,7 @@ GCONF_SCHEMAS= ${PORTNAME}.schemas
CONFIGURE_ARGS+= --without-gconf --disable-schemas-install
.endif
-.if defined(WITH_NOCACHE)
+.if ${PORT_OPTIONS:MNOCACHE}
CONFIGURE_ARGS+= --disable-caching
.endif
@@ -51,11 +48,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' \
${WRKSRC}/configure \
${WRKSRC}/src/Makefile.in
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e \
's|install-gecko_mediaplayerdocDATA install-schemaDATA|install-schemaDATA|' \
${WRKSRC}/Makefile.in
.endif
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>