aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-05 11:32:45 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-05 11:32:45 +0000
commit5468d240d08fcce87b07f1065e851dd8fc9279e7 (patch)
tree28befdc3b22390b6b4f17977a6124b50603974b9
parent2098c2e1edb563e03cf4b806d6ee465544387f04 (diff)
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-String-ToIdentifier-EN/Makefile38
-rw-r--r--textproc/p5-String-ToIdentifier-EN/distinfo2
-rw-r--r--textproc/p5-String-ToIdentifier-EN/pkg-descr18
-rw-r--r--textproc/p5-String-ToIdentifier-EN/pkg-plist9
5 files changed, 68 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7b54634083f9..f32791a7f09f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -711,6 +711,7 @@
SUBDIR += p5-String-ShellQuote
SUBDIR += p5-String-ShowDiff
SUBDIR += p5-String-Strip
+ SUBDIR += p5-String-ToIdentifier-EN
SUBDIR += p5-String-Tokenizer
SUBDIR += p5-String-Truncate
SUBDIR += p5-Syntax-Highlight-Engine-Kate
diff --git a/textproc/p5-String-ToIdentifier-EN/Makefile b/textproc/p5-String-ToIdentifier-EN/Makefile
new file mode 100644
index 000000000000..d15c344ac484
--- /dev/null
+++ b/textproc/p5-String-ToIdentifier-EN/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-String-ToIdentifier-EN
+# Date created: 2011-12-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-ToIdentifier-EN
+PORTVERSION= 0.06
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Convert Strings to English Program Identifiers
+
+BUILD_DEPENDS= p5-Lingua-EN-Inflect-Phrase>=0.07:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Phrase \
+ p5-Text-Unidecode>=0.04:${PORTSDIR}/converters/p5-Text-Unidecode \
+ p5-namespace-clean>=0.20:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS= p5-Lingua-EN-Inflect-Phrase>=0.07:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Phrase \
+ p5-Text-Unidecode>=0.04:${PORTSDIR}/converters/p5-Text-Unidecode \
+ p5-namespace-clean>=0.20:${PORTSDIR}/devel/p5-namespace-clean
+
+TEST_DEPENDS= p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+
+PERL_CONFIGURE= yes
+
+MAN3= String::ToIdentifier::EN.3 \
+ String::ToIdentifier::EN::Unicode.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.92:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-String-ToIdentifier-EN/distinfo b/textproc/p5-String-ToIdentifier-EN/distinfo
new file mode 100644
index 000000000000..d9d67d41001b
--- /dev/null
+++ b/textproc/p5-String-ToIdentifier-EN/distinfo
@@ -0,0 +1,2 @@
+SHA256 (String-ToIdentifier-EN-0.06.tar.gz) = 75932a23d08a2275b365136d586ddccbd74c11b90fa24d3f9c5b12274f6eb4e6
+SIZE (String-ToIdentifier-EN-0.06.tar.gz) = 34177
diff --git a/textproc/p5-String-ToIdentifier-EN/pkg-descr b/textproc/p5-String-ToIdentifier-EN/pkg-descr
new file mode 100644
index 000000000000..889edf2a5d34
--- /dev/null
+++ b/textproc/p5-String-ToIdentifier-EN/pkg-descr
@@ -0,0 +1,18 @@
+String::ToIdentifier::EN provides a utility method, "to_identifier" for
+converting an arbitrary string into a readable representation using the ASCII
+subset of \w for use as an identifier in a computer program. The intent is to
+make unique identifier names from which the content of the original string can
+be easily inferred by a human just by reading the identifier.
+
+If you need the full set of \w including Unicode, see the subclass
+String::ToIdentifier::EN::Unicode.
+
+Currently, this process is one way only, and will likely remain this way.
+
+The default is to create camelCase identifiers, or you may pass in a separator
+char of your choice such as _.
+
+Binary char groups will be separated by _ even in camelCase identifiers to make
+them easier to read, e.g.: foo_2_0xFF_Bar.
+
+WWW: http://search.cpan.org/dist/String-ToIdentifier-EN/
diff --git a/textproc/p5-String-ToIdentifier-EN/pkg-plist b/textproc/p5-String-ToIdentifier-EN/pkg-plist
new file mode 100644
index 000000000000..e45c52965405
--- /dev/null
+++ b/textproc/p5-String-ToIdentifier-EN/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/String/ToIdentifier/EN.pm
+%%SITE_PERL%%/String/ToIdentifier/EN/Unicode.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/ToIdentifier/EN/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/ToIdentifier/EN
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/ToIdentifier
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String
+@dirrm %%SITE_PERL%%/String/ToIdentifier/EN
+@dirrmtry %%SITE_PERL%%/String/ToIdentifier
+@dirrmtry %%SITE_PERL%%/String