aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-07-26 23:24:45 +0000
committerSteve Wills <swills@FreeBSD.org>2014-07-26 23:24:45 +0000
commit6cbff030cb1b6c5a3d6e665ab7746fc8b8a36b89 (patch)
tree122535a8ff52838fd8523af5519e61cb79385974
parentd268986101c8e623a3736ce6fabac90efb4c7411 (diff)
downloadports-6cbff030cb1b6c5a3d6e665ab7746fc8b8a36b89.tar.gz
ports-6cbff030cb1b6c5a3d6e665ab7746fc8b8a36b89.zip
Notes
-rw-r--r--Mk/bsd.ruby.mk4
-rw-r--r--lang/ruby20/Makefile3
-rw-r--r--lang/ruby20/distinfo4
-rw-r--r--lang/ruby20/files/extra-patch-ext__readline__readline.c11
-rw-r--r--lang/ruby20/files/patch-configure.in16
-rw-r--r--lang/ruby20/files/patch-ext__dl__extconf.rb11
-rw-r--r--lang/ruby20/files/patch-thread_pthread.c19
7 files changed, 13 insertions, 55 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index d55fb5ce1caf..0449f1a41899 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -193,9 +193,9 @@ RUBY21= "@comment "
# Ruby 2.0
#
RUBY_RELVERSION= 2.0.0
-RUBY_PORTREVISION= 6
+RUBY_PORTREVISION= 0
RUBY_PORTEPOCH= 1
-RUBY_PATCHLEVEL= 353
+RUBY_PATCHLEVEL= 481
#
# PLIST_SUB helpers
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index 9e819ea1df61..8d31f1e8c0a9 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -103,7 +103,6 @@ CONFIGURE_ARGS+= --enable-libedit --with-libedit-prefix=${LOCALBASE}
BUILD_DEPENDS+= readline>=0:${PORTSDIR}/devel/readline
RUN_DEPENDS+= readline>=0:${PORTSDIR}/devel/readline
CONFIGURE_ARGS+= --disable-libedit --with-readline-prefix=${LOCALBASE}
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ext__readline__readline.c
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
@@ -330,6 +329,6 @@ validate:
rm -rf ${WRKSRC}/rubyspec/*
(cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/rubyspec.git)
(cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/mspec.git)
- (cd ${WRKSRC}/rubyspec/rubyspec && env PATH=${WRKSRC}/rubyspec/mspec/bin:${PATH} mspec -t ${STAGEDIR}${PREFIX}/bin/ruby${RUBY_SUFFIX})
+ (cd ${WRKSRC}/rubyspec/rubyspec && env PATH=${WRKSRC}/rubyspec/mspec/bin:${PATH} mspec -t ${PREFIX}/bin/ruby${RUBY_SUFFIX} .)
.include <bsd.port.post.mk>
diff --git a/lang/ruby20/distinfo b/lang/ruby20/distinfo
index 49b4c7f3a17d..fbd96017cafa 100644
--- a/lang/ruby20/distinfo
+++ b/lang/ruby20/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/ruby-2.0.0-p353.tar.bz2) = 3de4e4d9aff4682fa4f8ed2b70bd0d746fae17452fc3d3a8e8f505ead9105ad9
-SIZE (ruby/ruby-2.0.0-p353.tar.bz2) = 10730412
+SHA256 (ruby/ruby-2.0.0-p481.tar.bz2) = 0762dad7e96d8091bdf33b3e3176c2066fbf3dc09dfe85fbf40e74e83c63d8e2
+SIZE (ruby/ruby-2.0.0-p481.tar.bz2) = 10727244
diff --git a/lang/ruby20/files/extra-patch-ext__readline__readline.c b/lang/ruby20/files/extra-patch-ext__readline__readline.c
deleted file mode 100644
index dd5a2eb1282b..000000000000
--- a/lang/ruby20/files/extra-patch-ext__readline__readline.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext/readline/readline.c.orig 2013/10/29 03:09:00 43458
-+++ ext/readline/readline.c 2014/03/01 07:19:08 45225
-@@ -1974,7 +1974,7 @@
-
- rl_attempted_completion_function = readline_attempted_completion_function;
- #if defined(HAVE_RL_PRE_INPUT_HOOK)
-- rl_pre_input_hook = (Function *)readline_pre_input_hook;
-+ rl_pre_input_hook = (rl_hook_func_t *)readline_pre_input_hook;
- #endif
- #ifdef HAVE_RL_CATCH_SIGNALS
- rl_catch_signals = 0;
diff --git a/lang/ruby20/files/patch-configure.in b/lang/ruby20/files/patch-configure.in
index 4905f9ec8717..82b5aaf21ee6 100644
--- a/lang/ruby20/files/patch-configure.in
+++ b/lang/ruby20/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2014-03-20 05:47:33.807394460 +0000
-+++ configure.in 2014-03-20 05:47:49.855394229 +0000
-@@ -1386,11 +1386,11 @@
+--- configure.in.orig 2014-01-30 15:58:25.000000000 +0000
++++ configure.in 2014-07-26 19:30:21.165009183 +0000
+@@ -1401,11 +1401,11 @@
AC_CHECK_DECLS([sys_nerr], [], [], [$ac_includes_default
@%:@include <errno.h>])
@@ -17,7 +17,7 @@
AS_CASE(["$target_cpu"],
[alpha*|sh4|sh4el|sh4eb], [AS_CASE(["$target_os"::"$GCC"],
-@@ -2081,7 +2081,7 @@
+@@ -2096,7 +2096,7 @@
fi
if test x"$enable_pthread" = xyes; then
@@ -26,7 +26,7 @@
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
-@@ -2095,6 +2095,7 @@
+@@ -2110,6 +2110,7 @@
[c], [],
[root], [],
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
@@ -34,15 +34,15 @@
[AS_CASE(["$target_os"],
[openbsd*], [LIBS="-pthread $LIBS"],
[LIBS="-l$pthread_lib $LIBS"])])
-@@ -2326,7 +2327,6 @@
+@@ -2341,7 +2342,6 @@
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
-- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
else
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
fi
-@@ -2713,6 +2713,7 @@
+@@ -2728,6 +2728,7 @@
[freebsd*|dragonfly*], [
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'
diff --git a/lang/ruby20/files/patch-ext__dl__extconf.rb b/lang/ruby20/files/patch-ext__dl__extconf.rb
deleted file mode 100644
index bddc2036ae85..000000000000
--- a/lang/ruby20/files/patch-ext__dl__extconf.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext/dl/extconf.rb.orig 2014-02-24 15:49:13.436431209 +0000
-+++ ext/dl/extconf.rb 2014-02-24 15:50:21.287476923 +0000
-@@ -1,7 +1,7 @@
- require 'mkmf'
-
- if RbConfig::CONFIG['GCC'] == 'yes'
-- (have_macro("__clang__") ? $LDFLAGS : $CFLAGS) << " -fno-defer-pop"
-+ $CFLAGS << " -fno-defer-pop" unless have_macro("__clang__")
- $CFLAGS << " -fno-omit-frame-pointer"
- end
-
diff --git a/lang/ruby20/files/patch-thread_pthread.c b/lang/ruby20/files/patch-thread_pthread.c
deleted file mode 100644
index c3ae23dac5f2..000000000000
--- a/lang/ruby20/files/patch-thread_pthread.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- thread_pthread.c.orig 2013-05-01 15:40:57.000000000 +0000
-+++ thread_pthread.c 2014-01-25 03:00:55.044466722 +0000
-@@ -1420,13 +1420,13 @@
- exit(EXIT_FAILURE);
- }
- # ifdef PTHREAD_STACK_MIN
-- if (PTHREAD_STACK_MIN < 4096 * 3) {
-+ if (PTHREAD_STACK_MIN < 4096 * 4) {
- /* Allocate the machine stack for the timer thread
-- * at least 12KB (3 pages). FreeBSD 8.2 AMD64 causes
-+ * at least 16KB (4 pages). FreeBSD 8.2 AMD64 causes
- * machine stack overflow only with PTHREAD_STACK_MIN.
- */
- pthread_attr_setstacksize(&attr,
-- 4096 * 3 + (THREAD_DEBUG ? BUFSIZ : 0));
-+ 4096 * 4 + (THREAD_DEBUG ? BUFSIZ : 0));
- }
- else {
- pthread_attr_setstacksize(&attr,