aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-12-13 00:08:23 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-12-13 00:08:23 +0000
commit6ec9d598feac01a09156deb7e404f69d4be06209 (patch)
treec84b2725bbc77f3c786511ef038c8a2881f5204e
parent894f4f928214b5e6153a809cccbe4135a54c6aab (diff)
Notes
-rw-r--r--sysutils/bacula/Makefile258
-rw-r--r--sysutils/bacula/distinfo2
-rw-r--r--sysutils/bacula/files/bacula-barcodes51
-rw-r--r--sysutils/bacula/files/chio-bacula191
-rw-r--r--sysutils/bacula/files/patch-autoconf-Make.common.in19
-rw-r--r--sysutils/bacula/files/patch-scripts-Makefile.in43
-rw-r--r--sysutils/bacula/files/patch-src-console-Makefile.in19
-rw-r--r--sysutils/bacula/files/patch-src-console-console.c63
-rw-r--r--sysutils/bacula/pkg-deinstall26
-rw-r--r--sysutils/bacula/pkg-descr11
-rw-r--r--sysutils/bacula/pkg-install58
-rw-r--r--sysutils/bacula/pkg-message10
-rw-r--r--sysutils/bacula/pkg-plist35
13 files changed, 0 insertions, 786 deletions
diff --git a/sysutils/bacula/Makefile b/sysutils/bacula/Makefile
deleted file mode 100644
index c314d02a3256..000000000000
--- a/sysutils/bacula/Makefile
+++ /dev/null
@@ -1,258 +0,0 @@
-# New ports collection makefile for: bacula
-# Date created: 24 February 2003
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= bacula
-PORTVERSION= 1.36.1
-PORTREVISION= 0
-CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= bacula
-
-MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
-COMMENT= The network backup solution
-
-# The user/group IDs below are registered, see
-# http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/book.html#DADS-UID
-#
-BACULA_DIR?=/var/db/bacula
-#
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcp-wrappers=/usr/lib \
- --enable-smartalloc \
- --with-working-dir=${BACULA_DIR} \
- --with-scriptdir=${PREFIX}/share/bacula \
- --with-fd-user=root \
- --with-fd-group=wheel \
- --with-dir-user=bacula \
- --with-dir-group=bacula \
- --with-sd-user=bacula \
- --with-sd-group=operator \
- --with-readline=yes \
- --disable-conio
-
-CONFIGURE_ENV+= CPPFLAGS="-I/usr/include/readline -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-
-OPTIONS= CLIENT_ONLY "Build bacula file daemon only" off
-OPTIONS+= WXCONSOLE "Build with wxGTK based GUI console" off
-OPTIONS+= GNOMECONSOLE "Build with GNOME based GUI console" off
-OPTIONS+= MYSQL "Use MySQL database instead of SqLite" off
-OPTIONS+= POSTGRESQL7 "Use PostgreSQL 7.X database instead of SqLite" off
-OPTIONS+= MTX "Install mtx for control of autochanger devices" off
-
-# Prepare if gnome-console is selected this must be happen before
-# include of bsd.port.pre.mk!
-WANT_GNOME= yes
-.if defined(WITH_GNOMECONSOLE)
-USE_GNOME= libgnome
-.endif
-
-.include <bsd.port.pre.mk>
-
-PLIST_SUB+= BACULA_DIR=${BACULA_DIR}
-
-# Build gnome-console
-.if defined(WITH_GNOMECONSOLE)
-CONFIGURE_ARGS+= --enable-gnome
-PLIST_SUB+= GNOMECONS=""
-.else
-# We didn't need GTK (it's not possible to put WANT_GNOME in an .if statement!)
-WITHOUT_GNOME= yes
-PLIST_SUB+= GNOMECONS="@comment "
-.endif
-
-# Build wx-console
-.if defined(WITH_WXCONSOLE)
-CONFIGURE_ARGS+= --enable-wx-console
-LIB_DEPENDS+= wx_gtk-2.4:${PORTSDIR}/x11-toolkits/wxgtk
-CONFIGURE_ENV+= WXCONFIG=${X11BASE}/bin/wxgtk-2.4-config
-PLIST_SUB+= WXCONS=""
-.else
-# We didn't need GTK (it's not possible to put WANT_GNOME in an .if statement!)
-WITHOUT_GNOME= yes
-PLIST_SUB+= WXCONS="@comment "
-.endif
-
-# Client only or full server version
-.if defined(WITH_CLIENT_ONLY)
-CONFIGURE_ARGS+= --enable-client-only
-PLIST_SUB+= SERVER="@comment "
-.else
-.if defined(WITH_MYSQL)
-CONFIGURE_ARGS+= --with-mysql=yes
-USE_MYSQL= yes
-DBTYPE= mysql
-.elif defined(WITH_POSTGRESQL7)
-CONFIGURE_ARGS+= --with-postgresql=yes
-LIB_DEPENDS+= pq:${PORTSDIR}/databases/postgresql7
-DBTYPE= postgresql
-.else
-CONFIGURE_ARGS+= --with-sqlite=yes
-LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite
-DBTYPE= sqlite
-.endif
-PLIST_SUB+= DBTYPE=${DBTYPE}
-PLIST_SUB+= SERVER=""
-.endif
-
-# Install mtx
-.if defined(WITH_MTX)
-RUN_DEPENDS+= ${LOCALBASE}/sbin/mtx:${PORTSDIR}/misc/mtx
-.endif
-
-PORTDOCS= bacula.pdf ReleaseNotes html-manual
-
-pre-everything::
-.if !defined(WITH_CLIENT_ONLY)
- @${ECHO_MSG} "=======> ATTENTION <======="
- @${ECHO_MSG} "######################################################"
- @${ECHO_MSG} "===> Please read the file"
- @${ECHO_MSG} "===> ${DOCSDIR}/ReleaseNotes"
- @${ECHO_MSG} "===> for the upgrade procedure!"
- @${ECHO_MSG} "===> IF YOU IGNORE THIS you may !! LOSE DATA !!"
- @${ECHO_MSG} "######################################################"
- @${ECHO_MSG} "===> Note that there is a pthreads problem, which leads to the loss of 500kB"
- @${ECHO_MSG} "===> of data at the end of an tape. This is corrected in newer versions of FreeBSD"
- @${ECHO_MSG} "===> READ ${WRKSRC}/platforms/freebsd/pthreads-fix.txt"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options (or make config):"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
- @${ECHO_MSG} " WITH_WXCONSOLE=yes if you only want a wxGTK based GUI console."
- @${ECHO_MSG} " WITH_GNOMECONSOLE=yes if you only want a GNOME based GUI console."
- @${ECHO_MSG} " WITH_MTX=yes if you want to use mtx instead of chio for autochanger control."
-.if !defined(WITH_MYSQL) && !defined(WITH_POSTGRESQL7)
- @${ECHO_MSG} " WITH_MYSQL=yes if you want MySQL instead of SqLite as the database."
- @${ECHO_MSG} " WITH_POSTGRESQL7=yes if you want PostgreSQL 7.X instead of SqLite as the database."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "The default DB is SQLite!"
-.endif
- @${ECHO_MSG} ""
- @${ECHO_MSG} "===> Using ${DBTYPE} as the bacula database."
- @${ECHO_MSG} ""
-.else
- @${ECHO_MSG} "===> Building file daemon only."
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_CFLAGS}|g' ${WRKSRC}/configure
-
-post-install:
-.if defined(WITH_CLIENT_ONLY)
- # Extend only /etc/services
- @ ${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PORTNAME}
-.else
- # Extend /etc/services and install UID/GID
- @ ${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
- # Install config files and preserve existing ones
- ${INSTALL_SCRIPT} ${FILESDIR}/chio-bacula ${PREFIX}/sbin
- if [ -f ${PREFIX}/etc/bacula-barcodes ]; then \
- ${INSTALL_DATA} ${FILESDIR}/bacula-barcodes ${PREFIX}/etc/bacula-barcodes.new ; \
- ${ECHO_CMD} "etc/bacula-barcodes.new" >> ${TMPPLIST}; \
- else \
- ${INSTALL_DATA} ${FILESDIR}/bacula-barcodes ${PREFIX}/etc/bacula-barcodes.samples ; \
- ${ECHO_CMD} "etc/bacula-barcodes.samples" >> ${TMPPLIST}; \
- fi
- if [ -f ${PREFIX}/etc/bconsole.conf.new ]; then \
- ${ECHO_CMD} "etc/bconsole.conf.new" >> ${TMPPLIST}; \
- elif [ -f ${PREFIX}/etc/bconsole.conf ]; then \
- ${MV} ${PREFIX}/etc/bconsole.conf ${PREFIX}/etc/bconsole.conf.sample; \
- ${ECHO_CMD} "etc/bconsole.conf.sample" >> ${TMPPLIST}; \
- fi
-.if defined(WITH_WXCONSOLE)
- if [ -f ${PREFIX}/etc/wx-console.conf.new ]; then \
- ${ECHO_CMD} "etc/wx-console.conf.new" >> ${TMPPLIST}; \
- elif [ -f ${PREFIX}/etc/wx-console.conf ]; then \
- ${MV} ${PREFIX}/etc/wx-console.conf ${PREFIX}/etc/wx-console.conf.sample; \
- ${ECHO_CMD} "etc/wx-console.conf.sample" >> ${TMPPLIST}; \
- fi
-.endif
-.if defined(WITH_GNOMECONSOLE)
- if [ -f ${PREFIX}/etc/gnome-console.conf.new ]; then \
- ${ECHO_CMD} "etc/gnome-console.conf.new" >> ${TMPPLIST}; \
- elif [ -f ${PREFIX}/etc/gnome-console.conf ]; then \
- ${MV} ${PREFIX}/etc/gnome-console.conf ${PREFIX}/etc/gnome-console.conf.sample; \
- ${ECHO_CMD} "etc/gnome-console.conf.sample" >> ${TMPPLIST}; \
- fi
-.endif # chmod of bsmtp program so bacula can use it with dropped down permissions
- ${CHMOD} o+x ${PREFIX}/sbin/bsmtp
- ${CHOWN} -R bacula:bacula ${PREFIX}/share/bacula
-.endif
- # Install leaves existing conf files untouched. Respect this here!
- for na in sd fd dir; do \
- if [ -f ${PREFIX}/etc/bacula-$$na.conf.new ]; then \
- ${ECHO_CMD} "etc/bacula-$$na.conf.new" >> ${TMPPLIST}; \
- elif [ -f ${PREFIX}/etc/bacula-$$na.conf ]; then \
- ${MV} ${PREFIX}/etc/bacula-$$na.conf ${PREFIX}/etc/bacula-$$na.conf.sample; \
- ${ECHO_CMD} "etc/bacula-$$na.conf.sample" >> ${TMPPLIST}; \
- fi \
- done; \
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/html-manual
- cd ${WRKSRC}/doc && ${FIND} html-manual | \
- ${CPIO} -pdm -L -R root:wheel ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/bacula.pdf ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ReleaseNotes ${DOCSDIR}
-.endif
-
-# Inform user after install about important things ....
- @${ECHO_MSG} "*********************************************************************"
- @${ECHO_MSG} "NOTE:"
- @${ECHO_MSG} "Sample files are installed in ${PREFIX}/etc:"
- @${ECHO_MSG} " bconsole.conf.sample, bacula-barcodes.sample, bacula-fd.conf.sample"
-.if !defined(WITH_CLIENT_ONLY)
- @${ECHO_MSG} " bacula-sd.conf.sample, bacula-dir.conf.sample"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "An auto-changer manipulation script based on FreeBSDs"
- @${ECHO_MSG} "chio command is included and installed at"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " ${PREFIX}/sbin/chio-bacula"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Please have a look at it if you want to use an"
- @${ECHO_MSG} "autochanger. You have to configure the usage in"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " ${PREFIX}/etc/bacula-dir.conf"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Take care of correct permissions for changer and"
- @${ECHO_MSG} "tape device (e.g. /dev/ch0 and /dev/n[r]sa0) i.e."
- @${ECHO_MSG} "they must be accessible by user bacula."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Due to lack of some features in the FreeBSD tape driver"
- @${ECHO_MSG} "implementation you MUST add some OS dependent options to"
- @${ECHO_MSG} "the bacula-sd.conf file:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " Hardware End of Medium = no;"
- @${ECHO_MSG} " Backward Space Record = no;"
- @${ECHO_MSG} " Backward Space File = no;"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "With 2 filemart at EOT (see man mt):"
- @${ECHO_MSG} " Fast Forward Space File = no;"
- @${ECHO_MSG} " BSF at EOM = yes;"
- @${ECHO_MSG} " TWO EOF = yes;"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "With 1 filemart at EOT (see man mt):"
- @${ECHO_MSG} " Fast Forward Space File = yes;"
- @${ECHO_MSG} " BSF at EOM = no;"
- @${ECHO_MSG} " TWO EOF = no;"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "NOTE: YOU CAN SWITCH EOT model ONLY when starting"
- @${ECHO_MSG} " from scratch with EMPTY tapes!!!!"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "It is also important that all the scripts accessed"
- @${ECHO_MSG} "by RunBeforeJob and RunAfterJob can be executed by"
- @${ECHO_MSG} "the user bacula."
-.endif
- @${ECHO_MSG} "*********************************************************************"
-.if !defined(WITH_CLIENT_ONLY)
- @$(CAT) pkg-message
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/sysutils/bacula/distinfo b/sysutils/bacula/distinfo
deleted file mode 100644
index ebefb511e6a5..000000000000
--- a/sysutils/bacula/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (bacula-1.36.1.tar.gz) = d09ecce1bc9e3a421f7eaf5ad2de5850
-SIZE (bacula-1.36.1.tar.gz) = 6828844
diff --git a/sysutils/bacula/files/bacula-barcodes b/sysutils/bacula/files/bacula-barcodes
deleted file mode 100644
index 0a0b2dc28f24..000000000000
--- a/sysutils/bacula/files/bacula-barcodes
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Bacula barcode simulation file
-# used by ${PREFIX}/sbin/chio-bacula (FreeBSD)
-#
-# The volumenames are returned by the "changer list" command
-# labeling in the console is done by "label barcodes"
-# (then all volumes belog to the default pool).
-# All Lines with an "#" at the bedinning are ignored
-#
-# !!!! If you export an tape and reinsert another one,
-# !!!! don't forget to change the volume name in this file!
-#
-1:Volume1-100
-2:Volume1-101
-3:Volume1-102
-4:Volume1-103
-5:Volume1-104
-6:Volume1-105
-7:Volume1-106
-8:Volume1-107
-9:Volume1-108
-10:Volume1-109
-11:Volume1-110
-12:Volume1-111
-#
-# Further volumes exported from the changer
-#
-# 36GB AIT2 tapes
-#Volume1-100
-#Volume1-101
-#Volume1-102
-#Volume1-103
-#Volume1-104
-#Volume1-105
-#Volume1-106
-#Volume1-107
-#Volume1-108
-#Volume1-109
-#Volume1-110
-#Volume1-111
-#Volume1-112
-#Volume1-113
-#Volume1-114
-#Volume1-115
-#
-# 50GB AIT2 tapes
-#Volume2-200
-#Volume2-201
-#Volume2-202
-#Volume2-203
-#Volume2-204
diff --git a/sysutils/bacula/files/chio-bacula b/sysutils/bacula/files/chio-bacula
deleted file mode 100644
index a586cbd1e914..000000000000
--- a/sysutils/bacula/files/chio-bacula
+++ /dev/null
@@ -1,191 +0,0 @@
-#!/bin/sh
-#
-# Bacula interface to mtx autoloader
-# (By Lars Köller, lars+bacula@koellers.net)
-#
-# If you set in your Device resource
-#
-# Changer Command = "path-to-this-script/chio-bacula" %c %o %S %a
-# you will have the following input to this script:
-#
-# chio-bacula "changer-device" "command" "slot" "archive-device" "drive-index"
-# $1 $2 $3 $4 $5
-# for example:
-#
-# chio-bacula /dev/sg0 load 1 /dev/nst0 0 (on a FreeBSD system)
-#
-# If you need to to an offline, refer to the drive as $4
-# e.g. mt -f $f offline
-#
-# Many changers need an offline after the unload. Also many
-# changers need a sleep 60 after the mtx load.
-#
-# N.B. If you change the script, take care to return either
-# the mtx exit code or a 0. If the script exits with a non-zero
-# exit code, Bacula will assume the request failed.
-#
-
-# This simulates a barcode reader in the changer.
-# The labes of the virtual barcode reader are located in the BARCODE_FILE
-SIMULATE_BARCODE=true
-BARCODE_FILE=/usr/local/etc/bacula-barcodes
-MTX=/bin/chio
-# Set default values (see case statement below for
-# free mapping of drive index and tape device
-# We have a double drive Qualstar where drive 1 is the default bacula drive
-TAPE=/dev/nrsa0
-DRIVE=0
-# Time to wait for (un)loading
-SLEEP=20
-
-me=$(basename $0)
-
-# Debug
-logger -p user.err "$me $@"
-
-# The changer device
-if [ -z "$1" ] ; then
- usage;
-else
- CHANGER=$1
-fi
-# The command
-if [ -z "$2" ] ; then
- usage;
-else
- COMMAND=$2
-fi
-# The slot number
-if [ ! -z "$3" ]; then
- SLOT=$3
- # btape fill says "... slot 1 drive 0" :-(
- if [ "$SLOT" = "slot" ]; then
- shift
- SLOT=$3
- fi
-fi
-# Set tape device
-if [ ! -z "$4" ]; then
- TAPE=$4
-fi
-# Set drive for chio as you need
-# here you can also map to any tape device
-# DRIVE is the chio drive number!
-case $5 in
- 0)
- DRIVE=0
- TAPE=/dev/nrsa0
- #DRIVE=1
- #TAPE=/dev/nrsa2
- ;;
- 1)
- DRIVE=1
- #DRIVE=0
- TAPE=/dev/nrsa1
- ;;
-esac
-
-usage()
-{
- echo ""
- echo "The $me script for bacula"
- echo "--------------------------------------"
- echo ""
- echo "usage: $me <changer-device> <command> [slot] [devicename of tapedrive] [drive index]"
- echo ""
- echo "Valid commands:"
- echo ""
- echo "unload Unloads a tape into the slot"
- echo " from where it was loaded."
- echo "load <slot> Loads a tape from the slot <slot>"
- echo " (slot-base is calculated to 1 as first slot)"
- echo "list Lists full storage slots"
- echo "loaded Gives slot from where the tape was loaded."
- echo " 0 means the tape drive is empty."
- echo "slots Gives Number of aviable slots."
- echo ""
- echo "Example:"
- echo " mtx-changer /dev/changer load 1 loads a tape from slot 1"
- echo ""
- exit 2
-}
-
-
-case ${COMMAND} in
- unload)
- # enable the following line if you need to eject the cartridge
- mt -f ${TAPE} off
- sleep 2
- # if we have a slot, try it
- if [ ! -z "$SLOT" ]; then
- ${MTX} -f ${CHANGER} move drive ${DRIVE} slot $((${SLOT}-1))
- exit $?
- fi
- # Try other way (works if source element information is valid for drive)
- ${MTX} -f ${CHANGER} return drive ${DRIVE}
- # If the changer is power cycled with a tape loaded in a drive
- # we can compute the slot in case of a complete filled magazine, with
- # one slot free.
- if [ "$?" != "0" ]; then
- free_slot=`${MTX} -f ${CHANGER} stat | grep "^slot " | grep -v "FULL" | awk '{print $2}'`
- free_slot=${free_slot%:}
- ${MTX} -f ${CHANGER} move drive ${DRIVE} slot $free_slot
- fi
- ;;
-
- load)
- ${MTX} -f ${CHANGER} move slot $((${SLOT}-1)) drive ${DRIVE}
- rtn=$?
- # Increase the sleep time if you have a slow device
- sleep $SLEEP
- exit $rtn
- ;;
-
- list)
- if [ "${SIMULATE_BARCODE}" = "true" ]; then
- if [ -f "$BARCODE_FILE" ]; then
- cat $BARCODE_FILE | grep -v "^#"
- exit 0
- else
- echo "Barcode file $BARCODE_FILE missing ... exiting!"
- exit 1
- fi
- else
- ${MTX} -f ${CHANGER} status | grep "^slot .*: .*FULL>" | awk '{print $2}' | awk -F: '{print $1+1" "}' | tr -d "[\r\n]"
- fi
- ;;
-
- loaded)
- # echo "Request loaded"
- ${MTX} -f ${CHANGER} status -S > /tmp/mtx.$$
- rtn=$?
- # Try to get chio slot source from drive entry
- SLOT=$(cat /tmp/mtx.$$ | grep "^drive ${DRIVE}: <FULL> .*slot" | awk '{print $6+1}' | tr -d ">")
- if [ -z "$SLOT" ]; then
- # This handles the case a source slot is not available (power on
- # of the changer with a drive loaded) and all other slots are
- # occupied with a tape!
- SLOT=$(cat /tmp/mtx.$$ | grep "^slot .*: <ACCESS>" | awk '{print $2+1}')
- if [ -z "$SLOT" ]; then
- echo 0
- else
- echo $SLOT
- fi
- else
- echo $SLOT
- fi
- # All tapes are in the slots
- #cat /tmp/mtx.$$ | grep "^drive ${DRIVE}: .* source: <>" | awk "{print 0}"
- rm -f /tmp/mtx.$$
- exit $rtn
- ;;
-
- slots)
- # echo "Request slots"
- ${MTX} -f ${CHANGER} status | grep "^slot " | tail -1 | awk '{print $2+1}' | tr -d ":"
- ;;
-
- *)
- usage
- ;;
-esac
diff --git a/sysutils/bacula/files/patch-autoconf-Make.common.in b/sysutils/bacula/files/patch-autoconf-Make.common.in
deleted file mode 100644
index ca86ad0ebff5..000000000000
--- a/sysutils/bacula/files/patch-autoconf-Make.common.in
+++ /dev/null
@@ -1,19 +0,0 @@
-*** autoconf/Make.common.in.orig Sat Jun 19 23:16:06 2004
---- autoconf/Make.common.in Sun Jun 27 18:38:11 2004
-***************
-*** 43,49 ****
- RANLIB = @RANLIB@
- INSTALL = @INSTALL@
- # add the -s to the following in PRODUCTION mode
-! INSTALL_PROGRAM = @INSTALL@ -m @SBINPERM@
- INSTALL_DATA = @INSTALL@ -m 644
- INSTALL_SCRIPT = @INSTALL@ -m @SBINPERM@
- INSTALL_CONFIG = @INSTALL@ -m 640
---- 44,50 ----
- RANLIB = @RANLIB@
- INSTALL = @INSTALL@
- # add the -s to the following in PRODUCTION mode
-! INSTALL_PROGRAM = @INSTALL@ -s -m @SBINPERM@
- INSTALL_DATA = @INSTALL@ -m 644
- INSTALL_SCRIPT = @INSTALL@ -m @SBINPERM@
- INSTALL_CONFIG = @INSTALL@ -m 640
diff --git a/sysutils/bacula/files/patch-scripts-Makefile.in b/sysutils/bacula/files/patch-scripts-Makefile.in
deleted file mode 100644
index f5e2cee7d1b3..000000000000
--- a/sysutils/bacula/files/patch-scripts-Makefile.in
+++ /dev/null
@@ -1,43 +0,0 @@
-*** scripts/Makefile.in.orig Wed Nov 17 23:48:21 2004
---- scripts/Makefile.in Sun Nov 28 15:00:56 2004
-***************
-*** 32,50 ****
- $(MKDIR) $(DESTDIR)$(scriptdir)
-
- install: installdirs
-! $(INSTALL_SCRIPT) startmysql $(DESTDIR)$(scriptdir)/startmysql
-! $(INSTALL_SCRIPT) stopmysql $(DESTDIR)$(scriptdir)/stopmysql
-! $(INSTALL_SCRIPT) bconsole $(DESTDIR)$(scriptdir)/bconsole
-! $(INSTALL_SCRIPT) gconsole $(DESTDIR)$(scriptdir)/gconsole
-! $(INSTALL_SCRIPT) bacula $(DESTDIR)$(scriptdir)/bacula
- @if test -f ${DESTDIR}${scriptdir}/mtx-changer; then \
- echo " ==> Saving existing mtx-changer to mtx-changer.old"; \
- $(MV) -f ${DESTDIR}${scriptdir}/mtx-changer ${DESTDIR}${scriptdir}/mtx-changer.old; \
- fi
- $(INSTALL_SCRIPT) mtx-changer $(DESTDIR)$(scriptdir)/mtx-changer
-! $(INSTALL_DATA) btraceback.gdb $(DESTDIR)$(scriptdir)/btraceback.gdb
-! $(INSTALL_DATA) btraceback.dbx $(DESTDIR)$(scriptdir)/btraceback.dbx
-! $(INSTALL_SCRIPT) btraceback $(DESTDIR)$(sbindir)/btraceback
-
- uninstall:
- (cd $(DESTDIR)$(scriptdir); $(RMF) startmysql)
---- 32,50 ----
- $(MKDIR) $(DESTDIR)$(scriptdir)
-
- install: installdirs
-! # $(INSTALL_SCRIPT) startmysql $(DESTDIR)$(scriptdir)/startmysql
-! # $(INSTALL_SCRIPT) stopmysql $(DESTDIR)$(scriptdir)/stopmysql
-! # $(INSTALL_SCRIPT) bconsole $(DESTDIR)$(scriptdir)/bconsole
-! # $(INSTALL_SCRIPT) gconsole $(DESTDIR)$(scriptdir)/gconsole
-! $(INSTALL_SCRIPT) bacula $(DESTDIR)$(sysconfdir)/rc.d/bacula.sh.sample
- @if test -f ${DESTDIR}${scriptdir}/mtx-changer; then \
- echo " ==> Saving existing mtx-changer to mtx-changer.old"; \
- $(MV) -f ${DESTDIR}${scriptdir}/mtx-changer ${DESTDIR}${scriptdir}/mtx-changer.old; \
- fi
- $(INSTALL_SCRIPT) mtx-changer $(DESTDIR)$(scriptdir)/mtx-changer
-! # $(INSTALL_DATA) btraceback.gdb $(DESTDIR)$(scriptdir)/btraceback.gdb
-! # $(INSTALL_DATA) btraceback.dbx $(DESTDIR)$(scriptdir)/btraceback.dbx
-! # $(INSTALL_SCRIPT) btraceback $(DESTDIR)$(sbindir)/btraceback
-
- uninstall:
- (cd $(DESTDIR)$(scriptdir); $(RMF) startmysql)
diff --git a/sysutils/bacula/files/patch-src-console-Makefile.in b/sysutils/bacula/files/patch-src-console-Makefile.in
deleted file mode 100644
index e31efc2e2a9d..000000000000
--- a/sysutils/bacula/files/patch-src-console-Makefile.in
+++ /dev/null
@@ -1,19 +0,0 @@
-*** src/console/Makefile.in.org Sat Apr 3 20:40:26 2004
---- src/console/Makefile.in Sat May 8 14:01:49 2004
-***************
-*** 89,95 ****
- destconf=$$srcconf; \
- if test -f ${DESTDIR}${sysconfdir}/console.conf; then \
- echo "Existing console.conf moved to bconsole.conf"; \
-! @$(MV) ${DESTDIR}${sysconfdir}/console.conf ${DESTDIR}${sysconfdir}/bconsole.conf; \
- destconf=$$srcconf.new; \
- fi; \
- fi; \
---- 89,95 ----
- destconf=$$srcconf; \
- if test -f ${DESTDIR}${sysconfdir}/console.conf; then \
- echo "Existing console.conf moved to bconsole.conf"; \
-! $(MV) ${DESTDIR}${sysconfdir}/console.conf ${DESTDIR}${sysconfdir}/bconsole.conf; \
- destconf=$$srcconf.new; \
- fi; \
- fi; \
diff --git a/sysutils/bacula/files/patch-src-console-console.c b/sysutils/bacula/files/patch-src-console-console.c
deleted file mode 100644
index bbdf05da6702..000000000000
--- a/sysutils/bacula/files/patch-src-console-console.c
+++ /dev/null
@@ -1,63 +0,0 @@
-*** src/console/console.c.orig Sun Jun 20 13:43:02 2004
---- src/console/console.c Sat Jul 3 10:48:13 2004
-***************
-*** 63,69 ****
-
- /* Forward referenced functions */
- static void terminate_console(int sig);
-! int get_cmd(FILE *input, const char *prompt, BSOCK *sock, int sec);
- static int do_outputcmd(FILE *input, BSOCK *UA_sock);
- void senditf(const char *fmt, ...);
- void sendit(const char *buf);
---- 63,69 ----
-
- /* Forward referenced functions */
- static void terminate_console(int sig);
-! int get_cmd(FILE *input, char *prompt, BSOCK *sock, int sec);
- static int do_outputcmd(FILE *input, BSOCK *UA_sock);
- void senditf(const char *fmt, ...);
- void sendit(const char *buf);
-***************
-*** 200,206 ****
-
- static void read_and_process_input(FILE *input, BSOCK *UA_sock)
- {
-! const char *prompt = "*";
- bool at_prompt = false;
- int tty_input = isatty(fileno(input));
- int stat;
---- 200,206 ----
-
- static void read_and_process_input(FILE *input, BSOCK *UA_sock)
- {
-! char *prompt = "*";
- bool at_prompt = false;
- int tty_input = isatty(fileno(input));
- int stat;
-***************
-*** 499,510 ****
- #ifdef HAVE_READLINE
- #define READLINE_LIBRARY 1
- #undef free
- #include "readline.h"
- #include "history.h"
-
--
- int
-! get_cmd(FILE *input, const char *prompt, BSOCK *sock, int sec)
- {
- char *line;
-
---- 499,510 ----
- #ifdef HAVE_READLINE
- #define READLINE_LIBRARY 1
- #undef free
-+ #include <stdio.h>
- #include "readline.h"
- #include "history.h"
-
- int
-! get_cmd(FILE *input, char *prompt, BSOCK *sock, int sec)
- {
- char *line;
-
diff --git a/sysutils/bacula/pkg-deinstall b/sysutils/bacula/pkg-deinstall
deleted file mode 100644
index 28189213142e..000000000000
--- a/sysutils/bacula/pkg-deinstall
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-
-PATH=/bin:/usr/bin:/usr/sbin
-TMPFILE=/tmp/services-$RANDOM-$$
-if [ -z "${BACULA_DIR}" ]; then
- BACULA_DIR=/var/db/bacula
-fi
-
-case "$2" in
-"DEINSTALL")
- # Delete entries in /etc/services
- sed -e '/# Bacula port start/,/# Bacule port end/{' \
- -e 'd' \
- -e '}' /etc/services > $TMPFILE
- mv -f $TMPFILE /etc/services
-
- # Note how to delete UID/GID
- USER=bacula
- GROUP=${USER}
- if pw usershow "${USER}" 2>/dev/null 1>&2; then
- echo "To delete Bacula user permanently, use 'pw userdel ${USER}'"
- echo "To delete Bacula group permanently, use 'pw groupdel ${GROUP}'"
- echo "Check if ${BACULA_DIR} is empty and delete it to permanently remove the port"
- fi
- ;;
-esac
diff --git a/sysutils/bacula/pkg-descr b/sysutils/bacula/pkg-descr
deleted file mode 100644
index 4167c26533dc..000000000000
--- a/sysutils/bacula/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
-Bacula is a set of computer programs that permit you (or the system
-administrator) to manage backup, recovery, and verification of
-computer data across a network of computers of different kinds.
-In technical terms, it is a network Client/Server based backup program.
-Bacula is relatively easy to use and efficient, while offering many
-advanced storage management features that make it easy to find and
-recover lost or damaged files. Due to its modular design, Bacula is
-scalable from small single computer systems to systems consisting of
-hundreds of computers located over a large network.
-
-WWW: http://www.bacula.org/
diff --git a/sysutils/bacula/pkg-install b/sysutils/bacula/pkg-install
deleted file mode 100644
index 460b57fbfd6a..000000000000
--- a/sysutils/bacula/pkg-install
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/bin/sh
-
-PATH=/bin:/usr/bin:/usr/sbin
-if [ -z "${BACULA_DIR}" ]; then
- BACULA_DIR=/var/db/bacula
-fi
-
-# Always add lines in /etc/services
-grep -q "bacula-dir" /etc/services
-if [ "$?" != "0" ]; then
- echo "# Bacula port start
-bacula-dir 9101/tcp #Bacula director daemon
-bacula-fd 9102/tcp #Bacula file daemon
-bacula-sd 9103/tcp #Bacula storage daemon
-# Bacule port end" >> /etc/services
-fi
-
-case $2 in
-POST-INSTALL)
- # Install UID/GID
- USER=bacula
- GROUP=${USER}
- UID=910
- GID=${UID}
-
- if pw group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- if pw usermod ${USER} -d ${BACULA_DIR} -G operator
- then
- echo "Changed home directory of \"${USER}\" to \"${BACULA_DIR}\""
- else
- echo "Changing home directory of \"${USER}\" to \"${BACULA_DIR}\" failed..."
- exit 1
- fi
- else
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -G operator -h - \
- -d ${BACULA_DIR} -s /sbin/nologin -c "Bacula Daemon"
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
- chown -R ${USER}:${GROUP} ${BACULA_DIR}
- ;;
-esac
diff --git a/sysutils/bacula/pkg-message b/sysutils/bacula/pkg-message
deleted file mode 100644
index 3d9d7a8d06ff..000000000000
--- a/sysutils/bacula/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
-################################################################################
- Please read the file"
-
- ${DOCSDIR}/ReleaseNotes"
-
- for the upgrade procedure!
-
- IF YOU IGNORE THIS you may !! LOSE DATA !!
-
-################################################################################
diff --git a/sysutils/bacula/pkg-plist b/sysutils/bacula/pkg-plist
deleted file mode 100644
index 0bbb75ba717e..000000000000
--- a/sysutils/bacula/pkg-plist
+++ /dev/null
@@ -1,35 +0,0 @@
-%%SERVER%%share/bacula/query.sql
-etc/rc.d/bacula.sh.sample
-%%SERVER%%sbin/chio-bacula
-%%SERVER%%sbin/bacula-dir
-sbin/bacula-fd
-%%SERVER%%sbin/bacula-sd
-%%SERVER%%sbin/bextract
-%%SERVER%%sbin/bcopy
-%%SERVER%%sbin/bls
-%%SERVER%%sbin/bscan
-%%SERVER%%sbin/btape
-sbin/bconsole
-%%WXCONS%%sbin/wx-console
-%%GNOMECONS%%sbin/gnome-console
-%%SERVER%%sbin/dbcheck
-%%SERVER%%sbin/bsmtp
-%%SERVER%%share/bacula/mtx-changer
-%%SERVER%%share/bacula/create_bacula_database
-%%SERVER%%share/bacula/create_%%DBTYPE%%_database
-%%SERVER%%share/bacula/drop_bacula_database
-%%SERVER%%share/bacula/drop_%%DBTYPE%%_database
-%%SERVER%%share/bacula/drop_bacula_tables
-%%SERVER%%share/bacula/drop_%%DBTYPE%%_tables
-%%SERVER%%share/bacula/grant_bacula_privileges
-%%SERVER%%share/bacula/grant_%%DBTYPE%%_privileges
-%%SERVER%%share/bacula/make_bacula_tables
-%%SERVER%%share/bacula/make_%%DBTYPE%%_tables
-%%SERVER%%share/bacula/update_bacula_tables
-%%SERVER%%share/bacula/update_%%DBTYPE%%_tables
-%%SERVER%%share/bacula/delete_catalog_backup
-%%SERVER%%share/bacula/make_catalog_backup
-%%SERVER%%@dirrm share/bacula
-@unexec /usr/bin/killall badula-sd > /dev/null 2>&1 || true
-@unexec /usr/bin/killall bacula-dir > /dev/null 2>&1 || true
-@exec mkdir -p %%BACULA_DIR%%