aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-06 06:19:14 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-06 06:19:14 +0000
commit76d4d8ef82ef66caf2513f74a3e72624c203cc9d (patch)
tree07f41283903e7d162daaa33094ee2d73541066e1
parent15b3c0ae6c0e9bd7462cd689a09cdd99c41bd0d8 (diff)
downloadports-76d4d8ef82ef66caf2513f74a3e72624c203cc9d.tar.gz
ports-76d4d8ef82ef66caf2513f74a3e72624c203cc9d.zip
Notes
-rw-r--r--mail/p5-qpsmtpd/Makefile2
-rw-r--r--www/p5-Apache-AuthCookie/Makefile2
-rw-r--r--www/p5-Apache-DB/Makefile2
-rw-r--r--www/p5-Apache-MP3/Makefile10
4 files changed, 8 insertions, 8 deletions
diff --git a/mail/p5-qpsmtpd/Makefile b/mail/p5-qpsmtpd/Makefile
index 46a578a08dae..0fef3e5e8f39 100644
--- a/mail/p5-qpsmtpd/Makefile
+++ b/mail/p5-qpsmtpd/Makefile
@@ -28,7 +28,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS = MODPERL "Enable Apache Support via mod_perl" On
.ifdef WITH_MODPERL
-RUN_DEPENDS+= mod_perl2>=0:${PORTSDIR}/www/mod_perl2
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
.endif
MAKE_JOBS_SAFE= yes
diff --git a/www/p5-Apache-AuthCookie/Makefile b/www/p5-Apache-AuthCookie/Makefile
index 3bfd85379ee4..2f84e1aa0991 100644
--- a/www/p5-Apache-AuthCookie/Makefile
+++ b/www/p5-Apache-AuthCookie/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A perl module to provide custom forms for reauthentication
-BUILD_DEPENDS= mod_perl2>=0:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_APACHE= 20+
diff --git a/www/p5-Apache-DB/Makefile b/www/p5-Apache-DB/Makefile
index 184243ce827b..f3c56b42fa9f 100644
--- a/www/p5-Apache-DB/Makefile
+++ b/www/p5-Apache-DB/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Debugging and profiling tools for mod_perl
-RUN_DEPENDS= mod_perl2>=0:${PORTSDIR}/www/mod_perl2
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
MAKE_JOBS_SAFE= yes
diff --git a/www/p5-Apache-MP3/Makefile b/www/p5-Apache-MP3/Makefile
index 137f898c4f6a..3e2b78544091 100644
--- a/www/p5-Apache-MP3/Makefile
+++ b/www/p5-Apache-MP3/Makefile
@@ -15,11 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= MP3 browsing and streaming under mod_perl and Apache
-BUILD_DEPENDS= p5-Audio-Wav>=0:${PORTSDIR}/audio/p5-Audio-Wav \
- p5-CGI-Session>=0:${PORTSDIR}/www/p5-CGI-Session \
- p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info \
- p5-Ogg-Vorbis-Header>=0:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header \
- mod_perl2>=0:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS= ${SITE_PERL}/Audio/Wav.pm:${PORTSDIR}/audio/p5-Audio-Wav \
+ ${SITE_PERL}/CGI/Session.pm:${PORTSDIR}/www/p5-CGI-Session \
+ ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
+ ${SITE_PERL}/${PERL_ARCH}/Ogg/Vorbis/Header.pm:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header \
+ ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES