aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-28 09:33:33 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-28 09:33:33 +0000
commit7c95143f4f9b4dec59d797fa718ebf1dfc366bf1 (patch)
tree5d0b9cda6b787e97fe795bd6434023a32ad6516c
parent96906f5359174bf48ea14944276afbbb5145c043 (diff)
downloadports-7c95143f4f9b4dec59d797fa718ebf1dfc366bf1.tar.gz
ports-7c95143f4f9b4dec59d797fa718ebf1dfc366bf1.zip
Notes
-rw-r--r--print/Makefile1
-rw-r--r--print/panda/Makefile71
-rw-r--r--print/panda/distinfo1
-rw-r--r--print/panda/files/BSDMakefile34
-rw-r--r--print/panda/pkg-comment1
-rw-r--r--print/panda/pkg-descr3
-rw-r--r--print/panda/pkg-plist26
7 files changed, 137 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 033c1ce79829..0d9455a809a7 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -77,6 +77,7 @@
SUBDIR += p5-GnomePrint
SUBDIR += p5-Text-PDF
SUBDIR += pnm2ppa
+ SUBDIR += panda
SUBDIR += pclprint
SUBDIR += pdflib
SUBDIR += pdflib3
diff --git a/print/panda/Makefile b/print/panda/Makefile
new file mode 100644
index 000000000000..355f9e0186d3
--- /dev/null
+++ b/print/panda/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: Panda
+# Date created: 28 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= panda
+PORTVERSION= 0.4.p1
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= panda
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g:S/p/rc/}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.4:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.p/-rc/}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" \
+ CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${PREFIX}/lib" \
+ LIBS="${PTHREAD_LIBS}"
+INSTALLS_SHLIB= yes
+
+MAN3= checkinfo.3 initpanda.3 makedate.3 nowdate.3 \
+ panda-textmodes.3 panda-xobjectmodes.3 pdfclose.3 \
+ pdfopen.3 pdfpage.3 setauthor.3 setcharacterspacing.3 \
+ setcreator.3 setfont.3 setfontmode.3 setfontsize.3 \
+ sethorizontalscaling.3 setkeywords.3 setleading.3 \
+ setsubject.3 settitle.3 setwordspacing.3
+
+DOCS= AUTHORS BUGS CONTRIBUTORS ChangeLog \
+ DEV-HINTS README TODO UNDERWAY
+EXAMPLES= IMAGES *.jpg *.png *.tif main.c legacymain.c
+
+post-configure:
+# GNU make doesn't have a -V option, so we have to add a shot_VARIABLE
+# target for each variable and run gmake show_VARIABLE to look it up.
+ cd ${WRKSRC} && ${PERL} -pe 's/%%(\w+)%%/ \
+ open(H, ">> Makefile"); \
+ print H "show_$$1:; \@echo \$$($$1)\n"; \
+ close(H); \
+ $$_ = `${GMAKE} show_$$1`; \
+ chomp; \
+ $$_; \
+ /eg' \
+ ${FILESDIR}/BSDMakefile > ${WRKSRC}/BSDMakefile
+
+pre-build:
+ @cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f BSDMakefile ${MAKE_ARGS} ${ALL_TARGET}
+
+post-install:
+ @cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f BSDMakefile ${MAKE_ARGS} ${INSTALL_TARGET}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/
+.endfor
+ ${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/panda/distinfo b/print/panda/distinfo
new file mode 100644
index 000000000000..07db1efe0abd
--- /dev/null
+++ b/print/panda/distinfo
@@ -0,0 +1 @@
+MD5 (panda_0_4_rc1.tgz) = 25a203277383bed7a5563fae118d9600
diff --git a/print/panda/files/BSDMakefile b/print/panda/files/BSDMakefile
new file mode 100644
index 000000000000..85572b3dff13
--- /dev/null
+++ b/print/panda/files/BSDMakefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+LIB= panda
+SHLIB_MAJOR?= 0
+SHLIB_MINOR?= 0
+CFLAGS+= %%DEFS%% %%INCLUDES%% %%AM_CPPFLAGS%% %%CPPFLAGS%% %%AM_CFLAGS%%
+LDADD= %%LDFLAGS%% %%LIBS%%
+SRCS= %%libpanda_a_SOURCES%%
+INCS= ${LIB}/*.h
+NOMAN= YES
+LIBDIR= ${LOCALBASE}/lib
+INCDIR= ${LOCALBASE}/include/${LIB}
+
+.include <bsd.lib.mk>
+
+# For FreeBSD 3.x or older
+.if !target(_includeinstall)
+_includeinstall:
+.if defined(INCS)
+.for header in ${INCS}
+ cd ${.CURDIR} && \
+ ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
+ ${header} ${DESTDIR}${INCDIR}
+
+.endfor
+.endif
+
+beforeinstall: _includeinstall
+.endif
+
+_includeinstall: pre-_includeinstall
+
+pre-_includeinstall:
+ mkdir -p ${DESTDIR}${INCDIR}
diff --git a/print/panda/pkg-comment b/print/panda/pkg-comment
new file mode 100644
index 000000000000..38139c608a5e
--- /dev/null
+++ b/print/panda/pkg-comment
@@ -0,0 +1 @@
+A GPL'ed PDF generation library
diff --git a/print/panda/pkg-descr b/print/panda/pkg-descr
new file mode 100644
index 000000000000..9f3935e9cc9c
--- /dev/null
+++ b/print/panda/pkg-descr
@@ -0,0 +1,3 @@
+Panda is a GPL'ed PDF generation library.
+
+WWW: http://www.stillhq.com/cgi-bin/getpage?area=panda&page=index.htm
diff --git a/print/panda/pkg-plist b/print/panda/pkg-plist
new file mode 100644
index 000000000000..7221d10698be
--- /dev/null
+++ b/print/panda/pkg-plist
@@ -0,0 +1,26 @@
+include/panda/constants.h
+include/panda/functions.h
+include/panda/objects.h
+include/panda/legacy.h
+@dirrm include/panda
+lib/libpanda.a
+%%PORTDOCS%%share/doc/panda/AUTHORS
+%%PORTDOCS%%share/doc/panda/BUGS
+%%PORTDOCS%%share/doc/panda/CONTRIBUTORS
+%%PORTDOCS%%share/doc/panda/ChangeLog
+%%PORTDOCS%%share/doc/panda/DEV-HINTS
+%%PORTDOCS%%share/doc/panda/README
+%%PORTDOCS%%share/doc/panda/TODO
+%%PORTDOCS%%share/doc/panda/UNDERWAY
+%%PORTDOCS%%@dirrm share/doc/panda
+%%PORTDOCS%%share/examples/panda/IMAGES
+%%PORTDOCS%%share/examples/panda/brave-gnu.png
+%%PORTDOCS%%share/examples/panda/gnu-head.jpg
+%%PORTDOCS%%share/examples/panda/gnu-head.png
+%%PORTDOCS%%share/examples/panda/gnu_box.jpg
+%%PORTDOCS%%share/examples/panda/input-ms.tif
+%%PORTDOCS%%share/examples/panda/input.tif
+%%PORTDOCS%%share/examples/panda/input2.tif
+%%PORTDOCS%%share/examples/panda/legacymain.c
+%%PORTDOCS%%share/examples/panda/main.c
+%%PORTDOCS%%@dirrm share/examples/panda