aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-12-20 10:23:35 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-12-20 10:23:35 +0000
commit838192f6f09f9be77596cbe60574535b0bb7cb77 (patch)
tree01ec0ff37d66ad96aac954028aa80abf9b4af536
parent55c3fef16a049a86bc68a659c112a7b020e3fd49 (diff)
downloadports-838192f6f09f9be77596cbe60574535b0bb7cb77.tar.gz
ports-838192f6f09f9be77596cbe60574535b0bb7cb77.zip
MFH: r520301 devel/py-pyrsistent: Level up ports compliance
- Match COMMENT to setup.py:description (modulo portlint requirements) - Strip shared library - Add test target and match dependency version requirements Approved by: koobs (python: maintainer) Approved by: ports-secteam (blanket: ports compliance)
Notes
Notes: svn path=/branches/2019Q4/; revision=520497
-rw-r--r--devel/py-pyrsistent/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/devel/py-pyrsistent/Makefile b/devel/py-pyrsistent/Makefile
index e5aa3a1b8f98..14a7ebb93ff7 100644
--- a/devel/py-pyrsistent/Makefile
+++ b/devel/py-pyrsistent/Makefile
@@ -2,21 +2,28 @@
PORTNAME= pyrsistent
PORTVERSION= 0.14.11
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
-COMMENT= Persistent/Immutable/Functional data structures for Python
+COMMENT= Persistent/Functional/Immutable data structures
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENCE.mit
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hypothesis>=0:devel/py-hypothesis@${PY_FLAVOR} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hypothesis<5:devel/py-hypothesis@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent distutils
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pvectorc.so
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+
.include <bsd.port.mk>