aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-10-28 23:02:26 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-10-28 23:02:26 +0000
commit91c58f29a60b1df1fc56da26770f6641b511d2de (patch)
treecfc85f00511a6071167927cf677b9d935981f20f
parentae51ddccf2228b62cd5dc165847212b63c9fb418 (diff)
downloadports-91c58f29a60b1df1fc56da26770f6641b511d2de.tar.gz
ports-91c58f29a60b1df1fc56da26770f6641b511d2de.zip
Notes
-rw-r--r--devel/commoncpp/Makefile8
-rw-r--r--net-p2p/gnunet/Makefile8
-rw-r--r--net/gnunet/Makefile8
-rw-r--r--security/cfs/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 852a83647b12..113002ca2ac4 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -36,7 +36,13 @@ INFO= commoncpp2
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700000
+BROKEN= "Does not compile on FreeBSD >= 7.0"
+.endif
+
pre-configure:
@${CP} ${LTMAIN} ${WRKSRC}/autoconf
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index a79991ce37e8..01d1c973446c 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -102,6 +102,12 @@ MAN1= gnunet-chat.1 gnunet-check.1 gnunet-convert.1 \
gnunet-update.1 gnunetd.1
MAN5= gnunet.conf.5
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700000
+BROKEN= "Does not compile on FreeBSD >= 7.0"
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You can build GNUnet with the following options:"
@@ -134,4 +140,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index a79991ce37e8..01d1c973446c 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -102,6 +102,12 @@ MAN1= gnunet-chat.1 gnunet-check.1 gnunet-convert.1 \
gnunet-update.1 gnunetd.1
MAN5= gnunet.conf.5
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700000
+BROKEN= "Does not compile on FreeBSD >= 7.0"
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You can build GNUnet with the following options:"
@@ -134,4 +140,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/cfs/Makefile b/security/cfs/Makefile
index 8f998252dc77..e076781a9012 100644
--- a/security/cfs/Makefile
+++ b/security/cfs/Makefile
@@ -25,6 +25,12 @@ SUB_FILES= pkg-message
SUB_LIST= CFSD_BOOTSTRAP=${CFSD_BOOTSTRAP}
PLIST_SUB= CFSD_BOOTSTRAP=${CFSD_BOOTSTRAP}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700000
+BROKEN= "Does not compile on FreeBSD >= 7.0"
+.endif
+
post-patch:
${REINPLACE_CMD} 's/^\.TH SSH/.TH CFSSH/' ${WRKSRC}/cfssh.1
@@ -40,4 +46,4 @@ do-install:
${INSTALL} -d ${_BINOWNGRP} -m 0 ${CFSD_BOOTSTRAP}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>