aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-29 14:53:23 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-29 14:53:23 +0000
commit921597722013b1123b6775e8f314063132cca72a (patch)
tree3b60dfc298ce215e08fe82984e17fdbbdd5feacd
parent34063c028207afd0e6fde774216128e13210357e (diff)
downloadports-921597722013b1123b6775e8f314063132cca72a.tar.gz
ports-921597722013b1123b6775e8f314063132cca72a.zip
Notes
-rw-r--r--lang/phantomjs/Makefile2
-rw-r--r--mail/opendkim/Makefile3
-rw-r--r--multimedia/librtmp/Makefile3
-rw-r--r--net/liboauth/Makefile3
-rw-r--r--net/qt4-network/Makefile3
-rw-r--r--net/qt5-network/Makefile3
-rw-r--r--security/botan110/Makefile3
-rw-r--r--security/dsniff/Makefile3
-rw-r--r--security/krb5-116/Makefile3
-rw-r--r--security/libssh/Makefile3
-rw-r--r--security/openssh-portable/Makefile3
-rw-r--r--security/py-m2crypto/Makefile3
-rw-r--r--www/nghttp2/Makefile3
13 files changed, 37 insertions, 1 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index d2e3084e2b2c..9787745ea65a 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -14,6 +14,8 @@ BROKEN_powerpc64= fails to build: g++48: not found
BROKEN_sparc64= does not link on sparc64
NOT_FOR_ARCHS= armv6 armv7
NOT_FOR_ARCHS_REASON= Platform.h: Not supported ARM architecture
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: member access into incomplete type 'X509' (aka 'x509_st')
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libfreetype.so:print/freetype2 \
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 445bb09aa85c..6d7563e88a80 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -20,6 +20,9 @@ LICENSE_GROUPS_SENDMAIL=FSF OSI
LICENSE_NAME_SENDMAIL= Sendmail Open Source License
LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= checking for library containing SSL_library_init... no
+
GNU_CONFIGURE= yes
NO_OPTIONS_SORT=yes
USES= libtool perl5 pkgconfig shebangfix ssl
diff --git a/multimedia/librtmp/Makefile b/multimedia/librtmp/Makefile
index dea0e49fd9b9..e3543e96a42d 100644
--- a/multimedia/librtmp/Makefile
+++ b/multimedia/librtmp/Makefile
@@ -11,6 +11,9 @@ COMMENT= RTMP stream library
LICENSE= GPLv2
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: incomplete definition of type 'struct dh_st'
+
USES= pkgconfig tar:bz2 ssl
USE_LDCONFIG= yes
CFLAGS+= -I${OPENSSLINC}
diff --git a/net/liboauth/Makefile b/net/liboauth/Makefile
index f821ceee868f..f442a5b8ac98 100644
--- a/net/liboauth/Makefile
+++ b/net/liboauth/Makefile
@@ -12,6 +12,9 @@ COMMENT= C library implementing the OAuth Core standard
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING.MIT
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: variable has incomplete type 'EVP_MD_CTX' (aka 'struct evp_md_ctx_st')
+
LIB_DEPENDS= libcurl.so:ftp/curl
USES= libtool pkgconfig ssl
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index 29214b0538d1..e6a0589d5d50 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -13,6 +13,9 @@ COMMENT= Qt network module
LICENSE= GPLv3 LGPL21 LGPL3 GFDL
LICENSE_COMB= dual
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: member access into incomplete type 'RSA' (aka 'rsa_st')
+
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USES= ssl
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index ed79cf9e5703..8f3acf20d1e9 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -9,6 +9,9 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt network module
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: member access into incomplete type 'X509' (aka 'x509_st')
+
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USES= ssl
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index 7f291dd2061a..a8918792f82e 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -12,6 +12,9 @@ DISTNAME= Botan-${PORTVERSION}
MAINTAINER= lapo@lapo.it
COMMENT= Portable, easy to use, and efficient C++ crypto library
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: variable has incomplete type 'EVP_MD_CTX' (aka 'struct evp_md_ctx_st')
+
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/doc/license.txt
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index fabd531b04ae..5441e59f321e 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -14,6 +14,9 @@ COMMENT= Various sniffing utilities for penetration testing
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= incomplete definition of type 'struct rsa_st'
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:net/libnids
LIB_DEPENDS= libnet.so:net/libnet
diff --git a/security/krb5-116/Makefile b/security/krb5-116/Makefile
index 68ae19123aa2..8c54aeefe66d 100644
--- a/security/krb5-116/Makefile
+++ b/security/krb5-116/Makefile
@@ -18,6 +18,9 @@ COMMENT= MIT implementation of RFC 4120 network authentication service
LICENSE= MIT
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: "This file is obsolete; please update your software."
+
CONFLICTS= heimdal-[0-9]* srp-[0-9]* krb5-11[34]-[0-9]* \
krb5-1.[0-9]* krb5-devel-*
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index 02b9ec4cd8c9..d88ecd7bb063 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -12,6 +12,9 @@ COMMENT= Library implementing the SSH1 and SSH2 protocol
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: variable has incomplete type 'EVP_MD_CTX' (aka 'struct evp_md_ctx_st')
+
OPTIONS_DEFINE= SSH1 STATIC
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= GCRYPT OPENSSL
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 4f11637393f0..3aec1c4b905b 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -26,7 +26,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --with-md5-passwords \
ETCOLD= ${PREFIX}/etc
-BROKEN_SSL_REASON_openssl-devel= incomplete definition of type struct rsa_st
+BROKEN_SSL= openssl-devel libressl
+BROKEN_SSL_REASON_openssl-devel= error: OpenSSL >= 1.1.0 is not yet supported
BROKEN_SSL_REASON_libressl= random crashes with 7.6 PR 223000
OPTIONS_DEFINE= PAM TCP_WRAPPERS LIBEDIT BSM \
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index 9b9026060c8e..b1a2ab2b03c9 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -14,6 +14,9 @@ COMMENT= Crypto and SSL toolkit for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENCE
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= Error: Syntax error in input(1).
+
BUILD_DEPENDS= swig3.0:devel/swig30
PYDISTUTILS_BUILDARGS= build_ext --include=${OPENSSLINC} --openssl=${OPENSSLBASE} --swig=${LOCALBASE}/bin/swig3.0
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index b571a708ab9b..dcaa6ed7a053 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -12,6 +12,9 @@ COMMENT= HTTP/2.0 C Library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: use of undeclared identifier 'SSL_get0_next_proto_negotiated'
+
BUILD_DEPENDS= libnghttp2>=${PORTVERSION}:www/libnghttp2
LIB_DEPENDS= libnghttp2.so:www/libnghttp2