aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-05 13:58:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-05 13:58:02 +0000
commit9633112db4a347281131743704adc79d4f622985 (patch)
tree27c3afe7808b6cc8a40a247cc71e4c69d9004897
parent6c130e4682be4cf1d1eac58a53e779c4f98e7743 (diff)
downloadports-9633112db4a347281131743704adc79d4f622985.tar.gz
ports-9633112db4a347281131743704adc79d4f622985.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/linux-sdl_ttf/Makefile25
-rw-r--r--graphics/linux-sdl_ttf/distinfo.i3866
-rw-r--r--graphics/linux-sdl_ttf/pkg-descr6
-rw-r--r--graphics/linux-sdl_ttf/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e834df1ab557..c2fe226fa40f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -433,6 +433,7 @@
SUBDIR += linux-png
SUBDIR += linux-png10
SUBDIR += linux-sdl_image
+ SUBDIR += linux-sdl_ttf
SUBDIR += linux-tiff
SUBDIR += linux-ungif
SUBDIR += linux_dri
diff --git a/graphics/linux-sdl_ttf/Makefile b/graphics/linux-sdl_ttf/Makefile
new file mode 100644
index 000000000000..85899662c1ee
--- /dev/null
+++ b/graphics/linux-sdl_ttf/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: linux-sdl_ttf
+# Date created: 03 Feb 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_ttf
+PORTVERSION= 2.0.8
+CATEGORIES= graphics linux
+MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
+DISTNAME= SDL_ttf-${PORTVERSION}-1
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= A library to use TrueType fonts in SDL applications (linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+
+USE_LINUX_RPM= yes
+USE_LDCONFIG= yes
+ONLY_FOR_ARCHS= i386 amd64
+DIST_SUBDIR= rpm
+PLIST_SUB+= SDLTTFVER=${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-sdl_ttf/distinfo.i386 b/graphics/linux-sdl_ttf/distinfo.i386
new file mode 100644
index 000000000000..959465435ded
--- /dev/null
+++ b/graphics/linux-sdl_ttf/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/SDL_ttf-2.0.8-1.i386.rpm) = 9ee787651fd29775eae178babb54cbf9
+SHA256 (rpm/SDL_ttf-2.0.8-1.i386.rpm) = 0856470abcac968c03ecb98b5a8226b0a3d970b985c369079d31046a3f4a13e4
+SIZE (rpm/SDL_ttf-2.0.8-1.i386.rpm) = 23551
+MD5 (rpm/SDL_ttf-2.0.8-1.src.rpm) = c75c4f30dab147a72c94bfe69a0a1a8d
+SHA256 (rpm/SDL_ttf-2.0.8-1.src.rpm) = 95c449d93ac9812dfbb398c715e28ddc12ee924cefddd91ef25999111e924111
+SIZE (rpm/SDL_ttf-2.0.8-1.src.rpm) = 2465661
diff --git a/graphics/linux-sdl_ttf/pkg-descr b/graphics/linux-sdl_ttf/pkg-descr
new file mode 100644
index 000000000000..77770e39e7d6
--- /dev/null
+++ b/graphics/linux-sdl_ttf/pkg-descr
@@ -0,0 +1,6 @@
+This is a simple library to load images of various formats as SDL surfaces.
+This library supports BMP, PPM, PCX, GIF, JPEG, PNG, TGA, and TIFF formats.
+
+(Linux version)
+
+WWW: http://www.libsdl.org/projects/SDL_image/
diff --git a/graphics/linux-sdl_ttf/pkg-plist b/graphics/linux-sdl_ttf/pkg-plist
new file mode 100644
index 000000000000..0f62dd0f5d05
--- /dev/null
+++ b/graphics/linux-sdl_ttf/pkg-plist
@@ -0,0 +1,6 @@
+usr/lib/libSDL_ttf-2.0.so.0
+usr/lib/libSDL_ttf-2.0.so.0.6.2
+usr/share/doc/SDL_ttf-%%SDLTTFVER%%/CHANGES
+usr/share/doc/SDL_ttf-%%SDLTTFVER%%/COPYING
+usr/share/doc/SDL_ttf-%%SDLTTFVER%%/README
+@dirrm usr/share/doc/SDL_ttf-%%SDLTTFVER%%