aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2019-11-27 20:26:36 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2019-11-27 20:26:36 +0000
commit96a4ccd2502eb4a19983aadd6d7fcac5374faed6 (patch)
tree509ee947aa5359d27b9b6a6b6c85e65a207dd622
parent1bcf05fa852f4a2106ac0eb5c52962c2e6c63e3f (diff)
downloadports-96a4ccd2502eb4a19983aadd6d7fcac5374faed6.tar.gz
ports-96a4ccd2502eb4a19983aadd6d7fcac5374faed6.zip
MFH: r518149
New ports required for gitlab-ce 12.5. Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2019Q4/; revision=518534
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-protobuf38/Makefile20
-rw-r--r--devel/rubygem-google-protobuf38/distinfo3
-rw-r--r--devel/rubygem-google-protobuf38/pkg-descr9
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rubygem-premailer-rails-rails52/Makefile24
-rw-r--r--mail/rubygem-premailer-rails-rails52/distinfo3
-rw-r--r--mail/rubygem-premailer-rails-rails52/pkg-descr6
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-diff_match_patch/Makefile20
-rw-r--r--textproc/rubygem-diff_match_patch/distinfo3
-rw-r--r--textproc/rubygem-diff_match_patch/pkg-descr3
12 files changed, 94 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 472edd3ba6f5..c502f410b199 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5887,6 +5887,7 @@
SUBDIR += rubygem-google-gax
SUBDIR += rubygem-google-protobuf
SUBDIR += rubygem-google-protobuf371
+ SUBDIR += rubygem-google-protobuf38
SUBDIR += rubygem-googleapis-common-protos
SUBDIR += rubygem-googleapis-common-protos-types
SUBDIR += rubygem-graf
diff --git a/devel/rubygem-google-protobuf38/Makefile b/devel/rubygem-google-protobuf38/Makefile
new file mode 100644
index 000000000000..612cfd795f7b
--- /dev/null
+++ b/devel/rubygem-google-protobuf38/Makefile
@@ -0,0 +1,20 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= google-protobuf
+PORTVERSION= 3.8.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 38
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Ruby extension to Google Protocol Buffers
+
+LICENSE= BSD3CLAUSE
+
+USES= gem
+USE_RUBY= yes
+
+PORTSCOUT= limit:^3\.8\.
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-protobuf38/distinfo b/devel/rubygem-google-protobuf38/distinfo
new file mode 100644
index 000000000000..435ca80295e2
--- /dev/null
+++ b/devel/rubygem-google-protobuf38/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1559219574
+SHA256 (rubygem/google-protobuf-3.8.0.gem) = c4624af322347d74916c29c1efe350d29b570d7681702c5f5a74b61c1312c32f
+SIZE (rubygem/google-protobuf-3.8.0.gem) = 262656
diff --git a/devel/rubygem-google-protobuf38/pkg-descr b/devel/rubygem-google-protobuf38/pkg-descr
new file mode 100644
index 000000000000..4b7e007200a3
--- /dev/null
+++ b/devel/rubygem-google-protobuf38/pkg-descr
@@ -0,0 +1,9 @@
+rubygem-google-protobuf is a Ruby extension that implements Protocol Buffers
+functionality. It makes use of generated Ruby code that defines message and enum
+types in a Ruby DSL. You may write definitions in this DSL directly, but we
+recommend using protoc's Ruby generation support with .proto files. The build
+process in this directory only installs the extension; you need to install
+protoc as well to have Ruby code generation functionality.
+
+WWW: https://developers.google.com/protocol-buffers/
+WWW: https://github.com/google/protobuf/tree/master/ruby
diff --git a/mail/Makefile b/mail/Makefile
index c17c25124713..44083b9401c9 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -622,6 +622,7 @@
SUBDIR += rubygem-premailer
SUBDIR += rubygem-premailer-rails
SUBDIR += rubygem-premailer-rails-rails5
+ SUBDIR += rubygem-premailer-rails-rails52
SUBDIR += rubygem-premailer-rails19-rails5
SUBDIR += rubygem-premailer-rails19-rails52
SUBDIR += rubygem-rmail
diff --git a/mail/rubygem-premailer-rails-rails52/Makefile b/mail/rubygem-premailer-rails-rails52/Makefile
new file mode 100644
index 000000000000..64e09503efe8
--- /dev/null
+++ b/mail/rubygem-premailer-rails-rails52/Makefile
@@ -0,0 +1,24 @@
+# Created by: Torsten Zuehlsdorff <ports@toco-domains.de>
+# $FreeBSD$
+
+PORTNAME= premailer-rails
+PORTVERSION= 1.10.3
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails52
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Improve the rendering of HTML emails
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-actionmailer52>=3:mail/rubygem-actionmailer52 \
+ rubygem-premailer>=1.7.9:mail/rubygem-premailer
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-premailer-rails-rails52/distinfo b/mail/rubygem-premailer-rails-rails52/distinfo
new file mode 100644
index 000000000000..e6ba39acd28d
--- /dev/null
+++ b/mail/rubygem-premailer-rails-rails52/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1574434277
+SHA256 (rubygem/premailer-rails-1.10.3.gem) = 7cdcb97027866f7a81c490c6d15ada7f39666b5f6375f0821b7e97e0483b112f
+SIZE (rubygem/premailer-rails-1.10.3.gem) = 22528
diff --git a/mail/rubygem-premailer-rails-rails52/pkg-descr b/mail/rubygem-premailer-rails-rails52/pkg-descr
new file mode 100644
index 000000000000..dc77dabbd406
--- /dev/null
+++ b/mail/rubygem-premailer-rails-rails52/pkg-descr
@@ -0,0 +1,6 @@
+This gem brings you the power of the premailer gem to Rails
+without any configuration needs. Create HTML emails, include
+a CSS file as you do in a normal HTML document and premailer
+will inline the included CSS.
+
+WWW: https://github.com/fphilipe/premailer-rails
diff --git a/textproc/Makefile b/textproc/Makefile
index 3ab141e9ad67..6e334a644bfd 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1522,6 +1522,7 @@
SUBDIR += rubygem-css_parser
SUBDIR += rubygem-cssmin
SUBDIR += rubygem-diff-lcs
+ SUBDIR += rubygem-diff_match_patch
SUBDIR += rubygem-diffy
SUBDIR += rubygem-diffy31
SUBDIR += rubygem-docdiff
diff --git a/textproc/rubygem-diff_match_patch/Makefile b/textproc/rubygem-diff_match_patch/Makefile
new file mode 100644
index 000000000000..fbbd44645a66
--- /dev/null
+++ b/textproc/rubygem-diff_match_patch/Makefile
@@ -0,0 +1,20 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= diff_match_patch
+PORTVERSION= 0.1.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Ruby implementation of Google diff_match_patch
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-diff_match_patch/distinfo b/textproc/rubygem-diff_match_patch/distinfo
new file mode 100644
index 000000000000..d1530737dc40
--- /dev/null
+++ b/textproc/rubygem-diff_match_patch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1574429017
+SHA256 (rubygem/diff_match_patch-0.1.0.gem) = b36057bfcfeaedf19dcb7b2c28c19ee625bd6ec6d0d182717d3ef22b3879c40e
+SIZE (rubygem/diff_match_patch-0.1.0.gem) = 25088
diff --git a/textproc/rubygem-diff_match_patch/pkg-descr b/textproc/rubygem-diff_match_patch/pkg-descr
new file mode 100644
index 000000000000..9cb4150fc36e
--- /dev/null
+++ b/textproc/rubygem-diff_match_patch/pkg-descr
@@ -0,0 +1,3 @@
+Ruby implementation of Google diff_match_patch.
+
+WWW: https://github.com/kalmbach/diff_match_patch