aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-09 20:22:42 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-09 20:22:42 +0000
commit9c749957bf613edc626c7c3b341c956de357ef49 (patch)
treeaff128e66a576503a79ec3d5731b66bb672674f2
parent0a1ef7cf8f9f7fc4eb35ee6edcd06aa0f74669b5 (diff)
downloadports-9c749957bf613edc626c7c3b341c956de357ef49.tar.gz
ports-9c749957bf613edc626c7c3b341c956de357ef49.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/hexyl/Makefile45
-rw-r--r--sysutils/hexyl/distinfo41
-rw-r--r--sysutils/hexyl/pkg-descr6
4 files changed, 93 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 808bf062cda7..6cf5a3a25094 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -476,6 +476,7 @@
SUBDIR += heirloom
SUBDIR += helm
SUBDIR += hextools
+ SUBDIR += hexyl
SUBDIR += hfm
SUBDIR += hfsexplorer
SUBDIR += hfsutils
diff --git a/sysutils/hexyl/Makefile b/sysutils/hexyl/Makefile
new file mode 100644
index 000000000000..2ce7b9050a39
--- /dev/null
+++ b/sysutils/hexyl/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= hexyl
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.0
+CATEGORIES= sysutils
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Command-line hex viewer
+
+LICENSE= MIT APACHE20
+LICENSE_COMB= dual
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
+LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE-APACHE
+
+USES= cargo
+USE_GITHUB= yes
+GH_ACCOUNT= sharkdp
+
+CARGO_CRATES= ansi_term-0.11.0 \
+ atty-0.2.11 \
+ bitflags-1.0.4 \
+ clap-2.32.0 \
+ kernel32-sys-0.2.2 \
+ libc-0.2.45 \
+ redox_syscall-0.1.49 \
+ redox_termios-0.1.1 \
+ strsim-0.7.0 \
+ term_size-0.3.1 \
+ termion-1.5.1 \
+ textwrap-0.10.0 \
+ unicode-width-0.1.5 \
+ vec_map-0.8.1 \
+ winapi-0.2.8 \
+ winapi-0.3.6 \
+ winapi-build-0.1.1 \
+ winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-x86_64-pc-windows-gnu-0.4.0
+
+PLIST_FILES= bin/hexyl
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/hexyl
+
+.include <bsd.port.mk>
diff --git a/sysutils/hexyl/distinfo b/sysutils/hexyl/distinfo
new file mode 100644
index 000000000000..fbd0a7192ecc
--- /dev/null
+++ b/sysutils/hexyl/distinfo
@@ -0,0 +1,41 @@
+TIMESTAMP = 1547064973
+SHA256 (rust/crates/ansi_term-0.11.0.tar.gz) = ee49baf6cb617b853aa8d93bf420db2383fab46d314482ca2803b40d5fde979b
+SIZE (rust/crates/ansi_term-0.11.0.tar.gz) = 17087
+SHA256 (rust/crates/atty-0.2.11.tar.gz) = 9a7d5b8723950951411ee34d271d99dddcc2035a16ab25310ea2c8cfd4369652
+SIZE (rust/crates/atty-0.2.11.tar.gz) = 5916
+SHA256 (rust/crates/bitflags-1.0.4.tar.gz) = 228047a76f468627ca71776ecdebd732a3423081fcf5125585bcd7c49886ce12
+SIZE (rust/crates/bitflags-1.0.4.tar.gz) = 15282
+SHA256 (rust/crates/clap-2.32.0.tar.gz) = b957d88f4b6a63b9d70d5f454ac8011819c6efa7727858f458ab71c756ce2d3e
+SIZE (rust/crates/clap-2.32.0.tar.gz) = 196073
+SHA256 (rust/crates/kernel32-sys-0.2.2.tar.gz) = 7507624b29483431c0ba2d82aece8ca6cdba9382bff4ddd0f7490560c056098d
+SIZE (rust/crates/kernel32-sys-0.2.2.tar.gz) = 24537
+SHA256 (rust/crates/libc-0.2.45.tar.gz) = 2d2857ec59fadc0773853c664d2d18e7198e83883e7060b63c924cb077bd5c74
+SIZE (rust/crates/libc-0.2.45.tar.gz) = 349425
+SHA256 (rust/crates/redox_syscall-0.1.49.tar.gz) = f22c50afdcf3f0a31ebb6b47697f6a7c5e5a24967e842858118bce0615f0afad
+SIZE (rust/crates/redox_syscall-0.1.49.tar.gz) = 15541
+SHA256 (rust/crates/redox_termios-0.1.1.tar.gz) = 7e891cfe48e9100a70a3b6eb652fef28920c117d366339687bd5576160db0f76
+SIZE (rust/crates/redox_termios-0.1.1.tar.gz) = 3227
+SHA256 (rust/crates/strsim-0.7.0.tar.gz) = bb4f380125926a99e52bc279241539c018323fab05ad6368b56f93d9369ff550
+SIZE (rust/crates/strsim-0.7.0.tar.gz) = 8435
+SHA256 (rust/crates/term_size-0.3.1.tar.gz) = 9e5b9a66db815dcfd2da92db471106457082577c3c278d4138ab3e3b4e189327
+SIZE (rust/crates/term_size-0.3.1.tar.gz) = 10754
+SHA256 (rust/crates/termion-1.5.1.tar.gz) = 689a3bdfaab439fd92bc87df5c4c78417d3cbe537487274e9b0b2dce76e92096
+SIZE (rust/crates/termion-1.5.1.tar.gz) = 20659
+SHA256 (rust/crates/textwrap-0.10.0.tar.gz) = 307686869c93e71f94da64286f9a9524c0f308a9e1c87a583de8e9c9039ad3f6
+SIZE (rust/crates/textwrap-0.10.0.tar.gz) = 15986
+SHA256 (rust/crates/unicode-width-0.1.5.tar.gz) = 882386231c45df4700b275c7ff55b6f3698780a650026380e72dabe76fa46526
+SIZE (rust/crates/unicode-width-0.1.5.tar.gz) = 15761
+SHA256 (rust/crates/vec_map-0.8.1.tar.gz) = 05c78687fb1a80548ae3250346c3db86a80a7cdd77bda190189f2d0a0987c81a
+SIZE (rust/crates/vec_map-0.8.1.tar.gz) = 14959
+SHA256 (rust/crates/winapi-0.2.8.tar.gz) = 167dc9d6949a9b857f3451275e911c3f44255842c1f7a76f33c55103a909087a
+SIZE (rust/crates/winapi-0.2.8.tar.gz) = 455145
+SHA256 (rust/crates/winapi-0.3.6.tar.gz) = 92c1eb33641e276cfa214a0522acad57be5c56b10cb348b3c5117db75f3ac4b0
+SIZE (rust/crates/winapi-0.3.6.tar.gz) = 1029391
+SHA256 (rust/crates/winapi-build-0.1.1.tar.gz) = 2d315eee3b34aca4797b2da6b13ed88266e6d612562a0c46390af8299fc699bc
+SIZE (rust/crates/winapi-build-0.1.1.tar.gz) = 669
+SHA256 (rust/crates/winapi-i686-pc-windows-gnu-0.4.0.tar.gz) = ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6
+SIZE (rust/crates/winapi-i686-pc-windows-gnu-0.4.0.tar.gz) = 2918815
+SHA256 (rust/crates/winapi-x86_64-pc-windows-gnu-0.4.0.tar.gz) = 712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f
+SIZE (rust/crates/winapi-x86_64-pc-windows-gnu-0.4.0.tar.gz) = 2947998
+SHA256 (sharkdp-hexyl-v0.3.0_GH0.tar.gz) = 7a6b8c6058fa887105dcd5f85b2808b2e0e7557f13b28d6fe802ce5609ff473e
+SIZE (sharkdp-hexyl-v0.3.0_GH0.tar.gz) = 14876
diff --git a/sysutils/hexyl/pkg-descr b/sysutils/hexyl/pkg-descr
new file mode 100644
index 000000000000..f2551ee3a5d8
--- /dev/null
+++ b/sysutils/hexyl/pkg-descr
@@ -0,0 +1,6 @@
+Hexyl is a simple hex viewer for the terminal. It uses a colored
+output to distinguish different categories of bytes (NULL bytes,
+printable ASCII characters, ASCII whitespace characters, other ASCII
+characters and non-ASCII).
+
+WWW: https://github.com/sharkdp/hexyl