diff options
author | Michael Gmelin <grembo@FreeBSD.org> | 2017-01-30 22:29:23 +0000 |
---|---|---|
committer | Michael Gmelin <grembo@FreeBSD.org> | 2017-01-30 22:29:23 +0000 |
commit | a0eac7f8c4aacffa89598ad571c8ab23480b8116 (patch) | |
tree | c91b9ef356282af4394b33792d960a4e00919852 | |
parent | 104700fa67fdf4e736a5ecd178ada004e394e418 (diff) | |
download | ports-a0eac7f8c4aacffa89598ad571c8ab23480b8116.tar.gz ports-a0eac7f8c4aacffa89598ad571c8ab23480b8116.zip |
Notes
-rw-r--r-- | UPDATING | 11 | ||||
-rw-r--r-- | devel/ice/Makefile | 2 | ||||
-rw-r--r-- | devel/ice/files/patch-cpp-include-IceUtil-Config.h | 24 |
3 files changed, 33 insertions, 4 deletions
@@ -5,6 +5,17 @@ they are unavoidable. You should get into the habit of checking this file for changes each time you update your ports collection, before attempting any port upgrades. +20170130: + AFFECTS: users of devel/ice, devel/py-ice, devel/php5-ice + AUTHOR: grembo@FreeBSD.org + + Since __WORDSIZE as defined by <stdint.h> always reports 32 when using + C++98/03 (unless __STDC_LIMIT_MACROS is set explictly), Ice 3.6.3 used + "long long" for Int64 instead of "long" on 64-bit platforms by mistake. + A workaround has been added in version 3.6.3_2 of these three ports, + requiring to upgrade all of them at the same time and to rebuild all + custom code that links against them. + 20170129: AFFECTS: users of multimedia/motion AUTHOR: jhale@FreeBSD.org diff --git a/devel/ice/Makefile b/devel/ice/Makefile index 878e55509b6e..aa8a5d423a65 100644 --- a/devel/ice/Makefile +++ b/devel/ice/Makefile @@ -3,7 +3,7 @@ PORTNAME= Ice PORTVERSION= 3.6.3 -PORTREVISION= 1 +PORTREVISION= 2 DISTVERSIONPREFIX= v CATEGORIES= devel diff --git a/devel/ice/files/patch-cpp-include-IceUtil-Config.h b/devel/ice/files/patch-cpp-include-IceUtil-Config.h index 79047cf87788..677e339779ae 100644 --- a/devel/ice/files/patch-cpp-include-IceUtil-Config.h +++ b/devel/ice/files/patch-cpp-include-IceUtil-Config.h @@ -1,6 +1,24 @@ ---- cpp/include/IceUtil/Config.h.orig 2015-06-27 15:37:32.688102665 +0000 -+++ cpp/include/IceUtil/Config.h 2015-06-27 15:37:34.926179135 +0000 -@@ -49,6 +49,16 @@ +--- cpp/include/IceUtil/Config.h.orig 2016-10-05 16:59:08.000000000 +0200 ++++ cpp/include/IceUtil/Config.h 2017-01-30 22:11:08.235308977 +0100 +@@ -80,13 +80,15 @@ + // + # include <stdint.h> + +-# if defined(__WORDSIZE) && (__WORDSIZE == 64) ++# if (__cplusplus >= 201103L) && defined(__WORDSIZE) && (__WORDSIZE == 64) + # define ICE_64 +-# elif defined(__WORDSIZE) && (__WORDSIZE == 32) ++# elif (__cplusplus >= 201103L) && defined(__WORDSIZE) && (__WORDSIZE == 32) + # define ICE_32 + # elif defined(__sun) && (defined(__sparcv9) || defined(__x86_64)) || \ + defined(__linux) && defined(__x86_64) || \ + defined(__APPLE__) && defined(__x86_64) || \ ++ defined(__FreeBSD__) && defined(__x86_64) || \ ++ defined(__FreeBSD__) && defined(__LP64__) || \ + defined(__hppa) && defined(__LP64__) || \ + defined(_ARCH_COM) && defined(__64BIT__) || \ + defined(__alpha__) || \ +@@ -98,6 +100,16 @@ #endif // |