aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulio Merino <jmmv@FreeBSD.org>2013-12-27 20:45:03 +0000
committerJulio Merino <jmmv@FreeBSD.org>2013-12-27 20:45:03 +0000
commitb529e3c0b47e9520d2e99a112d3ae8f5c13da94b (patch)
tree196344d26d885cd04eda70a28f85864be6952dbe
parentae506911a33e04725e2d6817235a0ff9d4b6f7b0 (diff)
downloadports-b529e3c0b47e9520d2e99a112d3ae8f5c13da94b.tar.gz
ports-b529e3c0b47e9520d2e99a112d3ae8f5c13da94b.zip
Notes
-rw-r--r--UIDs1
-rw-r--r--devel/kyua/Makefile12
-rw-r--r--devel/kyua/files/kyua.conf.in14
3 files changed, 27 insertions, 0 deletions
diff --git a/UIDs b/UIDs
index 2977c65a4f6d..d8cb7273e937 100644
--- a/UIDs
+++ b/UIDs
@@ -274,4 +274,5 @@ boinc:*:973:973::0:0:BOINC user:/var/db/boinc:/bin/sh
radicale:*:974:974::0:0:Radicale daemon:/nonexistent:/usr/sbin/nologin
unifi:*:975:975::0:0:Unifi Wireless Controller:/nonexistent:/usr/sbin/nologin
minetest:*:976:976::0:0:& server:/nonexistent:/usr/sbin/nologin
+tests:*:977:65534::0:0:Unprivileged user for tests:/nonexistent:/usr/sbin/nologin
nobody:*:65534:65534::0:0:Unprivileged user:/nonexistent:/usr/sbin/nologin
diff --git a/devel/kyua/Makefile b/devel/kyua/Makefile
index dba138ccba45..9a7dd5d6c138 100644
--- a/devel/kyua/Makefile
+++ b/devel/kyua/Makefile
@@ -3,6 +3,7 @@
PORTNAME= kyua
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PROJECTHOST= kyua
@@ -21,6 +22,11 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USES= pkgconfig
+TESTS_USER= tests
+USERS= ${TESTS_USER}
+SUB_FILES= kyua.conf
+SUB_LIST= TESTS_USER=${TESTS_USER}
+
OPTIONS_DEFINE= DOCS EXAMPLES
NO_STAGE= yes
.include <bsd.port.options.mk>
@@ -38,6 +44,8 @@ MAKE_FLAGS+= doc_DATA=
MAKE_FLAGS+= dist_examples_DATA=
.endif
PLIST_FILES= bin/kyua
+PLIST_DIRS= etc/kyua
+PLIST_FILES+= etc/kyua/kyua.conf
PORTDATA= misc store examples
PORTDOCS= AUTHORS COPYING NEWS README
@@ -47,4 +55,8 @@ MAN1+= kyua-report.1 kyua-test.1 kyua.1
MAN5= kyua.conf.5 kyuafile.5
MAN7= kyua-build-root.7 kyua-test-filters.7
+post-install:
+ ${MKDIR} ${PREFIX}/etc/kyua/
+ ${INSTALL_DATA} ${WRKDIR}/kyua.conf ${PREFIX}/etc/kyua/
+
.include <bsd.port.mk>
diff --git a/devel/kyua/files/kyua.conf.in b/devel/kyua/files/kyua.conf.in
new file mode 100644
index 000000000000..e09018346c54
--- /dev/null
+++ b/devel/kyua/files/kyua.conf.in
@@ -0,0 +1,14 @@
+-- $FreeBSD$
+--
+-- System-wide configuration file for kyua(1). See kyua.conf(5) for details
+-- on the syntax.
+--
+
+syntax(2)
+
+-- User to drop privileges to when invoking kyua(1) as root and a test case
+-- requests to be run with non-root permissions.
+unprivileged_user = '%%TESTS_USER%%'
+
+-- An example to set a configuration property specific to FreeBSD.
+--test_suites.FreeBSD.fstype = 'ffs'