aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-09-30 08:02:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-09-30 08:02:15 +0000
commitb7df943d51603632e78bcf25d232f2002c026ffd (patch)
tree626d190663c9b7565003910b791a40b884e9929f
parentc9e3c3046af6a677660320d1462e0579b28ef640 (diff)
downloadports-b7df943d51603632e78bcf25d232f2002c026ffd.tar.gz
ports-b7df943d51603632e78bcf25d232f2002c026ffd.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/dvdisaster/Makefile53
-rw-r--r--sysutils/dvdisaster/distinfo3
-rw-r--r--sysutils/dvdisaster/pkg-descr20
-rw-r--r--sysutils/dvdisaster/pkg-plist261
5 files changed, 338 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9425a9d66fa2..dee57842875e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -139,6 +139,7 @@
SUBDIR += dvd+rw-tools
SUBDIR += dvdbackup
SUBDIR += dvdimagecmp
+ SUBDIR += dvdisaster
SUBDIR += dvdtape
SUBDIR += dwatch
SUBDIR += e2fsprogs
diff --git a/sysutils/dvdisaster/Makefile b/sysutils/dvdisaster/Makefile
new file mode 100644
index 000000000000..1b81351d4ab9
--- /dev/null
+++ b/sysutils/dvdisaster/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: dvdisaster
+# Date created: 2006/08/13
+# Whom: Heiner <h.eichmann@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvdisaster
+PORTVERSION= 0.70.1
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dvdisaster
+
+MAINTAINER= h.eichmann@gmx.de
+COMMENT= A CD/DVD error recovery tool
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+WRKSRC= ${WRKDIR}/dvdisaster-0.70
+MAKEFILE= GNUmakefile
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GNOME= gtk20
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --prefix=${PREFIX}
+USE_GMAKE= yes
+USE_GETOPT_LONG= yes
+
+MAN1= dvdisaster.1
+MANLANG= "" cs de it
+
+do-configure:
+ @(cd ${CONFIGURE_WRKSRC} && \
+ if ! ${SETENV} CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ INSTALL="/usr/bin/install -c ${_BINOWNGRP}" \
+ INSTALL_DATA="${INSTALL_DATA}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ ${CONFIGURE_ENV} bash configure ${CONFIGURE_ARGS}; then \
+ ${ECHO_CMD} "===> Script \"${CONFIGURE_SCRIPT}\" failed unexpectedly."; \
+ (${ECHO_CMD} ${CONFIGURE_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
+ ${FALSE}; \
+ fi)
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/dvdisaster/distinfo b/sysutils/dvdisaster/distinfo
new file mode 100644
index 000000000000..dcae31544844
--- /dev/null
+++ b/sysutils/dvdisaster/distinfo
@@ -0,0 +1,3 @@
+MD5 (dvdisaster-0.70.1.tar.bz2) = 350b76ccaf2c8f08dcd26643ec359614
+SHA256 (dvdisaster-0.70.1.tar.bz2) = eaa963cd0ac8627129ae5a48eae68386e2d4bf9dc8317857461674a644d532bf
+SIZE (dvdisaster-0.70.1.tar.bz2) = 1146683
diff --git a/sysutils/dvdisaster/pkg-descr b/sysutils/dvdisaster/pkg-descr
new file mode 100644
index 000000000000..05eaca1726b3
--- /dev/null
+++ b/sysutils/dvdisaster/pkg-descr
@@ -0,0 +1,20 @@
+The dvdisaster project:
+dvdisaster provides a margin of safety against data loss on CD and DVD media
+caused by aging or scratches.
+
+ * dvdisaster creates error correction data to compensate read errors which
+ are not correctable in the CD/DVD drive.
+
+ * dvdisaster tries to read as much data as possible from defective media.
+ Afterwards unreadable sectors are recovered using the previously created
+ error correction data. The maximum error correction capacity is
+ user-selectable.
+
+ * dvdisaster operates at the image level and does not depend on the file
+ system.
+
+If you create the error correction data in time and keep it at a safe place,
+you have a good chance of recovering the medium contents from typical read
+errors and to transfer your complete data onto a new medium.
+
+WWW: http://www.dvdisaster.com/
diff --git a/sysutils/dvdisaster/pkg-plist b/sysutils/dvdisaster/pkg-plist
new file mode 100644
index 000000000000..aaab8cf0b382
--- /dev/null
+++ b/sysutils/dvdisaster/pkg-plist
@@ -0,0 +1,261 @@
+bin/dvdisaster
+bin/dvdisaster-uninstall.sh
+doc/dvdisaster-0.70/CHANGELOG
+doc/dvdisaster-0.70/COPYING
+doc/dvdisaster-0.70/CREDITS.cs
+doc/dvdisaster-0.70/CREDITS.de
+doc/dvdisaster-0.70/CREDITS.en
+doc/dvdisaster-0.70/README.MODIFYING
+doc/dvdisaster-0.70/TODO
+doc/dvdisaster-0.70/cs/background.html
+doc/dvdisaster-0.70/cs/background10.html
+doc/dvdisaster-0.70/cs/background20.html
+doc/dvdisaster-0.70/cs/background30.html
+doc/dvdisaster-0.70/cs/background40.html
+doc/dvdisaster-0.70/cs/background50.html
+doc/dvdisaster-0.70/cs/background60.html
+doc/dvdisaster-0.70/cs/background70.html
+doc/dvdisaster-0.70/cs/download.html
+doc/dvdisaster-0.70/cs/download10.html
+doc/dvdisaster-0.70/cs/download20.html
+doc/dvdisaster-0.70/cs/example.html
+doc/dvdisaster-0.70/cs/example1.html
+doc/dvdisaster-0.70/cs/example10.html
+doc/dvdisaster-0.70/cs/example2.html
+doc/dvdisaster-0.70/cs/example20.html
+doc/dvdisaster-0.70/cs/example21.html
+doc/dvdisaster-0.70/cs/example22.html
+doc/dvdisaster-0.70/cs/example3.html
+doc/dvdisaster-0.70/cs/example30.html
+doc/dvdisaster-0.70/cs/example4.html
+doc/dvdisaster-0.70/cs/example40.html
+doc/dvdisaster-0.70/cs/example5.html
+doc/dvdisaster-0.70/cs/example50.html
+doc/dvdisaster-0.70/cs/example6.html
+doc/dvdisaster-0.70/cs/example80.html
+doc/dvdisaster-0.70/cs/example81.html
+doc/dvdisaster-0.70/cs/example82.html
+doc/dvdisaster-0.70/cs/example83.html
+doc/dvdisaster-0.70/cs/example90.html
+doc/dvdisaster-0.70/cs/images/bg-adaptive.png
+doc/dvdisaster-0.70/cs/images/bg-linear.png
+doc/dvdisaster-0.70/cs/images/btn-compare.png
+doc/dvdisaster-0.70/cs/images/btn-create.png
+doc/dvdisaster-0.70/cs/images/btn-drive.png
+doc/dvdisaster-0.70/cs/images/btn-eccfile.png
+doc/dvdisaster-0.70/cs/images/btn-fix.png
+doc/dvdisaster-0.70/cs/images/btn-image.png
+doc/dvdisaster-0.70/cs/images/btn-protocol.png
+doc/dvdisaster-0.70/cs/images/btn-read.png
+doc/dvdisaster-0.70/cs/images/btn-scan.png
+doc/dvdisaster-0.70/cs/images/ex-compare.png
+doc/dvdisaster-0.70/cs/images/ex-create.png
+doc/dvdisaster-0.70/cs/images/ex-fix.png
+doc/dvdisaster-0.70/cs/images/ex-read-a.png
+doc/dvdisaster-0.70/cs/images/ex-read.png
+doc/dvdisaster-0.70/cs/images/ex-scan.png
+doc/dvdisaster-0.70/cs/images/prefs-ecc-1.png
+doc/dvdisaster-0.70/cs/images/prefs-ecc-2.png
+doc/dvdisaster-0.70/cs/images/prefs-ecc.png
+doc/dvdisaster-0.70/cs/images/prefs-general-1.png
+doc/dvdisaster-0.70/cs/images/prefs-general-2.png
+doc/dvdisaster-0.70/cs/images/prefs-general-3.png
+doc/dvdisaster-0.70/cs/images/prefs-general.png
+doc/dvdisaster-0.70/cs/images/prefs-read-1.png
+doc/dvdisaster-0.70/cs/images/prefs-read-2.png
+doc/dvdisaster-0.70/cs/images/prefs-read-3.png
+doc/dvdisaster-0.70/cs/images/prefs-read.png
+doc/dvdisaster-0.70/cs/images/scratch-corr.png
+doc/dvdisaster-0.70/cs/images/scratch-scan.png
+doc/dvdisaster-0.70/cs/index.html
+doc/dvdisaster-0.70/cs/index10.html
+doc/dvdisaster-0.70/cs/index20.html
+doc/dvdisaster-0.70/cs/index30.html
+doc/dvdisaster-0.70/cs/inline1.html
+doc/dvdisaster-0.70/cs/inline2.html
+doc/dvdisaster-0.70/cs/qa.html
+doc/dvdisaster-0.70/cs/qa10.html
+doc/dvdisaster-0.70/cs/qa20.html
+doc/dvdisaster-0.70/de/background.html
+doc/dvdisaster-0.70/de/background10.html
+doc/dvdisaster-0.70/de/background20.html
+doc/dvdisaster-0.70/de/background30.html
+doc/dvdisaster-0.70/de/background40.html
+doc/dvdisaster-0.70/de/background50.html
+doc/dvdisaster-0.70/de/background60.html
+doc/dvdisaster-0.70/de/background70.html
+doc/dvdisaster-0.70/de/download.html
+doc/dvdisaster-0.70/de/download10.html
+doc/dvdisaster-0.70/de/download20.html
+doc/dvdisaster-0.70/de/example.html
+doc/dvdisaster-0.70/de/example1.html
+doc/dvdisaster-0.70/de/example10.html
+doc/dvdisaster-0.70/de/example2.html
+doc/dvdisaster-0.70/de/example20.html
+doc/dvdisaster-0.70/de/example21.html
+doc/dvdisaster-0.70/de/example22.html
+doc/dvdisaster-0.70/de/example3.html
+doc/dvdisaster-0.70/de/example30.html
+doc/dvdisaster-0.70/de/example4.html
+doc/dvdisaster-0.70/de/example40.html
+doc/dvdisaster-0.70/de/example5.html
+doc/dvdisaster-0.70/de/example50.html
+doc/dvdisaster-0.70/de/example6.html
+doc/dvdisaster-0.70/de/example7.html
+doc/dvdisaster-0.70/de/example80.html
+doc/dvdisaster-0.70/de/example81.html
+doc/dvdisaster-0.70/de/example82.html
+doc/dvdisaster-0.70/de/example83.html
+doc/dvdisaster-0.70/de/example84.html
+doc/dvdisaster-0.70/de/example90.html
+doc/dvdisaster-0.70/de/images/bg-adaptive.png
+doc/dvdisaster-0.70/de/images/bg-linear.png
+doc/dvdisaster-0.70/de/images/btn-compare.png
+doc/dvdisaster-0.70/de/images/btn-create.png
+doc/dvdisaster-0.70/de/images/btn-fix.png
+doc/dvdisaster-0.70/de/images/btn-new-image.png
+doc/dvdisaster-0.70/de/images/btn-protocol.png
+doc/dvdisaster-0.70/de/images/btn-read.png
+doc/dvdisaster-0.70/de/images/btn-scan.png
+doc/dvdisaster-0.70/de/images/ex-compare-rs02.png
+doc/dvdisaster-0.70/de/images/ex-compare.png
+doc/dvdisaster-0.70/de/images/ex-create-rs02.png
+doc/dvdisaster-0.70/de/images/ex-create.png
+doc/dvdisaster-0.70/de/images/ex-fix.png
+doc/dvdisaster-0.70/de/images/ex-read-a.png
+doc/dvdisaster-0.70/de/images/ex-read.png
+doc/dvdisaster-0.70/de/images/ex-scan.png
+doc/dvdisaster-0.70/de/images/prefs-ecc-0.png
+doc/dvdisaster-0.70/de/images/prefs-ecc-1.png
+doc/dvdisaster-0.70/de/images/prefs-ecc-2.png
+doc/dvdisaster-0.70/de/images/prefs-ecc.png
+doc/dvdisaster-0.70/de/images/prefs-general-1.png
+doc/dvdisaster-0.70/de/images/prefs-general-2.png
+doc/dvdisaster-0.70/de/images/prefs-general-3.png
+doc/dvdisaster-0.70/de/images/prefs-general.png
+doc/dvdisaster-0.70/de/images/prefs-read-1.png
+doc/dvdisaster-0.70/de/images/prefs-read-2.png
+doc/dvdisaster-0.70/de/images/prefs-read-3.png
+doc/dvdisaster-0.70/de/images/prefs-read.png
+doc/dvdisaster-0.70/de/images/prefs-rs02-0.png
+doc/dvdisaster-0.70/de/images/prefs-rs02-1.png
+doc/dvdisaster-0.70/de/images/prefs-rs02.png
+doc/dvdisaster-0.70/de/images/scratch-corr.png
+doc/dvdisaster-0.70/de/images/scratch-scan.png
+doc/dvdisaster-0.70/de/index.html
+doc/dvdisaster-0.70/de/index10.html
+doc/dvdisaster-0.70/de/index20.html
+doc/dvdisaster-0.70/de/index30.html
+doc/dvdisaster-0.70/de/inline1.html
+doc/dvdisaster-0.70/de/inline2.html
+doc/dvdisaster-0.70/de/qa.html
+doc/dvdisaster-0.70/de/qa10.html
+doc/dvdisaster-0.70/de/qa20.html
+doc/dvdisaster-0.70/en/background.html
+doc/dvdisaster-0.70/en/background10.html
+doc/dvdisaster-0.70/en/background20.html
+doc/dvdisaster-0.70/en/background30.html
+doc/dvdisaster-0.70/en/background40.html
+doc/dvdisaster-0.70/en/background50.html
+doc/dvdisaster-0.70/en/background60.html
+doc/dvdisaster-0.70/en/background70.html
+doc/dvdisaster-0.70/en/download.html
+doc/dvdisaster-0.70/en/download10.html
+doc/dvdisaster-0.70/en/download20.html
+doc/dvdisaster-0.70/en/example.html
+doc/dvdisaster-0.70/en/example1.html
+doc/dvdisaster-0.70/en/example10.html
+doc/dvdisaster-0.70/en/example2.html
+doc/dvdisaster-0.70/en/example20.html
+doc/dvdisaster-0.70/en/example21.html
+doc/dvdisaster-0.70/en/example22.html
+doc/dvdisaster-0.70/en/example3.html
+doc/dvdisaster-0.70/en/example30.html
+doc/dvdisaster-0.70/en/example4.html
+doc/dvdisaster-0.70/en/example40.html
+doc/dvdisaster-0.70/en/example5.html
+doc/dvdisaster-0.70/en/example50.html
+doc/dvdisaster-0.70/en/example6.html
+doc/dvdisaster-0.70/en/example7.html
+doc/dvdisaster-0.70/en/example80.html
+doc/dvdisaster-0.70/en/example81.html
+doc/dvdisaster-0.70/en/example82.html
+doc/dvdisaster-0.70/en/example83.html
+doc/dvdisaster-0.70/en/example84.html
+doc/dvdisaster-0.70/en/example90.html
+doc/dvdisaster-0.70/en/images/bg-adaptive.png
+doc/dvdisaster-0.70/en/images/bg-linear.png
+doc/dvdisaster-0.70/en/images/btn-compare.png
+doc/dvdisaster-0.70/en/images/btn-create.png
+doc/dvdisaster-0.70/en/images/btn-fix.png
+doc/dvdisaster-0.70/en/images/btn-new-image.png
+doc/dvdisaster-0.70/en/images/btn-protocol.png
+doc/dvdisaster-0.70/en/images/btn-read.png
+doc/dvdisaster-0.70/en/images/btn-scan.png
+doc/dvdisaster-0.70/en/images/ex-compare-rs02.png
+doc/dvdisaster-0.70/en/images/ex-compare.png
+doc/dvdisaster-0.70/en/images/ex-create-rs02.png
+doc/dvdisaster-0.70/en/images/ex-create.png
+doc/dvdisaster-0.70/en/images/ex-fix.png
+doc/dvdisaster-0.70/en/images/ex-read-a.png
+doc/dvdisaster-0.70/en/images/ex-read.png
+doc/dvdisaster-0.70/en/images/ex-scan.png
+doc/dvdisaster-0.70/en/images/prefs-ecc-0.png
+doc/dvdisaster-0.70/en/images/prefs-ecc-1.png
+doc/dvdisaster-0.70/en/images/prefs-ecc-2.png
+doc/dvdisaster-0.70/en/images/prefs-ecc.png
+doc/dvdisaster-0.70/en/images/prefs-general-1.png
+doc/dvdisaster-0.70/en/images/prefs-general-2.png
+doc/dvdisaster-0.70/en/images/prefs-general-3.png
+doc/dvdisaster-0.70/en/images/prefs-general.png
+doc/dvdisaster-0.70/en/images/prefs-read-1.png
+doc/dvdisaster-0.70/en/images/prefs-read-2.png
+doc/dvdisaster-0.70/en/images/prefs-read-3.png
+doc/dvdisaster-0.70/en/images/prefs-read.png
+doc/dvdisaster-0.70/en/images/prefs-rs02-0.png
+doc/dvdisaster-0.70/en/images/prefs-rs02-1.png
+doc/dvdisaster-0.70/en/images/prefs-rs02.png
+doc/dvdisaster-0.70/en/images/scratch-corr.png
+doc/dvdisaster-0.70/en/images/scratch-scan.png
+doc/dvdisaster-0.70/en/index.html
+doc/dvdisaster-0.70/en/index10.html
+doc/dvdisaster-0.70/en/index20.html
+doc/dvdisaster-0.70/en/index30.html
+doc/dvdisaster-0.70/en/inline1.html
+doc/dvdisaster-0.70/en/inline2.html
+doc/dvdisaster-0.70/en/qa.html
+doc/dvdisaster-0.70/en/qa10.html
+doc/dvdisaster-0.70/en/qa20.html
+doc/dvdisaster-0.70/images/btn-drive.png
+doc/dvdisaster-0.70/images/btn-eccfile.png
+doc/dvdisaster-0.70/images/btn-image.png
+doc/dvdisaster-0.70/images/open-ecc.png
+doc/dvdisaster-0.70/images/open-img.png
+doc/dvdisaster-0.70/images/open-preferences.png
+doc/dvdisaster-0.70/images/scratch-img.jpg
+locale/cs/LC_MESSAGES/dvdisaster.mo
+locale/de/LC_MESSAGES/dvdisaster.mo
+locale/it/LC_MESSAGES/dvdisaster.mo
+locale/sv/LC_MESSAGES/dvdisaster.mo
+@dirrm doc/dvdisaster-0.70/images
+@dirrm doc/dvdisaster-0.70/en/images
+@dirrm doc/dvdisaster-0.70/en
+@dirrm doc/dvdisaster-0.70/de/images
+@dirrm doc/dvdisaster-0.70/de
+@dirrm doc/dvdisaster-0.70/cs/images
+@dirrm doc/dvdisaster-0.70/cs
+@dirrm doc/dvdisaster-0.70
+@dirrmtry locale/cs/LC_MESSAGES
+@dirrmtry locale/cs
+@dirrmtry locale/de/LC_MESSAGES
+@dirrmtry locale/de
+@dirrmtry locale/it/LC_MESSAGES
+@dirrmtry locale/it
+@dirrmtry locale/sv/LC_MESSAGES
+@dirrmtry locale/sv
+@dirrmtry locale
+@dirrmtry man/de/man1
+@dirrmtry man/de
+@dirrmtry man/cs/man1
+@dirrmtry man/cs
+@dirrmtry doc