aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2010-01-28 04:52:16 +0000
committerMark Linimon <linimon@FreeBSD.org>2010-01-28 04:52:16 +0000
commitb93b277e621a46e9c3504de7d9692babe843ee32 (patch)
treea17dfbe4faf5793a0cc1e7d3dd5c63b12b20cb71
parent849edf06d364e4b6d0ef90368b7690a0479c6567 (diff)
downloadports-b93b277e621a46e9c3504de7d9692babe843ee32.tar.gz
ports-b93b277e621a46e9c3504de7d9692babe843ee32.zip
Notes
-rw-r--r--devel/git/Makefile1
-rw-r--r--www/p5-Apache-Gallery/Makefile3
-rw-r--r--www/rt36/Makefile2
-rw-r--r--x11/rxvt-unicode/Makefile1
4 files changed, 4 insertions, 3 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 7ded7e782f8d..c3b8e2c03754 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -169,6 +169,7 @@ MAKE_ENV+= LIBMD_SHA1=yes \
MAKE_ARGS+= prefix="${PREFIX}"
USE_OPENSSL= yes
USE_RC_SUBR= git_daemon
+WANT_PERL= yes
SHELLS= /etc/shells
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index e8d0d3f5991c..d8e380aa0c37 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -26,6 +26,7 @@ BUILD_DEPENDS= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
RUN_DEPENDS= ${BUILD_DEPENDS}
+PERL_CONFIGURE= yes
USE_APACHE= 1.3+
.include <bsd.port.pre.mk>
@@ -35,8 +36,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-l
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
.endif
-PERL_CONFIGURE= yes
-
MAN3= Apache::Gallery.3
DOC_FILES= INSTALL LICENSE README TODO UPGRADE
diff --git a/www/rt36/Makefile b/www/rt36/Makefile
index 9d38fc42c951..7e4d5ce4c936 100644
--- a/www/rt36/Makefile
+++ b/www/rt36/Makefile
@@ -57,6 +57,7 @@ HAS_CONFIGURE= yes
NO_BUILD= yes
NO_PACKAGE= Executes scripts in post-install phase
USE_APACHE= 1.3+
+USE_PERL5= 5.8.3+
CONFIGURE_ARGS= --prefix=${RT_PATH} \
--enable-layout=${LAYOUT} \
@@ -107,7 +108,6 @@ PERL_MODULES+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-D
BUILD_DEPENDS+= ${PERL_MODULES}
RUN_DEPENDS+= ${PERL_MODULES}
-USE_PERL5= 5.8.3+
RT_PATH?= ${PREFIX}/rt3
PLIST_SUB= RT_PATH=${RT_PATH} RTPLIST=${RT_PATH:S/^${PREFIX}\///}
LAYOUT?= RT3
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index aed7e190f0a9..2eee0e73c1eb 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -20,6 +20,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS= --enable-shared --enable-everything --with-term=rxvt
USE_BZIP2= yes
+WANT_PERL= yes
OPTIONS= \
PERL "Embedded perl interpreter" On \