aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-03-27 19:41:49 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-03-27 19:41:49 +0000
commitc602617259f4ad1af79278e63c86196402ab8b97 (patch)
treeeea52e2685044937bf43015c87d1635d35ec2a6b
parentbbc250f452f8a8a82ff952b72e17b0bbbc6398d0 (diff)
Notes
-rw-r--r--graphics/netpbm/Makefile10
-rw-r--r--graphics/openjpeg/Makefile2
-rw-r--r--net-mgmt/xymon-server/Makefile2
-rw-r--r--news/cnews/Makefile2
-rw-r--r--news/fidogate/Makefile6
-rw-r--r--x11-wm/fvwm/Makefile2
6 files changed, 18 insertions, 6 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index df5afd52fec6..d43587c90961 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -35,16 +35,18 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
.endif
+MAKE_JOBS_UNSAFE= yes
+CONFLICTS= mgetty-1.*
+.if !defined(WITH_NETPBM_DEVEL)
+PORTSCOUT= limit:^10\.26\.
+.endif
+
USE_PERL5= yes
USE_GMAKE= yes
MAKE_ENV= LN="${LN}" RANLIB="${RANLIB}"
MAKEFILE= GNUmakefile
INSTALL_TARGET= install.bin install.lib install.data install-dev
USE_LDCONFIG= yes
-CONFLICTS= mgetty-1.*
-.if !defined(WITH_NETPBM_DEVEL)
-PORTSCOUT= limit:^10\.26\.
-.endif
MAN1= netpbm.1
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index ccebb6b9b94b..798771cd0d5a 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -18,6 +18,8 @@ COMMENT= An open-source JPEG 2000 codec
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
+MAKE_JOBS_UNSAFE= yes
+
USE_GMAKE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/OpenJPEG_v1_3
diff --git a/net-mgmt/xymon-server/Makefile b/net-mgmt/xymon-server/Makefile
index 187b803a3f91..fee17f7109de 100644
--- a/net-mgmt/xymon-server/Makefile
+++ b/net-mgmt/xymon-server/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= png:${PORTSDIR}/graphics/png \
pcre:${PORTSDIR}/devel/pcre
RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
+MAKE_JOBS_UNSAFE= yes
+
# Options
BBUSER?= hobbit
BBHOSTNAME?= hobbit.example.com
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index 218e9abd96b5..7f9f23b865ce 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -36,6 +36,8 @@ PATCHFILES= c-news-patch-fileart.c c-news-patch-namelen \
MAINTAINER= dinoex@FreeBSD.org
COMMENT= An news server
+MAKE_JOBS_UNSAFE= yes
+
DIST_SUBDIR= ${DISTNAME}
NO_WRKSUBDIR= yes
MAKEFILE= makefile
diff --git a/news/fidogate/Makefile b/news/fidogate/Makefile
index 1eff3c2d142d..b4c4e2131262 100644
--- a/news/fidogate/Makefile
+++ b/news/fidogate/Makefile
@@ -16,15 +16,17 @@ MASTER_SITE_SUBDIR= system/fido
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Fido-Internet Gateway and Tosser
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-perl
-
.if !defined(WITHOUT_IFCICO)
RUN_DEPENDS= ${LOCALBASE}/libexec/ifmail/ifcico:${PORTSDIR}/news/ifmail
.endif
+MAKE_JOBS_UNSAFE= yes
+
USE_GMAKE= yes
USE_PERL5= yes
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-perl
+
DOCLIST= fidogate.texi fidogate.txt gatebau94.txt kludge-rfc.doc \
msgid.doc qmail.txt texinfo.tex dirs.html index.html \
template.html fido howto misc rfc gatebau/msgid.sgml \
diff --git a/x11-wm/fvwm/Makefile b/x11-wm/fvwm/Makefile
index c1d506220ba9..fa09a1149740 100644
--- a/x11-wm/fvwm/Makefile
+++ b/x11-wm/fvwm/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= The fvwm window manager
NO_LATEST_LINK= yes
+MAKE_JOBS_UNSAFE= yes
+
USE_IMAKE= yes
USE_XORG= xbitmaps xpm xext x11 xmu
# must overwrite the default from bsd.port.mk