aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-12-20 10:11:29 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-12-20 10:11:29 +0000
commitc7e05b5f300890653ec31a635f46b1c11a0e2fed (patch)
treecd4c616e2b24275dd26f16a4aa5479b59eeece03
parent17f97dd01cc7585723b151b492deb9ee21e04d91 (diff)
downloadports-c7e05b5f300890653ec31a635f46b1c11a0e2fed.tar.gz
ports-c7e05b5f300890653ec31a635f46b1c11a0e2fed.zip
MFH: r520166 astro/pyephem: Add missing (ephem) dependency
The 3.7.7.0 release of pyephem was converted [1] into a stub, depending on the ephem package, in order to allow software authors to transition to the new package name. The ports r511276 commit updating the port to 3.7.7.0 missed the additional dependency. This change adds the missing dependency, after astro/py-ephem landed as a new port in ports r520162, and unbreaks all current astro/pyephem dependents, and all transitive dependents, including comms/gnuradio [2]. While I'm here: - Add NO_ARCH - Bump PORTREVISION given this issue did not affect builds, just runtime and dependents accordingly. [1] https://github.com/brandon-rhodes/pyephem/commit/5c32679a8650efd2e79d5f794edd1587b3b6e67b [2] bug 240546 PR: 240735 Submitted by: Rainer Hurling <rhurlin gwdg de> Approved by: portmgr (blanket(s): missing dependencies, build/run fix (dependents)) Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2019Q4/; revision=520494
-rw-r--r--astro/pyephem/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/astro/pyephem/Makefile b/astro/pyephem/Makefile
index 70e9675fd172..b27123caca08 100644
--- a/astro/pyephem/Makefile
+++ b/astro/pyephem/Makefile
@@ -3,10 +3,10 @@
PORTNAME= pyephem
PORTVERSION= 3.7.7.0
+PORTREVISION= 1
PORTEPOCH= 1
-CATEGORIES= astro math hamradio
+CATEGORIES= astro math python
MASTER_SITES= CHEESESHOP
-# XXX rename the directory too.
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
@@ -14,7 +14,11 @@ COMMENT= Scientific-grade astronomical computations for Python
LICENSE= LGPL3
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ephem==${PORTVERSION}:astro/py-ephem@${PY_FLAVOR}
+
USES= python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
.include <bsd.port.mk>