aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-07-01 07:19:44 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-07-01 07:19:44 +0000
commitd0cf2ae03fadb45248c16584e93a44f5b08e8669 (patch)
treeb968a05d2e589ec95b29417a7af3c6a3e4b8151b
parenta87fd3e21edf5e4b5b2756ec94c01b6a73adce37 (diff)
Notes
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/libtorrent-rasterbar-15-python/Makefile48
-rw-r--r--net-p2p/libtorrent-rasterbar-15-python/pkg-plist1
3 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 4d5d0ca67b7c..4e7baa04ad46 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -64,6 +64,7 @@
SUBDIR += libtorrent-devel
SUBDIR += libtorrent-rasterbar-14
SUBDIR += libtorrent-rasterbar-15
+ SUBDIR += libtorrent-rasterbar-15-python
SUBDIR += limewire
SUBDIR += linux-agsatellite
SUBDIR += linux-edonkey-core
diff --git a/net-p2p/libtorrent-rasterbar-15-python/Makefile b/net-p2p/libtorrent-rasterbar-15-python/Makefile
new file mode 100644
index 000000000000..1b359875c978
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-15-python/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: libtorrent-rasterbar-15-python
+# Date created: Mon Apr 29 01:53:20 UTC 2010
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+#
+# $FreeBSD$
+
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+COMMENT= Python bindings for libtorrent-rasterbar-15
+CATEGORIES= net-p2p python
+
+CONFLICTS+= py*-libtorrent-rasterbar-0.14.*
+
+USE_PYTHON= 2.5+
+
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>=0.6:${PORTSDIR}/devel/py-setuptools
+LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python-libs \
+ torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15
+
+BUILD_WRKSRC= ${WRKSRC}/bindings/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+PLIST= ${.CURDIR}/pkg-plist
+
+INSTALLS_EGGINFO= yes
+PYDISTUTILS_EGGINFO= python_libtorrent-${PORTVERSION}-py${PYTHON_VER}.egg-info
+
+NOPORTDOCS= yes
+
+slave-post-patch:
+ @${REINPLACE_CMD} -E -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/bindings/python/setup.py.in
+
+slave-post-install:
+# fix installation permissions
+ @${CHMOD} ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/libtorrent.so
+
+MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar-15
+.include "${MASTERDIR}/Makefile"
+
+##
+# information available after <bsd.port.pre.mk>
+##
+# insure python paths are correctly identified
+CONFIGURE_ENV+= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
+ PYTHON_VERSION="${PYTHON_VERSION}"
+# prefix PKGNAME with python- so that the egg info file is properly named.
+PYDISTUTILS_PKGNAME= python-${PORTNAME}
diff --git a/net-p2p/libtorrent-rasterbar-15-python/pkg-plist b/net-p2p/libtorrent-rasterbar-15-python/pkg-plist
new file mode 100644
index 000000000000..128a4b8d4812
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-15-python/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/libtorrent.so