aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-14 18:07:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-04-14 18:07:08 +0000
commitd69a0b0f5d549537bb2c0bfb3847b095411f8c2f (patch)
treeed2b9cf144fe5b527522a9c13da245cd940065c0
parentc8cb3b67f8bc37d28d8607a061642efb3e6ed0d9 (diff)
downloadports-d69a0b0f5d549537bb2c0bfb3847b095411f8c2f.tar.gz
ports-d69a0b0f5d549537bb2c0bfb3847b095411f8c2f.zip
- Fix shebang
Thanks to: amdmi3
Notes
Notes: svn path=/head/; revision=438530
-rw-r--r--lang/python27/Makefile13
-rw-r--r--lang/python33/Makefile8
-rw-r--r--lang/python34/Makefile9
-rw-r--r--lang/python35/Makefile9
-rw-r--r--lang/python36/Makefile9
5 files changed, 41 insertions, 7 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index a025105e5270..e1293eae2a1d 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python27
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -13,10 +13,17 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz shebangfix
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+SHEBANG_FILES= Lib/lib2to3/pgen2/*.py Lib/lib2to3/tests/*.py Lib/lib2to3/tests/data/*.py \
+ Lib/idlelib/*.py Lib/encodings/*.py Lib/test/*.py Lib/UserString.py \
+ Lib/base64.py Lib/cProfile.py Lib/keyword.py Lib/mimify.py Lib/pdb.py \
+ Lib/platform.py Lib/profile.py Lib/pydoc.py Lib/quopri.py Lib/smtpd.py \
+ Lib/smtplib.py Lib/symbol.py Lib/tabnanny.py Lib/timeit.py Lib/trace.py \
+ Lib/uu.py Lib/webbrowser.py
CPE_VENDOR= python
CPE_PRODUCT= ${CPE_VENDOR}
@@ -109,6 +116,8 @@ PLIST_SUB+= NO_NIS=""
.endif
post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
+ ${WRKSRC}/Lib/cgi.py
@${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${PATCH_WRKSRC}/Lib/pydoc.py
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 313a7b6564d8..c5a888714ef4 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python33
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -16,10 +16,12 @@ LICENSE= PSFL
DEPRECATED= No longer receives bug fixes, only security updates. Please update to Python 3.5
EXPIRATION_DATE= 2017-09-01
-USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz shebangfix
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+SHEBANG_FILES= Lib/lib2to3/tests/data/*.py Lib/encodings/*.py
CPE_VENDOR= python
CPE_PRODUCT= ${CPE_VENDOR}
@@ -106,6 +108,8 @@ PLIST_SUB+= NO_NIS=""
.endif
post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
+ ${WRKSRC}/Lib/cgi.py
.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
@${REINPLACE_CMD} -e 's/disabled_module_list =[^]]*/&, "nis"/' \
${WRKSRC}/setup.py
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index aeafd9d96133..ad2e50ffad9f 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python34
PORTVERSION= ${PYTHON_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -13,10 +14,12 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz shebangfix
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+SHEBANG_FILES= Lib/lib2to3/tests/data/*.py Lib/encodings/*.py
CPE_VENDOR= python
CPE_PRODUCT= ${CPE_VENDOR}
@@ -114,6 +117,10 @@ DISABLED_EXTENSIONS+= nis
PLIST_SUB+= NO_NIS=""
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
+ ${WRKSRC}/Lib/cgi.py
+
post-install:
.if ! ${PORT_OPTIONS:MDEBUG}
${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index 393f988d2345..841e568f8577 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python
DISTVERSION= ${PYTHON_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -14,10 +15,12 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz shebangfix
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+SHEBANG_FILES= Lib/lib2to3/tests/data/*.py Lib/encodings/*.py
CPE_VENDOR= python
CPE_PRODUCT= ${CPE_VENDOR}
@@ -122,6 +125,10 @@ DISABLED_EXTENSIONS+= nis
PLIST_SUB+= NO_NIS=""
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
+ ${WRKSRC}/Lib/cgi.py
+
post-install:
.if ! ${PORT_OPTIONS:MDEBUG}
${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index f20268b77d63..b399db294baa 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -14,10 +15,12 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz shebangfix
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+SHEBANG_FILES= Lib/lib2to3/tests/data/*.py Lib/encodings/*.py
CPE_VENDOR= python
CPE_PRODUCT= ${CPE_VENDOR}
@@ -118,6 +121,10 @@ DISABLED_EXTENSIONS+= nis
PLIST_SUB+= NO_NIS=""
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
+ ${WRKSRC}/Lib/cgi.py
+
post-install:
.if ! ${PORT_OPTIONS:MDEBUG}
${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975