aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-10-12 06:23:47 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-10-12 06:23:47 +0000
commitd926c2a5658aa32e68f4c0f3635feeae540b01eb (patch)
treef7de8780d0aeec6aec05027992f8fe7f029a5c30
parentdecae9455e2c0013bcb6eef7c26552c3f1e5f4e0 (diff)
downloadports-d926c2a5658aa32e68f4c0f3635feeae540b01eb.tar.gz
ports-d926c2a5658aa32e68f4c0f3635feeae540b01eb.zip
Notes
-rw-r--r--archivers/pecl-rar/Makefile1
-rw-r--r--databases/pecl-couchbase/Makefile1
-rw-r--r--databases/php7-tarantool/Makefile2
-rw-r--r--devel/ioncube/Makefile1
-rw-r--r--devel/pecl-eio/Makefile1
-rw-r--r--devel/pecl-msgpack/Makefile2
-rw-r--r--devel/pecl-request/Makefile2
-rw-r--r--devel/pecl-uv/Makefile2
-rw-r--r--devel/pecl-vld/Makefile2
-rw-r--r--devel/pecl-weakref2/Makefile2
-rw-r--r--devel/pecl-yac/Makefile2
-rw-r--r--devel/pecl-yaconf/Makefile2
-rw-r--r--mail/pecl-mailparse/Makefile2
-rw-r--r--net/pecl-amqp/Makefile1
-rw-r--r--net/pecl-oauth2/Makefile2
-rw-r--r--net/pecl-smbclient/Makefile1
-rw-r--r--net/pecl-yaz/Makefile2
-rw-r--r--security/pecl-ssh2/Makefile2
-rw-r--r--textproc/pecl-yaml/Makefile2
-rw-r--r--www/pecl-solr/Makefile2
-rw-r--r--www/pecl-yaf/Makefile2
-rw-r--r--www/phalcon/Makefile1
22 files changed, 22 insertions, 15 deletions
diff --git a/archivers/pecl-rar/Makefile b/archivers/pecl-rar/Makefile
index 8b1883c4c784..33c935ed1468 100644
--- a/archivers/pecl-rar/Makefile
+++ b/archivers/pecl-rar/Makefile
@@ -12,6 +12,7 @@ LICENSE= PHP301
USES= php:pecl
USE_PHP= spl:build
+IGNORE_WITH_PHP= 73
CONFIGURE_ARGS= --enable-rar
diff --git a/databases/pecl-couchbase/Makefile b/databases/pecl-couchbase/Makefile
index 52fbfdd366f1..253abb0cde2c 100644
--- a/databases/pecl-couchbase/Makefile
+++ b/databases/pecl-couchbase/Makefile
@@ -16,5 +16,6 @@ LIB_DEPENDS= libcouchbase.so:databases/libcouchbase
USES= php:pecl
USE_PHP= json:build
+IGNORE_WITH_PHP= 73
.include <bsd.port.mk>
diff --git a/databases/php7-tarantool/Makefile b/databases/php7-tarantool/Makefile
index 05e9bbdf5e49..fcbbe7679853 100644
--- a/databases/php7-tarantool/Makefile
+++ b/databases/php7-tarantool/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:ext
CONFIGURE_ARGS= --with-tarantool
-IGNORE_WITH_PHP=56
+IGNORE_WITH_PHP=56 73
USE_GITHUB= yes
GH_PROJECT= ${PORTNAME}-php
diff --git a/devel/ioncube/Makefile b/devel/ioncube/Makefile
index 1781a8575ac4..203e0672a810 100644
--- a/devel/ioncube/Makefile
+++ b/devel/ioncube/Makefile
@@ -23,6 +23,7 @@ IGNORE_DragonFly= is unsupported on DragonFly
ONLY_FOR_ARCHS= amd64 i386
NO_BUILD= yes
USES= php:flavors
+IGNORE_WITH_PHP= 73
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/pecl-eio/Makefile b/devel/pecl-eio/Makefile
index 8f95b8e19554..a3aec8b2ee0f 100644
--- a/devel/pecl-eio/Makefile
+++ b/devel/pecl-eio/Makefile
@@ -12,5 +12,6 @@ LICENSE= PHP301
CONFIGURE_ARGS= --enable-eio
USES= php:pecl
+IGNORE_WITH_PHP= 73
.include <bsd.port.mk>
diff --git a/devel/pecl-msgpack/Makefile b/devel/pecl-msgpack/Makefile
index 587e06d21a8f..867bdd3ad313 100644
--- a/devel/pecl-msgpack/Makefile
+++ b/devel/pecl-msgpack/Makefile
@@ -11,6 +11,6 @@ COMMENT= Provides API for communicating with MessagePack serialization
LICENSE= BSD3CLAUSE
USES= php:pecl
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
.include <bsd.port.mk>
diff --git a/devel/pecl-request/Makefile b/devel/pecl-request/Makefile
index 12eacefcb013..5aa3972ebd01 100644
--- a/devel/pecl-request/Makefile
+++ b/devel/pecl-request/Makefile
@@ -12,6 +12,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
USES= php:pecl
-IGNORE_WITH_PHP= 56 72
+IGNORE_WITH_PHP= 56 72 73
.include <bsd.port.mk>
diff --git a/devel/pecl-uv/Makefile b/devel/pecl-uv/Makefile
index 49cd97a13a05..95463a356bd5 100644
--- a/devel/pecl-uv/Makefile
+++ b/devel/pecl-uv/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libuv.so:devel/libuv
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
USES= php:pecl
.include <bsd.port.mk>
diff --git a/devel/pecl-vld/Makefile b/devel/pecl-vld/Makefile
index 071461f072c5..1174d80f677a 100644
--- a/devel/pecl-vld/Makefile
+++ b/devel/pecl-vld/Makefile
@@ -11,7 +11,7 @@ COMMENT= Dump the internal representation of PHP scripts
LICENSE= BSD2CLAUSE
USES= php:pecl
-IGNORE_WITH_PHP= 70
+IGNORE_WITH_PHP= 70 73
CONFIGURE_ARGS= --enable-vld
diff --git a/devel/pecl-weakref2/Makefile b/devel/pecl-weakref2/Makefile
index bf56bfb824e2..1bd84564d96a 100644
--- a/devel/pecl-weakref2/Makefile
+++ b/devel/pecl-weakref2/Makefile
@@ -13,7 +13,7 @@ LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
CONFLICTS= pecl-weakref-1*
diff --git a/devel/pecl-yac/Makefile b/devel/pecl-yac/Makefile
index 1cb376bb57ae..a30be2f5b24e 100644
--- a/devel/pecl-yac/Makefile
+++ b/devel/pecl-yac/Makefile
@@ -12,7 +12,7 @@ COMMENT= Yac is a shared memory user data cache for PHP
LICENSE= PHP301
USES= php:pecl
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
OPTIONS_DEFINE= MSGPACK
MSGPACK_DESC= Enable MSGPACK module
diff --git a/devel/pecl-yaconf/Makefile b/devel/pecl-yaconf/Makefile
index 30e77d1da95f..a50239274d77 100644
--- a/devel/pecl-yaconf/Makefile
+++ b/devel/pecl-yaconf/Makefile
@@ -11,7 +11,7 @@ COMMENT= PHP Persistent Configurations Container
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
USES= php:pecl
.include <bsd.port.mk>
diff --git a/mail/pecl-mailparse/Makefile b/mail/pecl-mailparse/Makefile
index ba1d54e43b11..fa6b792eae9c 100644
--- a/mail/pecl-mailparse/Makefile
+++ b/mail/pecl-mailparse/Makefile
@@ -13,6 +13,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
USE_PHP= mbstring:build
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
.include <bsd.port.mk>
diff --git a/net/pecl-amqp/Makefile b/net/pecl-amqp/Makefile
index 812cb66f0f5b..ef84db6da854 100644
--- a/net/pecl-amqp/Makefile
+++ b/net/pecl-amqp/Makefile
@@ -14,5 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= librabbitmq.so:net/rabbitmq-c-devel
USES= php:pecl
+IGNORE_WITH_PHP= 73
.include <bsd.port.mk>
diff --git a/net/pecl-oauth2/Makefile b/net/pecl-oauth2/Makefile
index ff3c334905a4..2d75173bab26 100644
--- a/net/pecl-oauth2/Makefile
+++ b/net/pecl-oauth2/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcurl.so:ftp/curl
USES= php:pecl
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/pecl-smbclient/Makefile b/net/pecl-smbclient/Makefile
index 9b061f77fbea..42441a57be37 100644
--- a/net/pecl-smbclient/Makefile
+++ b/net/pecl-smbclient/Makefile
@@ -12,6 +12,7 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl samba:lib
+IGNORE_WITH_PHP= 73
CONFIGURE_ARGS= --with-libsmbclient=${LOCALBASE}
CPPFLAGS+= -I${SAMBAINCLUDES}
diff --git a/net/pecl-yaz/Makefile b/net/pecl-yaz/Makefile
index f56e609cc0aa..f77c4b369ea3 100644
--- a/net/pecl-yaz/Makefile
+++ b/net/pecl-yaz/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libyaz.so:net/yaz
USES= php:pecl
USE_GNOME+= libxslt
-IGNORE_WITH_PHP= 70
+IGNORE_WITH_PHP= 70 73
CONFIGURE_ARGS= --with-yaz=${LOCALBASE}
diff --git a/security/pecl-ssh2/Makefile b/security/pecl-ssh2/Makefile
index ef1503256549..acf5e01079ae 100644
--- a/security/pecl-ssh2/Makefile
+++ b/security/pecl-ssh2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libssh2.so:security/libssh2
USES= php:pecl
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
diff --git a/textproc/pecl-yaml/Makefile b/textproc/pecl-yaml/Makefile
index 6754ce80f06d..2df896461c49 100644
--- a/textproc/pecl-yaml/Makefile
+++ b/textproc/pecl-yaml/Makefile
@@ -14,6 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libyaml.so:textproc/libyaml
USES= php:pecl
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 73
.include <bsd.port.mk>
diff --git a/www/pecl-solr/Makefile b/www/pecl-solr/Makefile
index d785c875d977..5d4714844e77 100644
--- a/www/pecl-solr/Makefile
+++ b/www/pecl-solr/Makefile
@@ -15,6 +15,6 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= php:pecl
USE_PHP= json:build
-IGNORE_WITH_PHP= 72
+IGNORE_WITH_PHP= 72 73
.include <bsd.port.mk>
diff --git a/www/pecl-yaf/Makefile b/www/pecl-yaf/Makefile
index b0ec766913af..3e9744d106bb 100644
--- a/www/pecl-yaf/Makefile
+++ b/www/pecl-yaf/Makefile
@@ -11,7 +11,7 @@ COMMENT= MVC framework written as a C PHP extension
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP=56
+IGNORE_WITH_PHP=56 73
LIB_DEPENDS= libpcre.so:devel/pcre
diff --git a/www/phalcon/Makefile b/www/phalcon/Makefile
index a87b13472e53..2cb4a1dec404 100644
--- a/www/phalcon/Makefile
+++ b/www/phalcon/Makefile
@@ -16,6 +16,7 @@ ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
USES= php:ext
USE_PHP= hash:build json:build pdo:build
+IGNORE_WITH_PHP= 73
USE_GITHUB= yes
GH_ACCOUNT= phalcon