aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-10-29 11:04:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-10-29 11:04:11 +0000
commite05f23caea1414d7534cd61eaddec0fd48429af3 (patch)
tree434e9cafefe402f6f08f65c81cce227647e20da6
parent2b52f238f136e4da77bfbaa1e8d8df520f2b99aa (diff)
downloadports-e05f23caea1414d7534cd61eaddec0fd48429af3.tar.gz
ports-e05f23caea1414d7534cd61eaddec0fd48429af3.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-uni-perl/Makefile27
-rw-r--r--devel/p5-uni-perl/distinfo3
-rw-r--r--devel/p5-uni-perl/pkg-descr3
-rw-r--r--devel/p5-uni-perl/pkg-plist13
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 21963ecf4f25..b6f08625df3d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2144,6 +2144,7 @@
SUBDIR += p5-subversion
SUBDIR += p5-threads
SUBDIR += p5-threads-shared
+ SUBDIR += p5-uni-perl
SUBDIR += p5-usb
SUBDIR += p5-version
SUBDIR += p65
diff --git a/devel/p5-uni-perl/Makefile b/devel/p5-uni-perl/Makefile
new file mode 100644
index 000000000000..b8afbf8263a0
--- /dev/null
+++ b/devel/p5-uni-perl/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-uni-perl
+# Date created: 2009-10-20
+# Whom: Mons Anderson <mons@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uni-perl
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mons@cpan.org
+COMMENT= Modern perl with unicode
+
+RUN_DEPENDS= p5-Data-Dumper>=2:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Encode>=2.37:${PORTSDIR}/converters/p5-Encode \
+ p5-lib-abs>=0.90:${PORTSDIR}/devel/p5-lib-abs
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+MASTER_SITES = http://freebsd.dev.rambler.ru/distfiles/rambler/
+
+PERL_CONFIGURE= 5.10.0+
+
+MAN3= uni::perl.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-uni-perl/distinfo b/devel/p5-uni-perl/distinfo
new file mode 100644
index 000000000000..2f98b6ebcfc1
--- /dev/null
+++ b/devel/p5-uni-perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (uni-perl-0.03.tar.gz) = afacb5d25398ca27887d9f4c1b83c7f5
+SHA256 (uni-perl-0.03.tar.gz) = f33e8a73d71f6f899913fc7957e56bc3b96e305265f5c909e21771a9e7799856
+SIZE (uni-perl-0.03.tar.gz) = 26550
diff --git a/devel/p5-uni-perl/pkg-descr b/devel/p5-uni-perl/pkg-descr
new file mode 100644
index 000000000000..a31c9dcc7776
--- /dev/null
+++ b/devel/p5-uni-perl/pkg-descr
@@ -0,0 +1,3 @@
+Modern perl with unicode
+
+WWW: http://search.cpan.org/dist/uni-perl/
diff --git a/devel/p5-uni-perl/pkg-plist b/devel/p5-uni-perl/pkg-plist
new file mode 100644
index 000000000000..8fc6be08514f
--- /dev/null
+++ b/devel/p5-uni-perl/pkg-plist
@@ -0,0 +1,13 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/uni/perl.pm
+%%SITE_PERL%%/uni/perl/blackjack.pm
+%%SITE_PERL%%/uni/perl/hookers.pm
+%%SITE_PERL%%/uni/perl/encodebase.pm
+%%SITE_PERL%%/uni/perl/dumper.pm
+%%SITE_PERL%%/uni/perl/ru.pm
+%%SITE_PERL%%/uni/perl/ua.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/uni/perl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/uni/perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/uni
+@dirrmtry %%SITE_PERL%%/uni/perl
+@dirrmtry %%SITE_PERL%%/uni