aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-12-07 12:14:22 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-12-07 12:14:22 +0000
commite2577670a7a013b33e80ac2b147ffb35ac3dd4d0 (patch)
tree4e8876387ae59680def465e202073e66a337c0b5
parent7e13e7bc17d1a866f8fd136045f111e39e511195 (diff)
downloadports-e2577670a7a013b33e80ac2b147ffb35ac3dd4d0.tar.gz
ports-e2577670a7a013b33e80ac2b147ffb35ac3dd4d0.zip
MFH: r514338
misc/openvdb: fix build on GCC architectures Compiling on GCC architectures fails: /wrkdirs/usr/ports/misc/openvdb/work/openvdb-6.1.0/openvdb/points/AttributeSet.cc: In member function 'openvdb::v6_1::points::AttributeSet::Descriptor::Ptr openvdb::v6_1::points::AttributeSet::Descriptor::duplicateDrop(const std::vector<long unsigned int>&) const': /wrkdirs/usr/ports/misc/openvdb/work/openvdb-6.1.0/openvdb/points/AttributeSet.cc:875:59: error: 'CHAR_BIT' was not declared in this scope 875 | const size_t GROUP_BITS = sizeof(GroupType) * CHAR_BIT; | ^~~~~~~~ /wrkdirs/usr/ports/misc/openvdb/work/openvdb-6.1.0/openvdb/points/AttributeSet.cc:35:1: note: 'CHAR_BIT' is defined in header '<climits>'; did you forget to '#include <climits>'? 34 | #include "AttributeGroup.h" +++ |+#include <climits> 35 | While here, add USES=xorg for TOOLS option. PR: 240630 Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/branches/2019Q4/; revision=519203
-rw-r--r--misc/openvdb/Makefile2
-rw-r--r--misc/openvdb/files/patch-openvdb_points_AttributeSet.cc10
2 files changed, 11 insertions, 1 deletions
diff --git a/misc/openvdb/Makefile b/misc/openvdb/Makefile
index 03271fbe71cb..0a2190016949 100644
--- a/misc/openvdb/Makefile
+++ b/misc/openvdb/Makefile
@@ -40,7 +40,7 @@ TOOLS_CMAKE_BOOL= OPENVDB_BUILD_BINARIES OPENVDB_BUILD_VDB_LOD \
OPENVDB_BUILD_VDB_RENDER OPENVDB_BUILD_VDB_VIEW
TOOLS_LIB_DEPENDS= libglfw.so:graphics/glfw \
libIlmImf.so:graphics/openexr
-TOOLS_USES= gl
+TOOLS_USES= gl xorg
TOOLS_USE= GL=gl,glu XORG=x11,xcursor,xi,xinerama,xrandr,xxf86vm
DOCS_CMAKE_BOOL= OPENVDB_BUILD_DOCS
diff --git a/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc b/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc
new file mode 100644
index 000000000000..2ddcb64c3d0b
--- /dev/null
+++ b/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc
@@ -0,0 +1,10 @@
+--- openvdb/points/AttributeSet.cc.orig 2019-09-16 16:50:50 UTC
++++ openvdb/points/AttributeSet.cc
+@@ -34,6 +34,7 @@
+ #include "AttributeGroup.h"
+
+ #include <algorithm> // std::equal
++#include <climits> // CHAR_BIT
+ #include <string>
+
+ namespace openvdb {