aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-04-25 06:56:01 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-04-25 06:56:01 +0000
commite3ab3cf61067676a4804cde27dc1dd69654a503e (patch)
treed2fe593d656958cf0e701de5b7fb3f91d7fc69a5
parentaf73eb50442670bfb6cc17a085c333eb397f7295 (diff)
downloadports-e3ab3cf61067676a4804cde27dc1dd69654a503e.tar.gz
ports-e3ab3cf61067676a4804cde27dc1dd69654a503e.zip
Notes
-rw-r--r--x11-wm/fvwm2/Makefile10
-rw-r--r--x11-wm/fvwm24/Makefile10
2 files changed, 18 insertions, 2 deletions
diff --git a/x11-wm/fvwm2/Makefile b/x11-wm/fvwm2/Makefile
index e0b523991a59..72e59ee515c1 100644
--- a/x11-wm/fvwm2/Makefile
+++ b/x11-wm/fvwm2/Makefile
@@ -36,6 +36,14 @@ CONFIGURE_ARGS+= --with-stroke --with-stroke-library=${LOCALBASE}/lib \
--with-stroke-includes=${LOCALBASE}/include
.endif
+.if defined(WITHOUT_SESSION_MGMT)
+CONFIGURE_ARGS+= --disable-sm
+.endif
+
+.if defined(WITHOUT_SHAPE)
+CONFIGURE_ARGS+= --disable-shape
+.endif
+
PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
.include <bsd.port.pre.mk>
@@ -44,7 +52,7 @@ PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
USE_GNOME= yes
PLIST_SUB+= GNOMEDATADIR="share/gnome/fvwm"
.else
-CONFIGURE_ARGS+= --without-gnome
+CONFIGURE_ARGS+= --without-gnome --disable-gnome-hints
PLIST_SUB+= GNOMEDATADIR="share/fvwm"
.endif
diff --git a/x11-wm/fvwm24/Makefile b/x11-wm/fvwm24/Makefile
index e0b523991a59..72e59ee515c1 100644
--- a/x11-wm/fvwm24/Makefile
+++ b/x11-wm/fvwm24/Makefile
@@ -36,6 +36,14 @@ CONFIGURE_ARGS+= --with-stroke --with-stroke-library=${LOCALBASE}/lib \
--with-stroke-includes=${LOCALBASE}/include
.endif
+.if defined(WITHOUT_SESSION_MGMT)
+CONFIGURE_ARGS+= --disable-sm
+.endif
+
+.if defined(WITHOUT_SHAPE)
+CONFIGURE_ARGS+= --disable-shape
+.endif
+
PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
.include <bsd.port.pre.mk>
@@ -44,7 +52,7 @@ PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
USE_GNOME= yes
PLIST_SUB+= GNOMEDATADIR="share/gnome/fvwm"
.else
-CONFIGURE_ARGS+= --without-gnome
+CONFIGURE_ARGS+= --without-gnome --disable-gnome-hints
PLIST_SUB+= GNOMEDATADIR="share/fvwm"
.endif