aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-08-06 17:00:13 +0000
committerXin LI <delphij@FreeBSD.org>2007-08-06 17:00:13 +0000
commite3b68cae2b01773ac1d6977e7aec8ea25b6fa630 (patch)
tree46dd48380723fa54f63a43790dd7a5d0dc49bbcc
parent55d045f1491ecc2bd50445d7506f836825f33081 (diff)
downloadports-e3b68cae2b01773ac1d6977e7aec8ea25b6fa630.tar.gz
ports-e3b68cae2b01773ac1d6977e7aec8ea25b6fa630.zip
Notes
-rw-r--r--editors/Makefile1
-rw-r--r--editors/madedit/Makefile30
-rw-r--r--editors/madedit/distinfo3
-rw-r--r--editors/madedit/files/patch-Makefile.in11
-rw-r--r--editors/madedit/pkg-descr7
-rw-r--r--editors/madedit/pkg-plist47
6 files changed, 99 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 542f8ae262f9..c059f77be48c 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -96,6 +96,7 @@
SUBDIR += leo
SUBDIR += lfhex
SUBDIR += lpe
+ SUBDIR += madedit
SUBDIR += manedit
SUBDIR += mg
SUBDIR += mined
diff --git a/editors/madedit/Makefile b/editors/madedit/Makefile
new file mode 100644
index 000000000000..7778085c33e6
--- /dev/null
+++ b/editors/madedit/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: madedit
+# Date created: 2007-08-08
+# Whom: Xin LI <delphij@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= madedit
+PORTVERSION= 0.2.7
+CATEGORIES= editors
+MASTER_SITES= SF
+
+MAINTAINER= delphij@FreeBSD.org
+COMMENT= An open-source and cross-platform text/hex editor
+
+USE_GETTEXT= yes
+USE_WX= 2.6+
+WANT_UNICODE= yes
+
+LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
+CONFIGURE_ENV+= PKG_CONFIG="${PKG_CONFIG}" glib_gtk2_CFLAGS="${glib_gtk2_CFLAGS}" glib_gtk2_LIBS="${glib_gtk2_LIBS}"
+
+PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
+glib_gtk2_CFLAGS=`${PKG_CONFIG} --cflags gtk+-2.0`
+glib_gtk2_LIBS= `${PKG_CONFIG} --libs gtk+-2.0`
+
+.include <bsd.port.mk>
diff --git a/editors/madedit/distinfo b/editors/madedit/distinfo
new file mode 100644
index 000000000000..72792a252eee
--- /dev/null
+++ b/editors/madedit/distinfo
@@ -0,0 +1,3 @@
+MD5 (madedit-0.2.7.tar.gz) = 9942261526394fbf4ea616e062b25066
+SHA256 (madedit-0.2.7.tar.gz) = 22b4b20e7472cf78a6fee5358d917d0e21da8bc991ad67518f621c1cf95c9740
+SIZE (madedit-0.2.7.tar.gz) = 1282681
diff --git a/editors/madedit/files/patch-Makefile.in b/editors/madedit/files/patch-Makefile.in
new file mode 100644
index 000000000000..d7d17fdec397
--- /dev/null
+++ b/editors/madedit/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- ./Makefile.in.orig 2007-02-27 23:06:16.000000000 +0800
++++ ./Makefile.in 2007-08-07 00:06:33.304370715 +0800
+@@ -283,7 +283,7 @@
+ target_alias = @target_alias@
+ SUBDIRS = syntax po
+ INCLUDES = -I$(top_srcdir)/wxFlatNotebook/include -I$(top_srcdir)/wxAUI/include -I$(top_srcdir)/charset-detector/include -I$(top_srcdir)/charset-detector/src -I$(top_srcdir)/charset-detector/src/tables
+-madedit_CXXFLAGS = -DwxUSE_AUI=1 -DWXDLLIMPEXP_AUI= -DDATA_DIR=\"${datadir}\"
++madedit_CXXFLAGS = -DwxUSE_AUI=1 -DWXDLLIMPEXP_AUI= -DDATA_DIR=\"${datadir}\" $(glib_gtk2_CFLAGS)
+ madedit_SOURCES = src/MadAboutDialog.cpp \
+ src/MadAboutDialog.h \
+ src/MadCommand.h \
diff --git a/editors/madedit/pkg-descr b/editors/madedit/pkg-descr
new file mode 100644
index 000000000000..a7ce45e20f03
--- /dev/null
+++ b/editors/madedit/pkg-descr
@@ -0,0 +1,7 @@
+MadEdit is an Open-Source & Cross-Platform Text/Hex Editor written
+in C++ and wxWidgets.
+
+MadEdit can edit files in Text/Column/Hex modes, and supports many
+useful functions, e.g. SyntaxHighlightings, WordWrap, Encodings.
+
+WWW: http://madedit.sourceforge.net
diff --git a/editors/madedit/pkg-plist b/editors/madedit/pkg-plist
new file mode 100644
index 000000000000..3f65f2a37119
--- /dev/null
+++ b/editors/madedit/pkg-plist
@@ -0,0 +1,47 @@
+bin/madedit
+share/locale/zh_CN/LC_MESSAGES/madedit.mo
+share/locale/zh_TW/LC_MESSAGES/madedit.mo
+share/locale/it_IT/LC_MESSAGES/madedit.mo
+share/pixmaps/madedit.xpm
+%%DATADIR%%/syntax/extension.list
+%%DATADIR%%/syntax/filename.list
+%%DATADIR%%/syntax/firstline.list
+%%DATADIR%%/syntax/Dark.sch
+%%DATADIR%%/syntax/DarkBlue.sch
+%%DATADIR%%/syntax/Gray.sch
+%%DATADIR%%/syntax/syntax_actionscript.syn
+%%DATADIR%%/syntax/syntax_angelscript.syn
+%%DATADIR%%/syntax/syntax_awk.syn
+%%DATADIR%%/syntax/syntax_batch.syn
+%%DATADIR%%/syntax/syntax_conf.syn
+%%DATADIR%%/syntax/syntax_cpp.syn
+%%DATADIR%%/syntax/syntax_csharp.syn
+%%DATADIR%%/syntax/syntax_css.syn
+%%DATADIR%%/syntax/syntax_diff.syn
+%%DATADIR%%/syntax/syntax_fortran.syn
+%%DATADIR%%/syntax/syntax_html.syn
+%%DATADIR%%/syntax/syntax_javascript.syn
+%%DATADIR%%/syntax/syntax_java.syn
+%%DATADIR%%/syntax/syntax_js_html.syn
+%%DATADIR%%/syntax/syntax_jsp.syn
+%%DATADIR%%/syntax/syntax_latex.syn
+%%DATADIR%%/syntax/syntax_lua.syn
+%%DATADIR%%/syntax/syntax_nfo.syn
+%%DATADIR%%/syntax/syntax_pas.syn
+%%DATADIR%%/syntax/syntax_perl.syn
+%%DATADIR%%/syntax/syntax_php.syn
+%%DATADIR%%/syntax/syntax_python.syn
+%%DATADIR%%/syntax/syntax_reg.syn
+%%DATADIR%%/syntax/syntax_ruby.syn
+%%DATADIR%%/syntax/syntax_sh.syn
+%%DATADIR%%/syntax/syntax_squirrel.syn
+%%DATADIR%%/syntax/syntax_syn.syn
+%%DATADIR%%/syntax/syntax_txt.syn
+%%DATADIR%%/syntax/syntax_vbscript_asp.syn
+%%DATADIR%%/syntax/syntax_visualbasic.syn
+%%DATADIR%%/syntax/syntax_x86asm.syn
+%%DATADIR%%/syntax/syntax_xml.syn
+share/applications/madedit.desktop
+@dirrmtry %%DATADIR%%/syntax
+@dirrmtry share/locale/it_IT/LC_MESSAGES
+@dirrmtry share/locale/it_IT