aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2006-10-10 05:31:20 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2006-10-10 05:31:20 +0000
commite8b7ef58d829db5cb75308857a123e677b6288c8 (patch)
tree026f363037b652952418b38989a0187d05782b7f
parentb962a3df046a19c96f9f37f392ed503a8926e4d0 (diff)
Notes
-rw-r--r--lang/python25/Makefile1
-rw-r--r--lang/python26/Makefile1
-rw-r--r--lang/python27/Makefile1
-rw-r--r--lang/python30/Makefile1
-rw-r--r--lang/python31/Makefile1
-rw-r--r--lang/python32/Makefile1
6 files changed, 6 insertions, 0 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 8831de95431e..04f73a152081 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -149,6 +149,7 @@ pre-patch:
${PATCH_WRKSRC}/Misc/python-config.in > ${WRKDIR}/${PYTHON_VERSION:S/thon/thon-shared/}-config
.if defined(WITH_FPECTL) && ${ARCH} == i386
+ ${MKDIR} ${WRKSRC}/Modules
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif