aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-10 00:37:04 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-10 00:37:04 +0000
commitf2894a6ab80d7139ed139c5d231d34dca04d60d1 (patch)
tree9246aacea92f8f96f8815c9a8ce70fbf3a0111e5
parent9f260c691c2344bcd273d00ebb0867e46d654e0f (diff)
downloadports-f2894a6ab80d7139ed139c5d231d34dca04d60d1.tar.gz
ports-f2894a6ab80d7139ed139c5d231d34dca04d60d1.zip
Notes
-rw-r--r--www/shellinabox/Makefile17
-rw-r--r--www/shellinabox/distinfo4
-rw-r--r--www/shellinabox/files/patch-Makefile.in10
-rw-r--r--www/shellinabox/files/patch-config.h.in15
-rw-r--r--www/shellinabox/files/patch-shellinabox__launcher.c74
-rw-r--r--www/shellinabox/files/patch-ssl.in12
6 files changed, 11 insertions, 121 deletions
diff --git a/www/shellinabox/Makefile b/www/shellinabox/Makefile
index 7c1d4a5924b7..09d0f8b9db73 100644
--- a/www/shellinabox/Makefile
+++ b/www/shellinabox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= shellinabox
-PORTVERSION= 2.10
-PORTREVISION= 3
+PORTVERSION= 2.14
CATEGORIES= www
MASTER_SITES= GOOGLE_CODE
@@ -17,7 +16,8 @@ COMMENT= Publish command line shell through AJAX interface
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS= ENABLE_CORES "Patch shellinaboxd to enable core dumps." off
+OPTIONS_DEFINE= CORES MANPAGES
+CORES_DESC= Patch shellinaboxd to enable core dumps
HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
@@ -29,7 +29,7 @@ USE_RC_SUBR= shellinaboxd
USERS?= shellinabox
GROUPS?= shellinabox
-MAN1= shellinaboxd.1
+MAN1= shellinaboxd.1
PORTDOCS= AUTHORS ChangeLog INSTALL README COPYING GPL-2 NEWS TODO
@@ -38,8 +38,6 @@ PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-deinstall
SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
-.include <bsd.port.options.mk>
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "powerpc"
@@ -47,7 +45,7 @@ BROKEN= Does not load on powerpc
.endif
post-patch:
-.if defined(WITH_ENABLE_CORES)
+.if ${PORT_OPTIONS:MCORES}
@${REINPLACE_CMD} \
-e 's|prctl(PR_SET_DUMPABLE,|// &|' \
-e 's|setrlimit(RLIMIT_CORE,|// &|' \
@@ -56,9 +54,12 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/shellinaboxd ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+
.endif
${MKDIR} ${ETCDIR}/
${CHMOD} 700 ${ETCDIR}/
diff --git a/www/shellinabox/distinfo b/www/shellinabox/distinfo
index 4810ce7dc83f..6254df7861b2 100644
--- a/www/shellinabox/distinfo
+++ b/www/shellinabox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (shellinabox-2.10.tar.gz) = 9a2dfa14fcb050de6f450b3b53522f2106cdef4a5591e3e41bd00de1e11d43cb
-SIZE (shellinabox-2.10.tar.gz) = 513430
+SHA256 (shellinabox-2.14.tar.gz) = 4126eb7070869787c161102cc2781d24d1d50c8aef4e5a3e1b5446e65d691071
+SIZE (shellinabox-2.14.tar.gz) = 544919
diff --git a/www/shellinabox/files/patch-Makefile.in b/www/shellinabox/files/patch-Makefile.in
deleted file mode 100644
index eebebc7ddde6..000000000000
--- a/www/shellinabox/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./Makefile.in.orig 2009-11-21 23:47:39.000000000 +0100
-+++ ./Makefile.in 2010-08-12 15:05:47.001428510 +0200
-@@ -372,6 +372,7 @@
- i[0-9]86) echo '-O elf32-i386 -B i386';; \
- x86_64) echo '-O elf64-x86-64 -B i386:x86-64';; \
- arm*) echo '-O elf32-littlearm -B arm';; \
-+ sparc64) echo '-O elf64-sparc -B sparc';; \
- esac
-
- renamesymbols = \
diff --git a/www/shellinabox/files/patch-config.h.in b/www/shellinabox/files/patch-config.h.in
deleted file mode 100644
index 8099bbb7e3b9..000000000000
--- a/www/shellinabox/files/patch-config.h.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./config.h.in.orig 2009-11-21 23:47:44.000000000 +0100
-+++ ./config.h.in 2010-08-12 14:11:16.292619989 +0200
-@@ -105,6 +105,12 @@
- /* Define to 1 if you have the <utmp.h> header file. */
- #undef HAVE_UTMP_H
-
-+/* Define to 1 if you have support for updwtmp */
-+#undef HAVE_UPDWTMP
-+
-+/* Define to 1 if you have support for updwtmpx */
-+#undef HAVE_UPDWTMPX
-+
- /* Define to 1 if zlib development files are installed */
- #undef HAVE_ZLIB
-
diff --git a/www/shellinabox/files/patch-shellinabox__launcher.c b/www/shellinabox/files/patch-shellinabox__launcher.c
deleted file mode 100644
index 27ebf55e25ed..000000000000
--- a/www/shellinabox/files/patch-shellinabox__launcher.c
+++ /dev/null
@@ -1,74 +0,0 @@
---- ./shellinabox/launcher.c.orig 2009-11-21 23:20:39.000000000 +0100
-+++ ./shellinabox/launcher.c 2010-08-12 14:11:16.296619939 +0200
-@@ -495,6 +495,33 @@
- return utmp;
- }
-
-+#if defined(HAVE_UPDWTMP) && !defined(HAVE_UPDWTMPX)
-+#define min(a,b) ({ typeof(a) _a=(a); typeof(b) _b=(b); _a < _b ? _a : _b; })
-+#define updwtmpx x_updwtmpx
-+static void updwtmpx(const char *wtmpx_file, const struct utmpx *utx) {
-+ struct utmp ut = { 0 };
-+ ut.ut_type = utx->ut_type;
-+ ut.ut_pid = utx->ut_pid;
-+ ut.ut_session = utx->ut_session;
-+ ut.ut_tv.tv_sec = utx->ut_tv.tv_sec;
-+ ut.ut_tv.tv_usec = utx->ut_tv.tv_usec;
-+ memcpy(&ut.ut_line, &utx->ut_line,
-+ min(sizeof(ut.ut_line), sizeof(utx->ut_line)));
-+ memcpy(&ut.ut_id, &utx->ut_id,
-+ min(sizeof(ut.ut_id), sizeof(utx->ut_id)));
-+ memcpy(&ut.ut_user, &utx->ut_user,
-+ min(sizeof(ut.ut_user), sizeof(utx->ut_user)));
-+ memcpy(&ut.ut_host, &utx->ut_host,
-+ min(sizeof(ut.ut_host), sizeof(utx->ut_host)));
-+ memcpy(&ut.ut_exit, &utx->ut_exit,
-+ min(sizeof(ut.ut_exit), sizeof(utx->ut_exit)));
-+ memcpy(&ut.ut_addr_v6, &utx->ut_addr_v6,
-+ min(sizeof(ut.ut_addr_v6), sizeof(utx->ut_addr_v6)));
-+ updwtmp(wtmpx_file, &ut);
-+}
-+#endif
-+
-+
- void destroyUtmp(struct Utmp *utmp) {
- if (utmp) {
- if (utmp->pty >= 0) {
-@@ -518,9 +545,12 @@
- setutxent();
- pututxline(&utmp->utmpx);
- endutxent();
-+
-+#if defined(HAVE_UPDWTMP) || defined(HAVE_UPDWTMPX)
- if (!utmp->useLogin) {
- updwtmpx("/var/log/wtmp", &utmp->utmpx);
- }
-+#endif
-
- // Switch back to the lower privileges
- check(!setresgid(r_gid, e_gid, s_gid));
-@@ -1027,7 +1057,9 @@
- setutxent();
- pututxline(&utmp->utmpx);
- endutxent();
-+#if defined(HAVE_UPDWTMP) || defined(HAVE_UPDWTMPX)
- updwtmpx("/var/log/wtmp", &utmp->utmpx);
-+#endif
- }
- #endif
-
-@@ -1308,12 +1340,14 @@
- }
- pututxline(&utmpx);
- endutxent();
-+#if defined(HAVE_UPDWTMP) || defined(HAVE_UPDWTMPX)
- if (!utmp->useLogin) {
- memset(&utmpx.ut_user, 0, sizeof(utmpx.ut_user));
- strncat(&utmpx.ut_user[0], "LOGIN", sizeof(utmpx.ut_user));
- updwtmpx("/var/log/wtmp", &utmpx);
- }
- #endif
-+#endif
-
- // Create session. We might have to fork another process as PAM wants us
- // to close the session when the child terminates. And we must retain
diff --git a/www/shellinabox/files/patch-ssl.in b/www/shellinabox/files/patch-ssl.in
deleted file mode 100644
index d4ffa216cbc2..000000000000
--- a/www/shellinabox/files/patch-ssl.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- libhttp/ssl.c.orig 2010-07-01 12:15:40.000000000 +0200
-+++ libhttp/ssl.c 2010-07-01 12:16:56.000000000 +0200
-@@ -626,6 +626,9 @@
- return -1;
- }
- struct hostent *he = gethostbyname(name);
-+ if (!he) {
-+ return -1;
-+ }
- *ret = *he;
- if (result) {
- *result = ret;