aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2008-08-25 03:05:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2008-08-25 03:05:46 +0000
commitf291d081d573f410f56db7fa6abed9041a8d57e3 (patch)
tree5429b9e42e7b82f69cff2aec2d79c7e23adfd3d8
parented3b837072f0b8a6b2555da1de51ff4f713972e4 (diff)
Notes
-rw-r--r--devel/php5-phing/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/php5-phing/Makefile b/devel/php5-phing/Makefile
index 168b100f5da9..d56d8c02eb26 100644
--- a/devel/php5-phing/Makefile
+++ b/devel/php5-phing/Makefile
@@ -7,7 +7,7 @@
PORTNAME= phing
PORTVERSION= 2.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://pear.phing.info/get/
@@ -37,6 +37,7 @@ FILES= etc/log.xsl etc/phpunit2-noframes.xsl etc/phpunit2-frames.xsl \
BuildLogger.php TaskContainer.php BuildEvent.php Task.php \
TaskAdapter.php Phing.php RuntimeConfigurable.php BuildListener.php \
Project.php UnknownElement.php BuildException.php Target.php \
+ phing.php \
util/regexp/RegexpEngine.php util/regexp/Regexp.php \
util/regexp/PregEngine.php \
util/SourceFileScanner.php util/ExtendedFileStream.php \
@@ -219,18 +220,19 @@ FILES= etc/log.xsl etc/phpunit2-noframes.xsl etc/phpunit2-frames.xsl \
DOCS=
EXAMPLES= src/HelloWorldTest.php src/HelloWorld.php build.xml
SQLS=
-SCRIPTFILES=
+SCRIPTFILES= phing
TESTS=
post-extract:
${MV} ${WRKSRC}/example ${WRKSRC}/examples
+
+post-patch:
+ ${MKDIR} ${WRKSRC}/pear-bin
${SED} -e "s|/opt/phing|${PREFIX}/lib/php/phing|" \
-e "s|@PHP-BIN@|${PREFIX}/bin/php|" \
-e "s|@PEAR-DIR@|${PREFIX}/share/pear|" \
- ${WRKSRC}/bin/pear-phing > ${WRKSRC}/bin/pear-phing.new
- @${INSTALL_SCRIPT} ${WRKSRC}/bin/pear-phing.new ${PREFIX}/bin/phing
- ${INSTALL_DATA} ${WRKSRC}/bin/phing.php ${PREFIX}/share/pear/phing.php
- @${CHMOD} 755 ${PREFIX}/bin/phing
+ ${WRKSRC}/bin/pear-phing > ${WRKSRC}/pear-phing
+ ${CP} ${WRKSRC}/bin/phing.php ${WRKSRC}/phing.php
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"