aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-17 22:19:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-17 22:19:39 +0000
commitf34318c64e93ec8e1da5472529b645a334f93d85 (patch)
tree9bfb6f31880a3a357330e40cec1e25957d7fb921
parent9e3e90903aefee58a80474bcaee598e5834f2646 (diff)
Notes
-rw-r--r--security/i2pd/Makefile3
-rw-r--r--security/i2pd/distinfo6
-rw-r--r--security/i2pd/files/patch-build_CMakeLists.txt15
-rw-r--r--security/i2pd/files/patch-daemon_I2PControl.cpp11
-rw-r--r--security/i2pd/files/patch-libi2pd_I2PEndian.h16
-rw-r--r--security/i2pd/files/patch-libi2pd_Reseed.cpp11
6 files changed, 4 insertions, 58 deletions
diff --git a/security/i2pd/Makefile b/security/i2pd/Makefile
index 56346bbdaa89..ec78b342c32c 100644
--- a/security/i2pd/Makefile
+++ b/security/i2pd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= i2pd
-PORTVERSION= 2.17.0
-PORTREVISION= 1
+PORTVERSION= 2.18.0
CATEGORIES= security net-p2p
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/security/i2pd/distinfo b/security/i2pd/distinfo
index 9e129b606e86..b77826d8e864 100644
--- a/security/i2pd/distinfo
+++ b/security/i2pd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1512469109
-SHA256 (PurpleI2P-i2pd-2.17.0_GH0.tar.gz) = 9afc79427300cabd4e50216466bcb5be980aee841dc2aea17a8c2ab60cd7918b
-SIZE (PurpleI2P-i2pd-2.17.0_GH0.tar.gz) = 1874984
+TIMESTAMP = 1518621300
+SHA256 (PurpleI2P-i2pd-2.18.0_GH0.tar.gz) = 8834190418de0c4e56c46eb8b9dc4422ef14f1ad7d6591e9daae99493bf7170e
+SIZE (PurpleI2P-i2pd-2.18.0_GH0.tar.gz) = 1868440
diff --git a/security/i2pd/files/patch-build_CMakeLists.txt b/security/i2pd/files/patch-build_CMakeLists.txt
deleted file mode 100644
index f10b0e3cebf0..000000000000
--- a/security/i2pd/files/patch-build_CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- build/CMakeLists.txt.orig 2017-12-04 18:40:32 UTC
-+++ build/CMakeLists.txt
-@@ -461,12 +461,6 @@ if (WITH_BINARY)
- fixup_bundle(\"${APPS}\" \"\" \"${DIRS}\")
- " COMPONENT Runtime)
- endif ()
--
-- if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
-- if (NOT (MSVC OR MSYS OR APPLE)) # for Clang build on Linux
-- target_link_libraries("${PROJECT_NAME}" stdc++)
-- endif()
-- endif()
- endif ()
-
- install(FILES ../LICENSE
diff --git a/security/i2pd/files/patch-daemon_I2PControl.cpp b/security/i2pd/files/patch-daemon_I2PControl.cpp
deleted file mode 100644
index e45bc92bdfff..000000000000
--- a/security/i2pd/files/patch-daemon_I2PControl.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- daemon/I2PControl.cpp.orig 2017-12-04 18:40:32 UTC
-+++ daemon/I2PControl.cpp
-@@ -35,7 +35,7 @@ namespace client
- I2PControlService::I2PControlService (const std::string& address, int port):
- m_IsRunning (false), m_Thread (nullptr),
- m_Acceptor (m_Service, boost::asio::ip::tcp::endpoint(boost::asio::ip::address::from_string(address), port)),
-- m_SSLContext (m_Service, boost::asio::ssl::context::sslv23),
-+ m_SSLContext (boost::asio::ssl::context::sslv23),
- m_ShutdownTimer (m_Service)
- {
- i2p::config::GetOption("i2pcontrol.password", m_Password);
diff --git a/security/i2pd/files/patch-libi2pd_I2PEndian.h b/security/i2pd/files/patch-libi2pd_I2PEndian.h
deleted file mode 100644
index 218622fa0df7..000000000000
--- a/security/i2pd/files/patch-libi2pd_I2PEndian.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- libi2pd/I2PEndian.h.orig 2017-12-04 18:40:32 UTC
-+++ libi2pd/I2PEndian.h
-@@ -3,10 +3,10 @@
- #include <inttypes.h>
- #include <string.h>
-
--#if defined(__linux__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__)
--#include <endian.h>
--#elif __FreeBSD__
-+#if defined(__FreeBSD__)
- #include <sys/endian.h>
-+#elif defined(__linux__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__)
-+#include <endian.h>
- #elif defined(__APPLE__) && defined(__MACH__)
-
- #include <libkern/OSByteOrder.h>
diff --git a/security/i2pd/files/patch-libi2pd_Reseed.cpp b/security/i2pd/files/patch-libi2pd_Reseed.cpp
deleted file mode 100644
index da2ca8e2bbc2..000000000000
--- a/security/i2pd/files/patch-libi2pd_Reseed.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libi2pd/Reseed.cpp.orig 2017-12-04 18:40:32 UTC
-+++ libi2pd/Reseed.cpp
-@@ -522,7 +522,7 @@ namespace data
- boost::asio::io_service service;
- boost::system::error_code ecode;
-
-- boost::asio::ssl::context ctx(service, boost::asio::ssl::context::sslv23);
-+ boost::asio::ssl::context ctx(boost::asio::ssl::context::sslv23);
- ctx.set_verify_mode(boost::asio::ssl::context::verify_none);
- boost::asio::ssl::stream<boost::asio::ip::tcp::socket> s(service, ctx);
-