aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2007-07-31 19:19:26 +0000
committerAndrej Zverev <az@FreeBSD.org>2007-07-31 19:19:26 +0000
commitf570c27bb249685cb390795165539047b6df62a4 (patch)
tree3b54d99e4617a05264b31ef633ce533a6da0c2ce
parentff89f3b900eddf467a96b7886259cb4ffd158944 (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Thread-Pool-Simple/Makefile28
-rw-r--r--devel/p5-Thread-Pool-Simple/distinfo3
-rw-r--r--devel/p5-Thread-Pool-Simple/pkg-descr7
-rw-r--r--devel/p5-Thread-Pool-Simple/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0699be814f74..2c4908d3a4ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1587,6 +1587,7 @@
SUBDIR += p5-Text-LevenshteinXS
SUBDIR += p5-Text-vFile-asData
SUBDIR += p5-Thread-Apartment
+ SUBDIR += p5-Thread-Pool-Simple
SUBDIR += p5-Thread-Queue-Duplex
SUBDIR += p5-Tie-Array-Pack
SUBDIR += p5-Tie-Array-Sorted
diff --git a/devel/p5-Thread-Pool-Simple/Makefile b/devel/p5-Thread-Pool-Simple/Makefile
new file mode 100644
index 000000000000..efc16f2467cc
--- /dev/null
+++ b/devel/p5-Thread-Pool-Simple/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Thread-Pool-Simple
+# Date created: 2007-07-31
+# Whom: Andrej Zverev <az@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Thread-Pool-Simple
+PORTVERSION= 0.23
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Thread
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Simple thread-pool implementaion
+
+PERL_CONFIGURE= yes
+
+MAN3= Thread::Pool::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Thread-Pool-Simple/distinfo b/devel/p5-Thread-Pool-Simple/distinfo
new file mode 100644
index 000000000000..61c3125b92b7
--- /dev/null
+++ b/devel/p5-Thread-Pool-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Thread-Pool-Simple-0.23.tar.gz) = 49f5526dded82f4375035e46e49e3c7d
+SHA256 (Thread-Pool-Simple-0.23.tar.gz) = e7b6c94deb90682edb11e70927dd85dafcf0ec2bc09c914fff9a3aa0b18731fd
+SIZE (Thread-Pool-Simple-0.23.tar.gz) = 4660
diff --git a/devel/p5-Thread-Pool-Simple/pkg-descr b/devel/p5-Thread-Pool-Simple/pkg-descr
new file mode 100644
index 000000000000..0b49e575535a
--- /dev/null
+++ b/devel/p5-Thread-Pool-Simple/pkg-descr
@@ -0,0 +1,7 @@
+Thread::Pool::Simple provides a simple thread-pool implementaion without
+external dependencies outside core modules.
+
+Jobs can be submitted to and handled by multi-threaded `workers' managed
+by the pool.
+
+WWW: http://search.cpan.org/dist/Thread-Pool-Simple/
diff --git a/devel/p5-Thread-Pool-Simple/pkg-plist b/devel/p5-Thread-Pool-Simple/pkg-plist
new file mode 100644
index 000000000000..e0a8f0ff7e65
--- /dev/null
+++ b/devel/p5-Thread-Pool-Simple/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Thread/Pool/Simple/.packlist
+%%SITE_PERL%%/Thread/Pool/Simple.pm
+@dirrmtry %%SITE_PERL%%/Thread/Pool
+@dirrmtry %%SITE_PERL%%/Thread
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Thread/Pool
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Thread