aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2015-05-18 19:48:47 +0000
committerXin LI <delphij@FreeBSD.org>2015-05-18 19:48:47 +0000
commitfd8e94314fa393acb0df55c9f41aec2d6389a474 (patch)
treed1fa5d93f74419911bc34d7c676eb6c24e04f1e9
parent708cc44676b2c4925d929cc13ea174c0a81fb145 (diff)
downloadports-fd8e94314fa393acb0df55c9f41aec2d6389a474.tar.gz
ports-fd8e94314fa393acb0df55c9f41aec2d6389a474.zip
Notes
-rw-r--r--devel/libinotify/Makefile7
-rw-r--r--devel/libinotify/distinfo4
-rw-r--r--devel/libinotify/files/Makefile5
3 files changed, 10 insertions, 6 deletions
diff --git a/devel/libinotify/Makefile b/devel/libinotify/Makefile
index 867053bdbe85..798c63c7ef46 100644
--- a/devel/libinotify/Makefile
+++ b/devel/libinotify/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libinotify
-PORTVERSION= 20140622
+PORTVERSION= 20150516
CATEGORIES= devel
MAINTAINER= delphij@FreeBSD.org
@@ -13,12 +13,15 @@ LICENSE= MIT
USE_GITHUB= yes
GH_ACCOUNT= dmatveev
GH_PROJECT= libinotify-kqueue
-GH_TAGNAME= d775062
+GH_TAGNAME= f4a092a
USE_LDCONFIG= yes
post-patch:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@${TOUCH} ${WRKSRC}/config.h
+ @echo "#define HAVE_PTHREAD_BARRIER 1" >> ${WRKSRC}/config.h
+ @echo "#define BUILD_LIBRARY 1" >> ${WRKSRC}/config.h
+ @echo "#include <sys/tree.h>" >> ${WRKSRC}/config.h
.include <bsd.port.mk>
diff --git a/devel/libinotify/distinfo b/devel/libinotify/distinfo
index fe8e81eeb1c3..c25c5d315778 100644
--- a/devel/libinotify/distinfo
+++ b/devel/libinotify/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dmatveev-libinotify-kqueue-20140622-d775062_GH0.tar.gz) = 283e995b815cf7adc169626ab3de1fc5dc6c3eba6de4b009ee3fb239f71ebcf4
-SIZE (dmatveev-libinotify-kqueue-20140622-d775062_GH0.tar.gz) = 33440
+SHA256 (dmatveev-libinotify-kqueue-20150516-f4a092a_GH0.tar.gz) = ad001b8229e83d379d41c0add348cff97b50c07ce60cf3f78aff86ddd18bdda3
+SIZE (dmatveev-libinotify-kqueue-20150516-f4a092a_GH0.tar.gz) = 42543
diff --git a/devel/libinotify/files/Makefile b/devel/libinotify/files/Makefile
index 269f7d255e30..78603579ff9e 100644
--- a/devel/libinotify/files/Makefile
+++ b/devel/libinotify/files/Makefile
@@ -7,11 +7,12 @@ DPADD= ${LIBPTHREAD}
LDADD= -lpthread
SRCS= utils.c
-SRCS+= barriers.c
+SRCS+= compat.c
SRCS+= conversions.c
SRCS+= dep-list.c
+SRCS+= inotify-watch.c
+SRCS+= watch-set.c
SRCS+= watch.c
-SRCS+= worker-sets.c
SRCS+= worker-thread.c
SRCS+= worker.c
SRCS+= controller.c