aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-09-03 11:43:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-09-03 11:43:57 +0000
commit0678d828e0ac1a7a46dc998c204296a73caa44f3 (patch)
treeeddb4640a388cdece546a8274740eac676ef8c27
parenta524a36b9826e867e0a8876d3eebbb02d1a4d6c8 (diff)
downloadports-0678d828e0ac1a7a46dc998c204296a73caa44f3.tar.gz
ports-0678d828e0ac1a7a46dc998c204296a73caa44f3.zip
Notes
-rw-r--r--net/liferea/Makefile28
-rw-r--r--net/liferea/distinfo6
-rw-r--r--net/liferea/pkg-plist50
3 files changed, 32 insertions, 52 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index b127e2a5911f..0c6183bfeb4c 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= liferea
-PORTVERSION= 1.2.22
+PORTVERSION= 1.4.0
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= liferea
@@ -14,7 +14,8 @@ MASTER_SITE_SUBDIR= liferea
MAINTAINER= pav@FreeBSD.org
COMMENT= Simple RSS/RDF feed reader
-USE_XLIB= yes
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+
USE_GECKO= mozilla firefox
USE_GNOME= gnomeprefix gnomehack libgtkhtml
USE_GMAKE= yes
@@ -30,8 +31,7 @@ INSTALLS_ICONS= yes
OPTIONS= LIBNOTIFY "Enable libnotify support" on \
DBUS "Enable dbus support" on \
GNUTLS "Enable SSL/HTTPS support" on \
- XPI "Firefox extension to subscribe feeds (req. dbus)" off \
- MOZILLA "Use Mozilla for rendering" off \
+ MOZILLA "Use Firefox for rendering" off \
XULRUNNER "Use Xulrunner for rendering" off
.include <bsd.port.pre.mk>
@@ -59,14 +59,6 @@ CONFIGURE_ARGS+=--disable-gecko
PLIST_SUB+= MOZ="@comment "
.endif
-.ifdef WITH_XPI
-PATCH_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
-RUN_DEPENDS+= firefox:${PORTSDIR}/www/firefox
-PLIST_SUB+= XPI=""
-.else
-PLIST_SUB+= XPI="@comment "
-.endif
-
.ifdef WITH_XULRUNNER
BUILD_DEPENDS+= xulrunner:${PORTSDIR}/www/xulrunner
RUN_DEPENDS+= xulrunner:${PORTSDIR}/www/xulrunner
@@ -89,17 +81,5 @@ post-patch:
-e '/INCLUDE/s,{print $$1},{print $$2},g' \
${WRKSRC}/configure
.endif
-.ifdef WITH_XPI
- @${MKDIR} ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}
- @${UNZIP_CMD} -q -d ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab} ${WRKSRC}/feedbag.xpi
-.endif
-
-post-install:
-.ifdef WITH_XPI
- ${MKDIR} ${PREFIX}/lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome
- ${INSTALL_DATA} ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome/feedbag.jar ${PREFIX}/lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome
- ${INSTALL_DATA} ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome.manifest ${PREFIX}/lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}
- ${INSTALL_DATA} ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/install.rdf ${PREFIX}/lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}
-.endif
.include <bsd.port.post.mk>
diff --git a/net/liferea/distinfo b/net/liferea/distinfo
index 7984b8f47d87..b74cc0e88d2a 100644
--- a/net/liferea/distinfo
+++ b/net/liferea/distinfo
@@ -1,3 +1,3 @@
-MD5 (liferea-1.2.22.tar.gz) = e76a449651e0b019101207f2f6b0c8be
-SHA256 (liferea-1.2.22.tar.gz) = 61c2357f1e35a542ab09020db92f28f3003e445d0d4a9b38b812eab3a3efbe56
-SIZE (liferea-1.2.22.tar.gz) = 1516302
+MD5 (liferea-1.4.0.tar.gz) = 501da54ff9a5ef0abbf6c84bff409f64
+SHA256 (liferea-1.4.0.tar.gz) = 25ab827128e34034e6db901c2fe190e30d93d2885b1c5252c44d8d9bb9ddec25
+SIZE (liferea-1.4.0.tar.gz) = 1573878
diff --git a/net/liferea/pkg-plist b/net/liferea/pkg-plist
index 9b4574b3834c..3951350c9fa7 100644
--- a/net/liferea/pkg-plist
+++ b/net/liferea/pkg-plist
@@ -1,8 +1,5 @@
bin/liferea
bin/liferea-add-feed
-%%XPI%%lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome/feedbag.jar
-%%XPI%%lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome.manifest
-%%XPI%%lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/install.rdf
lib/liferea/liblihtmlg.la
lib/liferea/liblihtmlg.so
%%MOZ%%lib/liferea/liblihtmlm.la
@@ -12,10 +9,12 @@ lib/liferea/liblihtmlg.so
%%NOTIFY%%lib/liferea/liblinotiflibnotify.la
%%NOTIFY%%lib/liferea/liblinotiflibnotify.so
%%NOTIFY%%lib/liferea/liblinotiflibnotify.so.0
-lib/liferea/liblinotifpopup.la
-lib/liferea/liblinotifpopup.so
-lib/liferea/liblinotifpopup.so.0
share/gnome/applications/liferea.desktop
+share/gnome/liferea/bloglines_source.glade
+share/gnome/liferea/google_source.glade
+share/gnome/liferea/liferea.glade
+share/gnome/liferea/node_source.glade
+share/gnome/liferea/opml_source.glade
share/gnome/liferea/css/adblock.css
share/gnome/liferea/css/liferea.css
share/gnome/liferea/doc/html/about_de.html
@@ -33,25 +32,28 @@ share/gnome/liferea/doc/html/headlines_de.html
share/gnome/liferea/doc/html/headlines_en.html
share/gnome/liferea/doc/html/help_feed_default.png
share/gnome/liferea/doc/html/help_feed_error.png
-share/gnome/liferea/doc/html/help_feed_prop_adv_1.2.0.png
-share/gnome/liferea/doc/html/help_feed_prop_cache_1.2.0.png
-share/gnome/liferea/doc/html/help_feed_prop_downl_1.2.0.png
-share/gnome/liferea/doc/html/help_feed_prop_general_1.2.0.png
-share/gnome/liferea/doc/html/help_feed_prop_source_1.2.0.png
+share/gnome/liferea/doc/html/help_feed_prop_adv_1.4.0.png
+share/gnome/liferea/doc/html/help_feed_prop_cache_1.4.0.png
+share/gnome/liferea/doc/html/help_feed_prop_downl_1.4.0.png
+share/gnome/liferea/doc/html/help_feed_prop_general_1.4.0.png
+share/gnome/liferea/doc/html/help_feed_prop_source_1.4.0.png
share/gnome/liferea/doc/html/help_folder.png
share/gnome/liferea/doc/html/help_item_flag.png
share/gnome/liferea/doc/html/help_item_unread.png
share/gnome/liferea/doc/html/help_opml.png
-share/gnome/liferea/doc/html/help_prefs_browser_1.2.0.png
-share/gnome/liferea/doc/html/help_prefs_enclosures_1.2.0.png
-share/gnome/liferea/doc/html/help_prefs_feeds_1.2.0.png
-share/gnome/liferea/doc/html/help_prefs_folders_1.2.0.png
-share/gnome/liferea/doc/html/help_prefs_gui_1.2.0.png
-share/gnome/liferea/doc/html/help_prefs_headlines_1.2.0.png
-share/gnome/liferea/doc/html/help_prefs_proxy_1.2.0.png
-share/gnome/liferea/doc/html/help_search_1.2.0.png
-share/gnome/liferea/doc/html/help_subscribe_1.2.0.png
-share/gnome/liferea/doc/html/help_vfolder_1.2.0.png
+share/gnome/liferea/doc/html/help_prefs_browser_1.4.0.png
+share/gnome/liferea/doc/html/help_prefs_enclosures_1.4.0.png
+share/gnome/liferea/doc/html/help_prefs_feeds_1.4.0.png
+share/gnome/liferea/doc/html/help_prefs_folders_1.4.0.png
+share/gnome/liferea/doc/html/help_prefs_gui_1.4.0.png
+share/gnome/liferea/doc/html/help_prefs_headlines_1.4.0.png
+share/gnome/liferea/doc/html/help_prefs_proxy_1.4.0.png
+share/gnome/liferea/doc/html/help_search_1.4.0.png
+share/gnome/liferea/doc/html/help_source_add_1.4.0.png
+share/gnome/liferea/doc/html/help_subscribe_1.4.0.png
+share/gnome/liferea/doc/html/help_vfolder_1.4.0.png
+share/gnome/liferea/doc/html/newsbin_de.html
+share/gnome/liferea/doc/html/newsbin_en.html
share/gnome/liferea/doc/html/preferences_de.html
share/gnome/liferea/doc/html/preferences_en.html
share/gnome/liferea/doc/html/reference.css
@@ -79,7 +81,6 @@ share/gnome/liferea/opml/feedlist_eu.opml
share/gnome/liferea/opml/feedlist_fr.opml
share/gnome/liferea/opml/feedlist_nl.opml
share/gnome/liferea/opml/feedlist_pl.opml
-share/gnome/liferea/opml/feedlist_pt_BR.opml
share/gnome/liferea/opml/feedlist_sk.opml
share/gnome/liferea/opml/feedlist_sv.opml
share/gnome/liferea/pixmaps/arrow.png
@@ -93,6 +94,8 @@ share/gnome/liferea/pixmaps/directory.png
share/gnome/liferea/pixmaps/edit.png
share/gnome/liferea/pixmaps/empty.png
share/gnome/liferea/pixmaps/empty_offline.png
+share/gnome/liferea/pixmaps/fl_bloglines.png
+share/gnome/liferea/pixmaps/fl_google.png
share/gnome/liferea/pixmaps/fl_opml.png
share/gnome/liferea/pixmaps/flag.png
share/gnome/liferea/pixmaps/grayflag.png
@@ -123,7 +126,6 @@ share/icons/hicolor/48x48/apps/liferea.png
share/locale/ar/LC_MESSAGES/liferea.mo
share/locale/be@latin/LC_MESSAGES/liferea.mo
share/locale/ca/LC_MESSAGES/liferea.mo
-share/locale/cs/LC_MESSAGES/liferea.mo
share/locale/de/LC_MESSAGES/liferea.mo
share/locale/es/LC_MESSAGES/liferea.mo
share/locale/eu/LC_MESSAGES/liferea.mo
@@ -147,5 +149,3 @@ share/locale/tr/LC_MESSAGES/liferea.mo
@dirrmtry man/pl/man1
@dirrmtry man/pl
@dirrm lib/liferea
-%%XPI%%@dirrm lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome
-%%XPI%%@dirrm lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}