aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-05-19 13:32:55 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-05-19 13:32:55 +0000
commit11054fb26504f12c5bfadc5e9ca1c8d1ff4313c8 (patch)
treeeb2f838f1654e60668a58778c549a0724ed08598
parentb960043ae63b92b151f439efeb65c0aa6c1c3727 (diff)
downloadports-11054fb26504f12c5bfadc5e9ca1c8d1ff4313c8.tar.gz
ports-11054fb26504f12c5bfadc5e9ca1c8d1ff4313c8.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-LWP-Authen-OAuth/Makefile26
-rw-r--r--www/p5-LWP-Authen-OAuth/distinfo2
-rw-r--r--www/p5-LWP-Authen-OAuth/pkg-descr5
-rw-r--r--www/p5-LWP-Authen-OAuth/pkg-plist4
5 files changed, 38 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0edc9b558ef9..6ba7d620e5ab 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1099,6 +1099,7 @@
SUBDIR += p5-Jemplate
SUBDIR += p5-Jifty
SUBDIR += p5-Kwiki
+ SUBDIR += p5-LWP-Authen-OAuth
SUBDIR += p5-LWP-Authen-Wsse
SUBDIR += p5-LWP-ConnCache-MaxKeepAliveRequests
SUBDIR += p5-LWP-MediaTypes
diff --git a/www/p5-LWP-Authen-OAuth/Makefile b/www/p5-LWP-Authen-OAuth/Makefile
new file mode 100644
index 000000000000..dfb2f6847192
--- /dev/null
+++ b/www/p5-LWP-Authen-OAuth/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: LWP::Authen::OAuth
+# Date created: 18 May 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-Authen-OAuth
+PORTVERSION= 1.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to generate signed OAuth requests
+
+RUN_DEPENDS= \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Authen::OAuth.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-LWP-Authen-OAuth/distinfo b/www/p5-LWP-Authen-OAuth/distinfo
new file mode 100644
index 000000000000..bc82bbd0dc49
--- /dev/null
+++ b/www/p5-LWP-Authen-OAuth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (LWP-Authen-OAuth-1.01.tar.gz) = ee020a5355b7be9e2191982e1c988c554e3dc3c1dd9e2f028d9b52dbd3e0ee9b
+SIZE (LWP-Authen-OAuth-1.01.tar.gz) = 4720
diff --git a/www/p5-LWP-Authen-OAuth/pkg-descr b/www/p5-LWP-Authen-OAuth/pkg-descr
new file mode 100644
index 000000000000..5d777cb9ad42
--- /dev/null
+++ b/www/p5-LWP-Authen-OAuth/pkg-descr
@@ -0,0 +1,5 @@
+This module provides a sub-class of LWP::UserAgent that generates
+OAuth 1.0 signed requests. You should familiarise yourself with OAuth
+at http://oauth.net/.
+
+WWW: http://search.cpan.org/dist/LWP-Authen-OAuth/
diff --git a/www/p5-LWP-Authen-OAuth/pkg-plist b/www/p5-LWP-Authen-OAuth/pkg-plist
new file mode 100644
index 000000000000..173216a32233
--- /dev/null
+++ b/www/p5-LWP-Authen-OAuth/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Authen/OAuth/.packlist
+%%SITE_PERL%%/LWP/Authen/OAuth.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Authen/OAuth
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Authen