aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-20 13:49:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-20 13:49:01 +0000
commit1869154cc972c10727f44b33f1c50b555b226e39 (patch)
treefebb56a1d2661026e4c77a9f09333b2b7f9b3738
parent210d118f6e0e101e1b16011245f298a1d5f3b650 (diff)
downloadports-1869154cc972c10727f44b33f1c50b555b226e39.tar.gz
ports-1869154cc972c10727f44b33f1c50b555b226e39.zip
Notes
-rw-r--r--devel/ruby-gems/Makefile.common37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/ruby-gems/Makefile.common b/devel/ruby-gems/Makefile.common
new file mode 100644
index 000000000000..927d1583c65c
--- /dev/null
+++ b/devel/ruby-gems/Makefile.common
@@ -0,0 +1,37 @@
+# $FreeBSD$
+# Ruby gem module common settings
+
+
+BUILD_DEPENDS+= ${RUBYGEMBIN}:${PORTSDIR}/devel/ruby-gems
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+PKGNAMEPREFIX= rubygem-
+EXTRACT_SUFX= .gem
+NO_EXTRACT= YES
+DIST_SUBDIR= rubygem
+
+USE_REINPLACE= yes
+
+NO_BUILD= yes
+
+REV= 1.8
+GEMS_BASE_DIR= lib/ruby/gems/${REV}
+GEMS_DIR= ${GEMS_BASE_DIR}/gems
+DOC_DIR= ${GEMS_BASE_DIR}/doc
+CACHE_DIR= ${GEMS_BASE_DIR}/cache
+SPEC_DIR= ${GEMS_BASE_DIR}/specifications
+
+PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
+ REV="${REV}" \
+ GEMS_BASE_DIR="lib/ruby/gems/${REV}" \
+ GEMS_DIR="${GEMS_BASE_DIR}/gems" \
+ DOC_DIR="${GEMS_BASE_DIR}/doc" \
+ CACHE_DIR="${GEMS_BASE_DIR}/cache" \
+ SPEC_DIR="${GEMS_BASE_DIR}/specifications" \
+ PORT="${PORTNAME}-${PORTVERSION}" \
+ EXTRACT_SUFX="${EXTRACT_SUFX}"
+
+RUBYGEMBIN= ${LOCALBASE}/bin/gem
+
+do-install:
+ ${RUBYGEMBIN} install --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}