aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2010-12-09 19:29:42 +0000
committerBrooks Davis <brooks@FreeBSD.org>2010-12-09 19:29:42 +0000
commit1e7f2d541476cd300c7e166e7dc3713c14e4137e (patch)
tree336a2d46ea0b90e4c7ac0966a009796574c63baf
parenta7346f2159e3a9e88f7492fe46d48f88f4876658 (diff)
downloadports-1e7f2d541476cd300c7e166e7dc3713c14e4137e.tar.gz
ports-1e7f2d541476cd300c7e166e7dc3713c14e4137e.zip
Notes
-rw-r--r--devel/llvm-devel/Makefile32
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo5
-rw-r--r--devel/llvm-devel/pkg-plist83
-rw-r--r--lang/clang-devel/distinfo10
-rw-r--r--lang/clang-devel/files/patch-Makefile2
-rw-r--r--lang/clang-devel/pkg-plist16
7 files changed, 82 insertions, 68 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 48c352455d94..dfd6ded5c99c 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -41,19 +41,26 @@ MAKE_ARGS+= REQUIRES_RTTI=1
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --disable-assertions \
- --enable-optimized
+CONFIGURE_ARGS+= --enable-optimized
.endif
CONFIGURE_ARGS+= --enable-bindings=none
OPTIONS= ASSERTS "Enable assertions (thread unsafe)" off
-MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvmc.1 llvm-ar.1 \
+.if defined(NOPORTDOCS)
+DOCSRCDIR=
+.else
+DOCSRCDIR= docs
+.endif
+
+.if !defined(NOPORTDOCS)
+MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 \
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-diff.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
- llvm-prof.1 llvm-ranlib.1 llvmgcc.1 \
+ llvm-prof.1 llvm-ranlib.1 llvmc.1 llvmgcc.1 \
llvmgxx.1 opt.1 tblgen.1
+.endif
.include <bsd.port.pre.mk>
@@ -64,10 +71,8 @@ SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | ${GREP} Revision | cut -d
.include "Makefile.svn_rev"
.endif
-.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
-BROKEN= does not compile
-.elif ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "sparc64"
+BROKEN= does not compile on sparc64
.endif
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
@@ -100,10 +105,12 @@ do-fetch:
.endif
post-patch:
- ${REINPLACE_CMD} -e 's,\(PROJ_docsdir.*:=\).*$$,\1${DOCSDIR},g' \
- ${WRKSRC}/Makefile.config.in
- ${REINPLACE_CMD} -e 's,\(PROJ_mandir.*:=\).*$$,\1${MANPREFIX}/man,g' \
- ${WRKSRC}/Makefile.config.in
+ ${REINPLACE_CMD} -e 's|\(PROJ_docsdir.*:=\).*$$|\1${DOCSDIR}|g' \
+ ${WRKSRC}/Makefile.config.in
+ ${REINPLACE_CMD} -e 's|\(PROJ_mandir.*:=\).*$$|\1${MANPREFIX}/man|g' \
+ ${WRKSRC}/Makefile.config.in
+ ${REINPLACE_CMD} -e 's|%%DOCSRCDIR%%|${DOCSRCDIR}|' \
+ ${WRKSRC}/Makefile
TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check-local-lit)'
regression-test: ${BUILD_COOKIE}
@@ -118,6 +125,7 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/llc \
bin/lli \
bin/llvm* \
+ bin/macho-dumpx \
bin/opt \
bin/tblgen \
lib/libBugpointPasses.so \
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index 506b7c3d05d1..de67b4ef6235 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 116582
+SVN_REV= 121368
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 5b350050b2d9..9ada8c0095e9 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,2 @@
-MD5 (llvm-2.9.r116582.tar.bz2) = 3ad4886e027b77cf5ea438e54d99aa2e
-SHA256 (llvm-2.9.r116582.tar.bz2) = ad5e66fcb06d5d7ce0ca77bf7a72a77e6d6bde44cf26fa5a4573decec3246c12
-SIZE (llvm-2.9.r116582.tar.bz2) = 7023799
+SHA256 (llvm-2.9.r121368.tar.bz2) = 23fe92c65926cd55c6cb51fc5f2376a325bedf726d4fc1fe50e79a6ec12e74f9
+SIZE (llvm-2.9.r121368.tar.bz2) = 7268189
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 9382ca09f4c7..396059dd4440 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -16,6 +16,7 @@ bin/llvm-prof
bin/llvm-ranlib
bin/llvm-stub
bin/llvmc
+bin/macho-dumpx
bin/opt
bin/tblgen
include/llvm-c/Analysis.h
@@ -47,7 +48,9 @@ include/llvm/ADT/ImmutableIntervalMap.h
include/llvm/ADT/ImmutableList.h
include/llvm/ADT/ImmutableMap.h
include/llvm/ADT/ImmutableSet.h
+include/llvm/ADT/InMemoryStruct.h
include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/IntervalMap.h
include/llvm/ADT/IntrusiveRefCntPtr.h
include/llvm/ADT/NullablePtr.h
include/llvm/ADT/Optional.h
@@ -90,6 +93,7 @@ include/llvm/Analysis/CaptureTracking.h
include/llvm/Analysis/CodeMetrics.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
+include/llvm/Analysis/DIBuilder.h
include/llvm/Analysis/DOTGraphTraitsPass.h
include/llvm/Analysis/DebugInfo.h
include/llvm/Analysis/DomPrinter.h
@@ -121,6 +125,7 @@ include/llvm/Analysis/ProfileInfoLoader.h
include/llvm/Analysis/ProfileInfoTypes.h
include/llvm/Analysis/RegionInfo.h
include/llvm/Analysis/RegionIterator.h
+include/llvm/Analysis/RegionPass.h
include/llvm/Analysis/RegionPrinter.h
include/llvm/Analysis/ScalarEvolution.h
include/llvm/Analysis/ScalarEvolutionExpander.h
@@ -199,7 +204,6 @@ include/llvm/CodeGen/PBQP/Heuristics/Briggs.h
include/llvm/CodeGen/PBQP/Math.h
include/llvm/CodeGen/PBQP/Solution.h
include/llvm/CodeGen/Passes.h
-include/llvm/CodeGen/PostRAHazardRecognizer.h
include/llvm/CodeGen/ProcessImplicitDefs.h
include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocPBQP.h
@@ -210,6 +214,7 @@ include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/ScheduleHazardRecognizer.h
include/llvm/CodeGen/SchedulerRegistry.h
+include/llvm/CodeGen/ScoreboardHazardRecognizer.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
@@ -243,6 +248,7 @@ include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
include/llvm/ExecutionEngine/JITEventListener.h
include/llvm/ExecutionEngine/JITMemoryManager.h
+include/llvm/ExecutionEngine/MCJIT.h
include/llvm/Function.h
include/llvm/GVMaterializer.h
include/llvm/GlobalAlias.h
@@ -269,7 +275,6 @@ include/llvm/LinkAllPasses.h
include/llvm/LinkAllVMCore.h
include/llvm/Linker.h
include/llvm/MC/EDInstInfo.h
-include/llvm/MC/ELFObjectWriter.h
include/llvm/MC/MCAsmInfo.h
include/llvm/MC/MCAsmInfoCOFF.h
include/llvm/MC/MCAsmInfoDarwin.h
@@ -287,6 +292,7 @@ include/llvm/MC/MCInst.h
include/llvm/MC/MCInstPrinter.h
include/llvm/MC/MCLabel.h
include/llvm/MC/MCMachOSymbolFlags.h
+include/llvm/MC/MCObjectFormat.h
include/llvm/MC/MCObjectStreamer.h
include/llvm/MC/MCObjectWriter.h
include/llvm/MC/MCParser/AsmCond.h
@@ -302,10 +308,12 @@ include/llvm/MC/MCSectionMachO.h
include/llvm/MC/MCStreamer.h
include/llvm/MC/MCSymbol.h
include/llvm/MC/MCValue.h
-include/llvm/MC/MachObjectWriter.h
include/llvm/MC/SectionKind.h
include/llvm/Metadata.h
include/llvm/Module.h
+include/llvm/Object/MachOFormat.h
+include/llvm/Object/MachOObject.h
+include/llvm/Object/ObjectFile.h
include/llvm/OperandTraits.h
include/llvm/Operator.h
include/llvm/Pass.h
@@ -314,8 +322,10 @@ include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassRegistry.h
include/llvm/PassSupport.h
+include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
+include/llvm/Support/Atomic.h
include/llvm/Support/CFG.h
include/llvm/Support/COFF.h
include/llvm/Support/CallSite.h
@@ -327,82 +337,82 @@ include/llvm/Support/ConstantRange.h
include/llvm/Support/CrashRecoveryContext.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataFlow.h
+include/llvm/Support/DataTypes.h
+include/llvm/Support/DataTypes.h.cmake
include/llvm/Support/Debug.h
include/llvm/Support/DebugLoc.h
+include/llvm/Support/Disassembler.h
include/llvm/Support/Dwarf.h
-include/llvm/Support/DynamicLinker.h
+include/llvm/Support/DynamicLibrary.h
include/llvm/Support/ELF.h
+include/llvm/Support/Endian.h
+include/llvm/Support/Errno.h
include/llvm/Support/ErrorHandling.h
+include/llvm/Support/FEnv.h
+include/llvm/Support/FileSystem.h
include/llvm/Support/FileUtilities.h
include/llvm/Support/Format.h
include/llvm/Support/FormattedStream.h
include/llvm/Support/GetElementPtrTypeIterator.h
include/llvm/Support/GraphWriter.h
+include/llvm/Support/Host.h
include/llvm/Support/IRBuilder.h
include/llvm/Support/IRReader.h
+include/llvm/Support/IncludeFile.h
include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
+include/llvm/Support/LICENSE.TXT
include/llvm/Support/LeakDetector.h
include/llvm/Support/MachO.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/MathExtras.h
+include/llvm/Support/Memory.h
include/llvm/Support/MemoryBuffer.h
include/llvm/Support/MemoryObject.h
+include/llvm/Support/Mutex.h
include/llvm/Support/MutexGuard.h
include/llvm/Support/NoFolder.h
include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
+include/llvm/Support/Path.h
+include/llvm/Support/PathV2.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
include/llvm/Support/PointerLikeTypeTraits.h
include/llvm/Support/PredIteratorCache.h
include/llvm/Support/PrettyStackTrace.h
+include/llvm/Support/Process.h
+include/llvm/Support/Program.h
+include/llvm/Support/RWMutex.h
include/llvm/Support/Recycler.h
include/llvm/Support/RecyclingAllocator.h
include/llvm/Support/Regex.h
include/llvm/Support/Registry.h
include/llvm/Support/RegistryParser.h
include/llvm/Support/SMLoc.h
+include/llvm/Support/Signals.h
+include/llvm/Support/Solaris.h
include/llvm/Support/SourceMgr.h
include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/StandardPasses.h
include/llvm/Support/StringPool.h
+include/llvm/Support/SwapByteOrder.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/TargetFolder.h
+include/llvm/Support/ThreadLocal.h
+include/llvm/Support/Threading.h
+include/llvm/Support/TimeValue.h
include/llvm/Support/Timer.h
include/llvm/Support/ToolOutputFile.h
include/llvm/Support/TypeBuilder.h
+include/llvm/Support/Valgrind.h
include/llvm/Support/ValueHandle.h
include/llvm/Support/circular_raw_ostream.h
include/llvm/Support/raw_os_ostream.h
include/llvm/Support/raw_ostream.h
+include/llvm/Support/system_error.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
-include/llvm/System/AIXDataTypesFix.h
-include/llvm/System/Alarm.h
-include/llvm/System/Atomic.h
-include/llvm/System/DataTypes.h
-include/llvm/System/DataTypes.h.cmake
-include/llvm/System/Disassembler.h
-include/llvm/System/DynamicLibrary.h
-include/llvm/System/Errno.h
-include/llvm/System/FEnv.h
-include/llvm/System/Host.h
-include/llvm/System/IncludeFile.h
-include/llvm/System/LICENSE.TXT
-include/llvm/System/Memory.h
-include/llvm/System/Mutex.h
-include/llvm/System/Path.h
-include/llvm/System/Process.h
-include/llvm/System/Program.h
-include/llvm/System/RWMutex.h
-include/llvm/System/Signals.h
-include/llvm/System/Solaris.h
-include/llvm/System/SwapByteOrder.h
-include/llvm/System/ThreadLocal.h
-include/llvm/System/Threading.h
-include/llvm/System/TimeValue.h
-include/llvm/System/Valgrind.h
include/llvm/Target/Mangler.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/Target.td
@@ -464,7 +474,6 @@ lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
lib/libLLVMARMDisassembler.a
lib/libLLVMARMInfo.a
-lib/libLLVMAlphaAsmPrinter.a
lib/libLLVMAlphaCodeGen.a
lib/libLLVMAlphaInfo.a
lib/libLLVMAnalysis.a
@@ -473,12 +482,10 @@ lib/libLLVMAsmParser.a
lib/libLLVMAsmPrinter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
-lib/libLLVMBlackfinAsmPrinter.a
lib/libLLVMBlackfinCodeGen.a
lib/libLLVMBlackfinInfo.a
lib/libLLVMCBackend.a
lib/libLLVMCBackendInfo.a
-lib/libLLVMCellSPUAsmPrinter.a
lib/libLLVMCellSPUCodeGen.a
lib/libLLVMCellSPUInfo.a
lib/libLLVMCodeGen.a
@@ -492,19 +499,21 @@ lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
lib/libLLVMJIT.a
lib/libLLVMLinker.a
+lib/libLLVMMBlazeAsmParser.a
lib/libLLVMMBlazeAsmPrinter.a
lib/libLLVMMBlazeCodeGen.a
+lib/libLLVMMBlazeDisassembler.a
lib/libLLVMMBlazeInfo.a
lib/libLLVMMC.a
lib/libLLVMMCDisassembler.a
+lib/libLLVMMCJIT.a
lib/libLLVMMCParser.a
lib/libLLVMMSP430AsmPrinter.a
lib/libLLVMMSP430CodeGen.a
lib/libLLVMMSP430Info.a
-lib/libLLVMMipsAsmPrinter.a
lib/libLLVMMipsCodeGen.a
lib/libLLVMMipsInfo.a
-lib/libLLVMPTXAsmPrinter.a
+lib/libLLVMObject.a
lib/libLLVMPTXCodeGen.a
lib/libLLVMPTXInfo.a
lib/libLLVMPowerPCAsmPrinter.a
@@ -512,12 +521,9 @@ lib/libLLVMPowerPCCodeGen.a
lib/libLLVMPowerPCInfo.a
lib/libLLVMScalarOpts.a
lib/libLLVMSelectionDAG.a
-lib/libLLVMSparcAsmPrinter.a
lib/libLLVMSparcCodeGen.a
lib/libLLVMSparcInfo.a
lib/libLLVMSupport.a
-lib/libLLVMSystem.a
-lib/libLLVMSystemZAsmPrinter.a
lib/libLLVMSystemZCodeGen.a
lib/libLLVMSystemZInfo.a
lib/libLLVMTarget.a
@@ -527,7 +533,6 @@ lib/libLLVMX86AsmPrinter.a
lib/libLLVMX86CodeGen.a
lib/libLLVMX86Disassembler.a
lib/libLLVMX86Info.a
-lib/libLLVMXCoreAsmPrinter.a
lib/libLLVMXCoreCodeGen.a
lib/libLLVMXCoreInfo.a
lib/libLLVMipa.a
@@ -651,8 +656,8 @@ lib/libprofile_rt.so
@dirrm include/llvm/Transforms/IPO
@dirrm include/llvm/Transforms
@dirrm include/llvm/Target
-@dirrm include/llvm/System
@dirrm include/llvm/Support
+@dirrm include/llvm/Object
@dirrm include/llvm/MC/MCParser
@dirrm include/llvm/MC
@dirrm include/llvm/ExecutionEngine
diff --git a/lang/clang-devel/distinfo b/lang/clang-devel/distinfo
index bcf24873dc50..a386f3559520 100644
--- a/lang/clang-devel/distinfo
+++ b/lang/clang-devel/distinfo
@@ -1,6 +1,4 @@
-MD5 (clang-2.9.r116582.tar.bz2) = f4dc890fc18a86ff6043bcd5233ff66c
-SHA256 (clang-2.9.r116582.tar.bz2) = 94c76107ff56d3797c44c82c858d32c6c237e06b5ba70f164f5fbf29b419c6d1
-SIZE (clang-2.9.r116582.tar.bz2) = 4767581
-MD5 (llvm-2.9.r116582.tar.bz2) = 3ad4886e027b77cf5ea438e54d99aa2e
-SHA256 (llvm-2.9.r116582.tar.bz2) = ad5e66fcb06d5d7ce0ca77bf7a72a77e6d6bde44cf26fa5a4573decec3246c12
-SIZE (llvm-2.9.r116582.tar.bz2) = 7023799
+SHA256 (clang-2.9.r121368.tar.bz2) = 1593384e1eb915a1ea06c63a9c44c90056ccf8ca517024acc3953dbe597bbfe3
+SIZE (clang-2.9.r121368.tar.bz2) = 4912313
+SHA256 (llvm-2.9.r121368.tar.bz2) = 23fe92c65926cd55c6cb51fc5f2376a325bedf726d4fc1fe50e79a6ec12e74f9
+SIZE (llvm-2.9.r121368.tar.bz2) = 7268189
diff --git a/lang/clang-devel/files/patch-Makefile b/lang/clang-devel/files/patch-Makefile
index 2c887b01275d..d056dceae2e2 100644
--- a/lang/clang-devel/files/patch-Makefile
+++ b/lang/clang-devel/files/patch-Makefile
@@ -6,7 +6,7 @@ $FreeBSD$
@@ -31,7 +31,7 @@
OPTIONAL_DIRS :=
else
- DIRS := lib/System lib/Support utils lib/VMCore lib tools/llvm-shlib \
+ DIRS := lib/Support utils lib/VMCore lib tools/llvm-shlib \
- tools/llvm-config tools runtime docs unittests
+ tools/llvm-config tools runtime %%DOCSRCDIR%% unittests
OPTIONAL_DIRS := projects bindings
diff --git a/lang/clang-devel/pkg-plist b/lang/clang-devel/pkg-plist
index 94c977a2b1e3..7257dc305413 100644
--- a/lang/clang-devel/pkg-plist
+++ b/lang/clang-devel/pkg-plist
@@ -12,6 +12,7 @@ include/clang/AST/ASTConsumer.h
include/clang/AST/ASTContext.h
include/clang/AST/ASTDiagnostic.h
include/clang/AST/ASTImporter.h
+include/clang/AST/ASTMutationListener.h
include/clang/AST/ASTVector.h
include/clang/AST/Attr.h
include/clang/AST/AttrImpl.inc
@@ -37,7 +38,6 @@ include/clang/AST/Expr.h
include/clang/AST/ExprCXX.h
include/clang/AST/ExprObjC.h
include/clang/AST/ExternalASTSource.h
-include/clang/AST/FullExpr.h
include/clang/AST/NestedNameSpecifier.h
include/clang/AST/OperationKinds.h
include/clang/AST/ParentMap.h
@@ -60,7 +60,6 @@ include/clang/AST/TemplateBase.h
include/clang/AST/TemplateName.h
include/clang/AST/Type.h
include/clang/AST/TypeLoc.h
-include/clang/AST/TypeLocBuilder.h
include/clang/AST/TypeLocNodes.def
include/clang/AST/TypeLocVisitor.h
include/clang/AST/TypeNodes.def
@@ -101,10 +100,13 @@ include/clang/Basic/DiagnosticCommonKinds.inc
include/clang/Basic/DiagnosticDriverKinds.inc
include/clang/Basic/DiagnosticFrontendKinds.inc
include/clang/Basic/DiagnosticGroups.inc
+include/clang/Basic/DiagnosticIDs.h
include/clang/Basic/DiagnosticLexKinds.inc
include/clang/Basic/DiagnosticParseKinds.inc
include/clang/Basic/DiagnosticSemaKinds.inc
include/clang/Basic/FileManager.h
+include/clang/Basic/FileSystemOptions.h
+include/clang/Basic/FileSystemStatCache.h
include/clang/Basic/IdentifierTable.h
include/clang/Basic/LangOptions.h
include/clang/Basic/Linkage.h
@@ -139,6 +141,7 @@ include/clang/Basic/TokenKinds.h
include/clang/Basic/TypeTraits.h
include/clang/Basic/Version.h
include/clang/Basic/Version.inc
+include/clang/Basic/Visibility.h
include/clang/Basic/arm_neon.inc
include/clang/Checker/AnalysisConsumer.h
include/clang/Checker/BugReporter/BugReporter.h
@@ -159,24 +162,21 @@ include/clang/Checker/PathSensitive/CheckerVisitor.h
include/clang/Checker/PathSensitive/ConstraintManager.h
include/clang/Checker/PathSensitive/Environment.h
include/clang/Checker/PathSensitive/ExplodedGraph.h
-include/clang/Checker/PathSensitive/GRAuditor.h
include/clang/Checker/PathSensitive/GRBlockCounter.h
include/clang/Checker/PathSensitive/GRCoreEngine.h
include/clang/Checker/PathSensitive/GRExprEngine.h
include/clang/Checker/PathSensitive/GRExprEngineBuilders.h
-include/clang/Checker/PathSensitive/GRSimpleAPICheck.h
include/clang/Checker/PathSensitive/GRState.h
include/clang/Checker/PathSensitive/GRStateTrait.h
include/clang/Checker/PathSensitive/GRSubEngine.h
include/clang/Checker/PathSensitive/GRTransferFuncs.h
include/clang/Checker/PathSensitive/GRWorkList.h
include/clang/Checker/PathSensitive/MemRegion.h
+include/clang/Checker/PathSensitive/SValBuilder.h
include/clang/Checker/PathSensitive/SVals.h
-include/clang/Checker/PathSensitive/SValuator.h
include/clang/Checker/PathSensitive/Store.h
include/clang/Checker/PathSensitive/SummaryManager.h
include/clang/Checker/PathSensitive/SymbolManager.h
-include/clang/Checker/PathSensitive/ValueManager.h
include/clang/CodeGen/BackendUtil.h
include/clang/CodeGen/CodeGenAction.h
include/clang/CodeGen/ModuleBuilder.h
@@ -251,6 +251,7 @@ include/clang/Index/Program.h
include/clang/Index/STLExtras.h
include/clang/Index/SelectorMap.h
include/clang/Index/TranslationUnit.h
+include/clang/Lex/AttrSpellings.inc
include/clang/Lex/CodeCompletionHandler.h
include/clang/Lex/DirectoryLookup.h
include/clang/Lex/ExternalPreprocessorSource.h
@@ -268,6 +269,7 @@ include/clang/Lex/Pragma.h
include/clang/Lex/PreprocessingRecord.h
include/clang/Lex/Preprocessor.h
include/clang/Lex/PreprocessorLexer.h
+include/clang/Lex/Release+Asserts/AttrSpellings.inc.tmp
include/clang/Lex/ScratchBuffer.h
include/clang/Lex/Token.h
include/clang/Lex/TokenConcatenation.h
@@ -311,6 +313,7 @@ include/clang/Sema/TemplateDeduction.h
include/clang/Serialization/ASTBitCodes.h
include/clang/Serialization/ASTDeserializationListener.h
include/clang/Serialization/ASTReader.h
+include/clang/Serialization/ASTSerializationListener.h
include/clang/Serialization/ASTWriter.h
include/clang/Serialization/AttrPCHRead.inc
include/clang/Serialization/AttrPCHWrite.inc
@@ -373,6 +376,7 @@ lib/libclangSerialization.a
@dirrm include/clang/Sema
@dirrm include/clang/Rewrite
@dirrm include/clang/Parse
+@dirrm include/clang/Lex/Release+Asserts
@dirrm include/clang/Lex
@dirrm include/clang/Index
@dirrm include/clang/FrontendTool