aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-09-23 00:33:58 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-09-23 00:33:58 +0000
commit1ec9e868fa3d9a8d4314ff3f981aaf0e8c150885 (patch)
tree236dd6ceacf5213818dbf98fd95fe100ffdcd7c0
parent74894ed54d114f8e046e460c8dca6d2c40eb86ee (diff)
downloadports-1ec9e868fa3d9a8d4314ff3f981aaf0e8c150885.tar.gz
ports-1ec9e868fa3d9a8d4314ff3f981aaf0e8c150885.zip
Notes
-rw-r--r--Mk/bsd.port.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 729fff0d800f..bc4d4e575b63 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -133,7 +133,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# compression.
# USE_ZIP - Says that the port distfile uses zip, not tar w/[bg]zip
# for compression.
-# USE_NEWGCC - Says that the port requirest the latest gcc, either in
+# USE_GCC295 - Says that the port requirest this version of gcc, either in
+# the system or installed from a port.
+# USE_GCC30 - Says that the port requirest this version of gcc, either in
# the system or installed from a port.
# USE_GMAKE - Says that the port uses gmake.
# GMAKE - Set to path of GNU make if not in $PATH (default: gmake).
@@ -801,12 +803,18 @@ LIBTOOLFILES?= configure
.endif
LIBTOOLFLAGS?= --disable-ltlibs
.endif
-.if defined(USE_NEWGCC) && ${OSVERSION} < 400012
+.if defined(USE_GCC295) && ${OSVERSION} < 400012
CC= gcc295
CXX= g++295
BUILD_DEPENDS+= gcc295:${PORTSDIR}/lang/gcc295
MAKE_ENV+= CC=${CC} CXX=${CXX}
.endif
+.if defined(USE_GCC30) && ${OSVERSION} < 500999
+CC= gcc30
+CXX= g++30
+BUILD_DEPENDS+= gcc30:${PORTSDIR}/lang/gcc30
+MAKE_ENV+= CC=${CC} CXX=${CXX}
+.endif
.if defined(USE_LINUX)
RUN_DEPENDS+= ${LINUXBASE}/etc/redhat-release:${PORTSDIR}/emulators/linux_base