aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-07-26 18:45:08 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-07-26 18:45:08 +0000
commit270e57af77dc27fe1d12f3d18fd9a8701d507f7c (patch)
tree249a3d168b8ddc07aaf3bc79837cae45ed995af0
parentc250bf61518c57993ebe3b273e58bbe7d9e7bf7a (diff)
Notes
-rw-r--r--mail/popa3d-before-sendmail/Makefile5
-rw-r--r--mail/popa3d/Makefile9
-rw-r--r--mail/popa3d/files/setproctitle.patch10
3 files changed, 20 insertions, 4 deletions
diff --git a/mail/popa3d-before-sendmail/Makefile b/mail/popa3d-before-sendmail/Makefile
index 36160a143b34..ac88659fdfea 100644
--- a/mail/popa3d-before-sendmail/Makefile
+++ b/mail/popa3d-before-sendmail/Makefile
@@ -12,8 +12,9 @@ MAINTAINER= dinoex@FreeBSD.org
WITH_SMTP_AFTER_POP3= yes
MASTERDIR?= ${.CURDIR}/../popa3d
-OPTIONS?= STANDALONE_POP3 "Unattended server mode" off \
- SMTP_AFTER_POP3 "Enable SMTP-after-POP mode" on
+OPTIONS?= SMTP_AFTER_POP3 "Enable SMTP-after-POP mode" on \
+ STANDALONE_POP3 "Enable standalone server mode" off \
+ SETPROCTITLE "Enable setproctitle mode" off
.if exists(${.CURDIR}/Makefile.local)
.include "${.CURDIR}/Makefile.local"
diff --git a/mail/popa3d/Makefile b/mail/popa3d/Makefile
index 9bed51d2d32c..13adad2212dd 100644
--- a/mail/popa3d/Makefile
+++ b/mail/popa3d/Makefile
@@ -22,8 +22,9 @@ PLIST= ${WRKDIR}/.PLIST.more
CFLAGS+= -DPREFIX=${PREFIX}
UNIQUENAME= ${.CURDIR:T}
-OPTIONS?= STANDALONE_POP3 "Unattended server mode" off \
- SMTP_AFTER_POP3 "Enable SMTP-after-POP mode" off
+OPTIONS?= SMTP_AFTER_POP3 "Enable SMTP-after-POP mode" off \
+ STANDALONE_POP3 "Enable standalone server mode" off \
+ SETPROCTITLE "Enable setproctitle mode" off
.include <bsd.port.pre.mk>
@@ -55,6 +56,10 @@ PLIST_SUB+= SMTP_AFTER_POP3="@comment "
CONFLICTS?= popa3d-standalone-0.* popa3d-before-sendmail-0.*
.endif
+.if defined(WITH_SETPROCTITLE)
+EXTRA_PATCHES+= ${FILESDIR}/setproctitle.patch
+.endif
+
.if defined(WITH_STANDALONE_POP3)
post-extract:
@${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/popa3d.sh \
diff --git a/mail/popa3d/files/setproctitle.patch b/mail/popa3d/files/setproctitle.patch
new file mode 100644
index 000000000000..99650b291627
--- /dev/null
+++ b/mail/popa3d/files/setproctitle.patch
@@ -0,0 +1,10 @@
+--- pop_root.c.orig Sun Mar 5 13:45:36 2006
++++ pop_root.c Wed Jul 26 20:26:08 2006
+@@ -248,6 +248,7 @@
+ if (result == AUTH_OK) {
+ if (close(channel[0])) return log_error("close");
+ log_pop_auth(result, user);
++ setproctitle(user);
+ return do_pop_trans(spool, mailbox);
+ }
+