aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2009-03-07 18:51:40 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2009-03-07 18:51:40 +0000
commit313c4c76c4f34ff85cc779dea6b66680e881c0ad (patch)
treec759527b4c790a0ff8c4eb85090ce757579a4ee6
parent2047051b206255a20bf3dfdf004a30ae00595ce5 (diff)
downloadports-313c4c76c4f34ff85cc779dea6b66680e881c0ad.tar.gz
ports-313c4c76c4f34ff85cc779dea6b66680e881c0ad.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/asterisk16-addons/Makefile33
-rw-r--r--net/asterisk16-addons/distinfo6
-rw-r--r--net/asterisk16-addons/files/codecnego.diff215
-rw-r--r--net/asterisk16-addons/files/patch-Makefile21
-rw-r--r--net/asterisk16-addons/files/patch-Makefile.rules12
6 files changed, 50 insertions, 238 deletions
diff --git a/net/Makefile b/net/Makefile
index 34412ef94985..fae3ac705e74 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -36,6 +36,7 @@
SUBDIR += asterisk12-addons
SUBDIR += asterisk12-app-ldap
SUBDIR += asterisk16
+ SUBDIR += asterisk16-addons
SUBDIR += astfax
SUBDIR += astmanproxy
SUBDIR += atmsupport
diff --git a/net/asterisk16-addons/Makefile b/net/asterisk16-addons/Makefile
index 08c49e8587d0..4b169063bfaa 100644
--- a/net/asterisk16-addons/Makefile
+++ b/net/asterisk16-addons/Makefile
@@ -5,17 +5,20 @@
# $FreeBSD$
#
-PORTNAME= asterisk-addons
-PORTVERSION= 1.4.6
-PORTREVISION= 4
+PORTNAME= asterisk16-addons
+PORTVERSION= 1.6.0.1
CATEGORIES= net
-MASTER_SITES= http://ftp.digium.com/pub/asterisk/releases/
+MASTER_SITES= http://downloads.digium.com/pub/asterisk/ \
+ http://downloads.digium.com/pub/asterisk/old-releases/ \
+ http://ftp.digium.com/pub/asterisk/ \
+ http://ftp.digium.com/pub/asterisk/old-releases/
+DISTNAME= asterisk-addons-${DISTVERSION}
MAINTAINER= pneumann@gmail.com
COMMENT= GPL modules for the Asterisk Open Source PBX
-BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
-RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk16
+RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk16
OPTIONS= SAMPLE_CONFIG "Install sample configuration files" off
@@ -24,6 +27,14 @@ USE_AUTOTOOLS= libtool:15
USE_MYSQL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ OSVERSION=${OSVERSION} \
+ NOISY_BUILD=YES \
+ DOCSDIR=${DOCSDIR} \
+ ASTCFLAGS="${CFLAGS}"
+
+CONFLICTS= asterisk*-1.2* asterisk*-1.4*
.include <bsd.port.pre.mk>
@@ -33,11 +44,11 @@ PLIST_SUB+= SAMPLE_CONFIG=""
PLIST_SUB+= SAMPLE_CONFIG="@comment "
.endif
-pre-configure:
- if ${GREP} -sq fixup_codecs ${LOCALBASE}/include/asterisk/channel.h; \
- then \
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/codecnego.diff; \
- fi
+#pre-configure:
+# if ${GREP} -sq fixup_codecs ${LOCALBASE}/include/asterisk/channel.h; \
+# then \
+# ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/codecnego.diff; \
+# fi
post-install:
.if defined(WITH_SAMPLE_CONFIG)
diff --git a/net/asterisk16-addons/distinfo b/net/asterisk16-addons/distinfo
index 89c6fc1fcbae..ba1feef59b69 100644
--- a/net/asterisk16-addons/distinfo
+++ b/net/asterisk16-addons/distinfo
@@ -1,3 +1,3 @@
-MD5 (asterisk-addons-1.4.6.tar.gz) = e9240dfbcbeca8c60d5f9704d1135e14
-SHA256 (asterisk-addons-1.4.6.tar.gz) = af7c0258837a9f211ecbb58c47cd1a793e943577f37e8e47155e8d07b0c93a73
-SIZE (asterisk-addons-1.4.6.tar.gz) = 798869
+MD5 (asterisk-addons-1.6.0.1.tar.gz) = 40c07612e486160c128e22811f357893
+SHA256 (asterisk-addons-1.6.0.1.tar.gz) = 82970f39075e267b51932d482a8535d77ce91d656bd100b5542ed30970cf7447
+SIZE (asterisk-addons-1.6.0.1.tar.gz) = 846856
diff --git a/net/asterisk16-addons/files/codecnego.diff b/net/asterisk16-addons/files/codecnego.diff
deleted file mode 100644
index 0cfe569b41ea..000000000000
--- a/net/asterisk16-addons/files/codecnego.diff
+++ /dev/null
@@ -1,215 +0,0 @@
---- channels/chan_ooh323.c.orig 2007-07-21 15:17:52.000000000 +0800
-+++ channels/chan_ooh323.c 2008-02-13 15:37:17.000000000 +0800
-@@ -42,8 +42,8 @@
-
-
- /* Channel Definition */
--static struct ast_channel *ooh323_request(const char *type, int format,
-- void *data, int *cause);
-+static struct ast_channel *ooh323_request(const char *type, const struct ast_codec_pref *format, void *data, int *cause);
-+
- static int ooh323_digit_begin(struct ast_channel *ast, char digit);
- static int ooh323_digit_end(struct ast_channel *ast, char digit, unsigned int duration);
- static int ooh323_call(struct ast_channel *ast, char *dest, int timeout);
-@@ -57,8 +57,7 @@
-
- static enum ast_rtp_get_result ooh323_get_rtp_peer(struct ast_channel *chan, struct ast_rtp **rtp);
- static enum ast_rtp_get_result ooh323_get_vrtp_peer(struct ast_channel *chan, struct ast_rtp **rtp);
--static int ooh323_set_rtp_peer(struct ast_channel *chan, struct ast_rtp *rtp,
-- struct ast_rtp *vrtp, int codecs, int nat_active);
-+static int ooh323_set_rtp_peer(struct ast_channel *chan, struct ast_rtp *rtp, struct ast_rtp *vrtp, const struct ast_codec_pref *codecs, int nat_active);
-
- static void print_codec_to_cli(int fd, struct ast_codec_pref *pref);
- static void ast_ooh323c_exit();
-@@ -244,6 +243,7 @@
- {
- struct ast_channel *ch = NULL;
- int fmt;
-+ int cap;
- if(gH323Debug)
- ast_log(LOG_DEBUG, "--- ooh323_new - %s\n", host);
-
-@@ -258,10 +258,11 @@
- ast_mutex_lock(&ch->lock);
- ch->tech = &ooh323_tech;
-
-- ch->nativeformats = i->capability;
--
-+ ast_codec_pref_init(&ch->nativeformats);
-+ ast_codec_pref_append_missing2(&ch->nativeformats, i->capability);
-
-- fmt = ast_best_codec(ch->nativeformats);
-+ cap = ast_codec_pref_bits(&ch->nativeformats);
-+ fmt = ast_best_codec(cap);
-
- ch->fds[0] = ast_rtp_fd(i->rtp);
- ch->fds[1] = ast_rtcp_fd(i->rtp);
-@@ -451,8 +452,7 @@
- /*
- Possible data values - peername, exten/peername, exten@ip
- */
--static struct ast_channel *ooh323_request(const char *type, int format,
-- void *data, int *cause)
-+static struct ast_channel *ooh323_request(const char *type, const struct ast_codec_pref *formats, void *data, int *cause)
-
- {
- struct ast_channel *chan=NULL;
-@@ -461,22 +461,11 @@
- char *dest = NULL;
- char *ext = NULL;
- char tmp[256];
-- char formats[512];
-- int oldformat;
- char *sport = NULL;
- int port = 0;
-
- if(gH323Debug)
-- ast_verbose("--- ooh323_request - data %s format %s\n", (char*)data,
-- ast_getformatname_multiple(formats,512,format) );
--
-- oldformat = format;
-- format &= ((AST_FORMAT_MAX_AUDIO << 1) - 1);
-- if (!format) {
-- ast_log(LOG_NOTICE, "Asked to get a channel of unsupported format "
-- "'%d'\n", format);
-- return NULL;
-- }
-+ ast_verbose("--- ooh323_request - data %s format %s\n", (char*)data, ast_codec_pref_dump(tmp, sizeof(tmp), formats) );
-
- p = ooh323_alloc(0,0); /* Initial callRef is zero */
-
-@@ -536,8 +525,8 @@
- if(ext)
- strncpy(p->exten, ext, sizeof(p->exten)-1);
-
-- if(peer->capability & format)
-- p->capability = peer->capability & format;
-+ if(peer->capability & formats->audio_bits)
-+ p->capability = peer->capability & formats->audio_bits;
- else{
- p->capability = peer->capability;
- }
-@@ -971,11 +960,11 @@
-
- if(f->frametype == AST_FRAME_VOICE)
- {
-- if(!(f->subclass & ast->nativeformats))
-+ if(!(f->subclass & ast->nativeformats.audio_bits))
- {
- ast_log(LOG_WARNING, "Asked to transmit frame type %d, while native "
- "formats is %d (read/write = %d/%d)\n",
-- f->subclass, ast->nativeformats, ast->readformat,
-+ f->subclass, ast->nativeformats.audio_bits, ast->readformat,
- ast->writeformat);
- return 0;
- }
-@@ -2219,12 +2208,12 @@
- int x, codec;
-
- for(x = 0; x < 32 ; x++) {
-- codec = ast_codec_pref_index(pref, x);
-+ codec = ast_codec_pref_index_audio(pref, x);
- if (!codec)
- break;
- ast_cli(fd, "%s", ast_getformatname(codec));
-- ast_cli(fd, ":%d", pref->framing[x]);
-- if (x < 31 && ast_codec_pref_index(pref, x + 1))
-+ ast_cli(fd, ":%d", pref->audio_framing[x]);
-+ if (x < 31 && ast_codec_pref_index_audio(pref, x + 1))
- ast_cli(fd, ",");
- }
- if (!x)
-@@ -3020,13 +3009,13 @@
- (ooCallData *call, struct ast_codec_pref *prefs)
- {
- int i=0;
-- int codec = ast_codec_pref_index(prefs, i);
-+ int codec = ast_codec_pref_index_audio(prefs, i);
-
- ooResetCapPrefs(call);
- while(codec)
- {
- ooAppendCapToCapPrefs(call, ooh323_convertAsteriskCapToH323Cap(codec));
-- codec = ast_codec_pref_index(prefs, ++i);
-+ codec = ast_codec_pref_index_audio(prefs, ++i);
- }
-
- return 0;
-@@ -3058,7 +3047,7 @@
-
- static int ooh323_set_rtp_peer
- (struct ast_channel *chan, struct ast_rtp *rtp, struct ast_rtp *vrtp,
-- int codecs, int nat_active)
-+ const struct ast_codec_pref *codecs, int nat_active)
- {
- /* XXX Deal with Video */
- struct ooh323_pvt *p;
-@@ -3106,7 +3095,7 @@
- strncpy(mediaInfo.lMediaIP, ast_inet_ntoa(us.sin_addr), sizeof(mediaInfo.lMediaIP)-1);
- mediaInfo.lMediaPort = ntohs(us.sin_port);
- mediaInfo.lMediaCntrlPort = mediaInfo.lMediaPort +1;
-- for(x=0; 0 != (format=ast_codec_pref_index(&p->prefs, x)); x++)
-+ for(x=0; 0 != (format=ast_codec_pref_index_audio(&p->prefs, x)); x++)
- {
- strcpy(mediaInfo.dir, "transmit");
- mediaInfo.cap = ooh323_convertAsteriskCapToH323Cap(format);
-@@ -3250,10 +3239,11 @@
- /* We already hold the channel lock */
- if (f->frametype == AST_FRAME_VOICE)
- {
-- if (f->subclass != p->owner->nativeformats)
-+ if (!(f->subclass & p->owner->nativeformats.audio_bits))
- {
- ast_log(LOG_DEBUG, "Oooh, format changed to %d\n", f->subclass);
-- p->owner->nativeformats = f->subclass;
-+ ast_codec_pref_append(&p->owner->nativeformats, f->subclass);
-+ p->capability |= f->subclass;
- ast_set_read_format(p->owner, p->owner->readformat);
- ast_set_write_format(p->owner, p->owner->writeformat);
- }
---- channels/ooh323cDriver.c.orig 2007-01-20 06:27:05.000000000 +0800
-+++ channels/ooh323cDriver.c 2008-02-11 16:47:24.000000000 +0800
-@@ -66,7 +66,7 @@
- if(gH323Debug)
- ast_verbose("\tAdding capabilities to H323 endpoint\n");
-
-- for(x=0; 0 != (format=ast_codec_pref_index(prefs, x)); x++)
-+ for(x=0; 0 != (format=ast_codec_pref_index_audio(prefs, x)); x++)
- {
- if(format & AST_FORMAT_ULAW)
- {
-@@ -172,14 +172,14 @@
- ret |= ooCallEnableDTMFH245Signal(call);
-
-
-- for(x=0; 0 !=(format=ast_codec_pref_index(prefs, x)); x++)
-+ for(x=0; 0 !=(format=ast_codec_pref_index_audio(prefs, x)); x++)
- {
- if(format & AST_FORMAT_ULAW)
- {
- if(gH323Debug)
- ast_verbose("\tAdding g711 ulaw capability to call(%s, %s)\n",
- call->callType, call->callToken);
-- txframes = prefs->framing[x];
-+ txframes = prefs->audio_framing[x];
- ret= ooCallAddG711Capability(call, OO_G711ULAW64K, txframes,
- grxframes, OORXANDTX,
- &ooh323c_start_receive_channel,
-@@ -192,7 +192,7 @@
- if(gH323Debug)
- ast_verbose("\tAdding g711 alaw capability to call(%s, %s)\n",
- call->callType, call->callToken);
-- txframes = prefs->framing[x];
-+ txframes = prefs->audio_framing[x];
- ret= ooCallAddG711Capability(call, OO_G711ALAW64K, txframes,
- grxframes, OORXANDTX,
- &ooh323c_start_receive_channel,
-@@ -206,7 +206,7 @@
- if(gH323Debug)
- ast_verbose("\tAdding g729A capability to call(%s, %s)\n",
- call->callType, call->callToken);
-- txframes = (prefs->framing[x])/10;
-+ txframes = (prefs->audio_framing[x])/10;
- ret= ooCallAddG729Capability(call, OO_G729A, txframes, 24,
- OORXANDTX, &ooh323c_start_receive_channel,
- &ooh323c_start_transmit_channel,
diff --git a/net/asterisk16-addons/files/patch-Makefile b/net/asterisk16-addons/files/patch-Makefile
index 4bcc7f4e3115..c72ec60cbf09 100644
--- a/net/asterisk16-addons/files/patch-Makefile
+++ b/net/asterisk16-addons/files/patch-Makefile
@@ -1,11 +1,14 @@
---- Makefile.orig Thu Feb 14 00:58:11 2008
-+++ Makefile Fri Feb 22 19:17:58 2008
-@@ -27,7 +27,7 @@
- # Overwite config files on "make samples"
- OVERWRITE:=y
-
--ASTCFLAGS+=-fPIC
-+ASTCFLAGS+=-fPIC -I${PREFIX}/include
+--- Makefile.orig 2008-09-12 18:21:53.000000000 +0000
++++ Makefile 2009-02-17 12:48:55.000000000 +0000
+@@ -26,7 +26,9 @@
+ ASTTOPDIR:=$(subst $(space),\$(space),$(CURDIR))
- #NOISY_BUILD=yes
+ # Overwite config files on "make samples"
+-OVERWRITE:=y
++OVERWRITE:=n
++
++ASTCFLAGS+=-I${LOCALBASE}/include
+ # If the file .asteriskaddons.makeopts is present in your home directory, you can
+ # include all of your favorite menuselect options so that every time you download
+
diff --git a/net/asterisk16-addons/files/patch-Makefile.rules b/net/asterisk16-addons/files/patch-Makefile.rules
new file mode 100644
index 000000000000..1378bba0c325
--- /dev/null
+++ b/net/asterisk16-addons/files/patch-Makefile.rules
@@ -0,0 +1,12 @@
+--- Makefile.rules.orig 2009-02-17 13:27:59.000000000 +0000
++++ Makefile.rules 2009-02-17 13:28:21.000000000 +0000
+@@ -38,7 +38,9 @@
+ # ppro's, etc, as well as the AMD K6 and K7.
+ #K6OPT=-DK6OPT
+
++ifneq ($(OSARCH),FreeBSD)
+ OPTIMIZE?=-O6
++endif
+ ASTCFLAGS+=$(OPTIMIZE)
+ endif
+