aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-12-02 12:53:33 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-12-02 12:53:33 +0000
commit3175500de54ed50410dd707754327b6027a6892b (patch)
tree58230cbeb55633838ea49c496f776343cfc818c9
parent214ba76e5f82551b4551d93f6127768e1a63b58d (diff)
downloadports-3175500de54ed50410dd707754327b6027a6892b.tar.gz
ports-3175500de54ed50410dd707754327b6027a6892b.zip
Notes
-rw-r--r--mail/roundcube/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index 3f24fd1f5cbd..0097a474e46a 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -34,7 +34,13 @@ SCRIPTS_ENV= SHAREOWN=${SHAREOWN} SHAREGRP=${SHAREGRP} \
WWWOWN=${WWWOWN} WWWGRP=${WWWGRP} \
RCUBEROOT=${RCUBEROOT}
-WANT_PHP_MOD= yes
+WANT_PHP_WEB= yes
+
+OPTIONS= MYSQL "Use MySQL backend" on \
+ PGSQL "Use PostgreSQL backend" off \
+ SQLITE "Use SQLite backend" off
+
+.include <bsd.port.pre.mk>
.if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
@@ -48,6 +54,8 @@ USE_PHP+= pgsql
USE_PHP+= sqlite
.endif
+.include "${PORTSDIR}/Mk/bsd.php.mk"
+
do-install:
${MKDIR} ${RCUBEROOT}
.for i in ${RCUBECOMP}
@@ -65,4 +73,4 @@ post-install:
@${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>