aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-06 20:04:42 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-06 20:04:42 +0000
commit385e80837528fa36a74d20af49f2424f8c741518 (patch)
tree4235167536133afa6763b41fb72a44778d75dbb8
parent6c52274886089a1c02450cdba93e2b0f1f37fec0 (diff)
downloadports-385e80837528fa36a74d20af49f2424f8c741518.tar.gz
ports-385e80837528fa36a74d20af49f2424f8c741518.zip
Notes
-rw-r--r--x11-wm/metacity/Makefile1
-rw-r--r--x11-wm/metacity/files/patch-src_window.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index 8a7da39e3f8a..0acb85b419d4 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -7,6 +7,7 @@
PORTNAME= metacity
PORTVERSION= 2.8.2
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
diff --git a/x11-wm/metacity/files/patch-src_window.c b/x11-wm/metacity/files/patch-src_window.c
new file mode 100644
index 000000000000..5e4ef9d96845
--- /dev/null
+++ b/x11-wm/metacity/files/patch-src_window.c
@@ -0,0 +1,13 @@
+--- src/window.c 31 Jul 2004 21:26:05 -0000 1.333
++++ src/window.c 4 Aug 2004 15:55:42 -0000
+@@ -1619,6 +1619,11 @@ window_takes_focus_on_map (MetaWindow *w
+ case META_WINDOW_NORMAL:
+ case META_WINDOW_DIALOG:
+ case META_WINDOW_MODAL_DIALOG:
++ /* Don't do focus stealing stuff; lame cop-out while we work on
++ * fixing http://bugzilla.gnome.org/show_bug.cgi?id=149028
++ */
++ return TRUE;
++
+ if (window->focus_despite_user_time)
+ return TRUE;