aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-12 00:27:08 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-12 00:27:08 +0000
commit3afabb25ea1a4d99b049aba4aff005f5bc8c96aa (patch)
tree33c9ba55005184cd82963fb494a85b5cb2c992ff
parentba422e29b73898282fa8ceee2dd6e92ec239e116 (diff)
downloadports-3afabb25ea1a4d99b049aba4aff005f5bc8c96aa.tar.gz
ports-3afabb25ea1a4d99b049aba4aff005f5bc8c96aa.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-AxKit-XSP-Sendmail/Makefile28
-rw-r--r--www/p5-AxKit-XSP-Sendmail/distinfo1
-rw-r--r--www/p5-AxKit-XSP-Sendmail/pkg-comment1
-rw-r--r--www/p5-AxKit-XSP-Sendmail/pkg-descr3
-rw-r--r--www/p5-AxKit-XSP-Sendmail/pkg-plist6
6 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index acbe97bc8cf3..927664f607e4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -240,6 +240,7 @@
SUBDIR += p5-AxKit-XSP-IfParam
SUBDIR += p5-AxKit-XSP-Param
SUBDIR += p5-AxKit-XSP-PerForm
+ SUBDIR += p5-AxKit-XSP-Sendmail
SUBDIR += p5-AxKit-XSP-Util
SUBDIR += p5-CGI-Application
SUBDIR += p5-CGI-ArgChecker
diff --git a/www/p5-AxKit-XSP-Sendmail/Makefile b/www/p5-AxKit-XSP-Sendmail/Makefile
new file mode 100644
index 000000000000..d7e18de66efd
--- /dev/null
+++ b/www/p5-AxKit-XSP-Sendmail/Makefile
@@ -0,0 +1,28 @@
+# Ports collection Makefile for: p5-AxKit-XSP-Sendmail
+# Date created: 8 Jan 2002
+# Whom: dom@happygiraffe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= AxKit-XSP-Sendmail
+PORTVERSION= 1.4
+CATEGORIES= www
+MASTER_SITES= http://www.cpan.org/authors/id/M/MS/MSERGEANT/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/AxKit.pm:${PORTSDIR}/www/p5-AxKit \
+ ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ ${SITE_PERL}/Email/Valid.pm:${PORTSDIR}/mail/p5-Email-Valid
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= AxKit::XSP::Sendmail.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/www/p5-AxKit-XSP-Sendmail/distinfo b/www/p5-AxKit-XSP-Sendmail/distinfo
new file mode 100644
index 000000000000..12c2c25d6853
--- /dev/null
+++ b/www/p5-AxKit-XSP-Sendmail/distinfo
@@ -0,0 +1 @@
+MD5 (AxKit-XSP-Sendmail-1.4.tar.gz) = c20df24c58af7c733b05f9cc9e7bb99d
diff --git a/www/p5-AxKit-XSP-Sendmail/pkg-comment b/www/p5-AxKit-XSP-Sendmail/pkg-comment
new file mode 100644
index 000000000000..f4d1c35e5aca
--- /dev/null
+++ b/www/p5-AxKit-XSP-Sendmail/pkg-comment
@@ -0,0 +1 @@
+Simple SMTP mailer tag library for AxKit eXtesible Server Pages.
diff --git a/www/p5-AxKit-XSP-Sendmail/pkg-descr b/www/p5-AxKit-XSP-Sendmail/pkg-descr
new file mode 100644
index 000000000000..a041c3b3ca13
--- /dev/null
+++ b/www/p5-AxKit-XSP-Sendmail/pkg-descr
@@ -0,0 +1,3 @@
+This perl module provides mail sending support for AxKit XSP's.
+
+WWW: http://search.cpan.org/search?dist=AxKit-XSP-Sendmail
diff --git a/www/p5-AxKit-XSP-Sendmail/pkg-plist b/www/p5-AxKit-XSP-Sendmail/pkg-plist
new file mode 100644
index 000000000000..cad6a9736c76
--- /dev/null
+++ b/www/p5-AxKit-XSP-Sendmail/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/AxKit/XSP/Sendmail.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/AxKit/XSP/Sendmail/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/AxKit/XSP/Sendmail
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/AxKit/XSP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/AxKit/XSP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/AxKit 2>/dev/null || true